Page 1 of 1

Support for 'Fastmail' themes.

Posted: 2020-11-04, 11:16
by Spudozo
Hello,

Not the end of the world but I cannot alter themes anymore in Fastmail and they say:

"Unfortunately, your browser doesn't support the technologies we now use to add theme support,
specifically CSS custom properties and JavaScript dynamic import"

I note that there is a userchrome.css hack (is that the correct terminology?).
Would this solve the issue assuming I can undertake such a daunting task? :)

Thanks.

Re: Support for 'Fastmail' themes.

Posted: 2021-04-08, 12:03
by duskull
A little update regarding this problem. I had a ticket open at Fastmail support and they told me that Palemoon does not support "CSS custom properties and dynamic import of ES modules" properly. They also told me that the latest version version of Palemoon is based on Firefox 38 ESR, which I know is not true any longer of course, but due to that they cannot support this browser. Like @Spudozo mentioned, is there a hack we can use to get back the theming support, which was there a few months ago, so sad to see it go away. :wtf:

Re: Support for 'Fastmail' themes.

Posted: 2021-04-08, 12:52
by New Tobin Paradigm
While it is true our ES Modules support doesn't have all the latest shinys we do have basic support in the platform well beyond UXP's esr52's original support. We also support custom css properties.

So basicly whomever told you that likely never went beyond a Firefox version and Pale Moon google search and almost certainly never bothered to test Pale Moon. That and given that their functionality existed before they refactored it to use whatever Chrome-focused junk today just demonstrates they don't give a shit. Not about their users or the health and well being of the web.

In the face of all that, perhaps you should considet not using them. They obviously don't care enough to retain you as a user that they lie to you either out of ignorance or intentionally thinking you'd never follow up and investigate.