Palemoon doesn't show no longer videos from youtube Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
Michel
Moongazer
Moongazer
Posts: 10
Joined: 2018-12-03, 18:36

Palemoon doesn't show no longer videos from youtube

Post by Michel » 2020-10-31, 18:00

After updating to 28.15.0 Palemoon doesn't play videos from yt on my Linux-PC with Kernel 5.9.1-1 and KDE-Plasma on OpenSuSE Tumbleweed.

As Firefox, Konqueror and Vivaldi have no problems with these Formats, i guess, that the problem is on Palemoon.

Does anybody know a solution?

Thanks.

Bye.

Michael
OpenSuSE Tumbleweed - KDE Plasma

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1585
Joined: 2015-09-30, 23:02
Location: uk.

Re: Palemoon doesn't show no longer videos from youtube

Post by Moonraker » 2020-10-31, 18:30

I use linux and youtube videos work with pale moon.
Xenial puppy linux 32-bit.

Pale moon 28.15.0

vannilla
Board Warrior
Board Warrior
Posts: 1274
Joined: 2018-05-05, 13:29

Re: Palemoon doesn't show no longer videos from youtube

Post by vannilla » 2020-10-31, 19:47

Use an invidious instance or Freetube.
Row row fight the power.

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1585
Joined: 2015-09-30, 23:02
Location: uk.

Re: Palemoon doesn't show no longer videos from youtube

Post by Moonraker » 2020-10-31, 19:50

vannilla wrote:
2020-10-31, 19:47
Use an invidious instance or Freetube.
Row row fight the power.
Invidious was too resource intensive for my liking.
Xenial puppy linux 32-bit.

Pale moon 28.15.0

User avatar
Michel
Moongazer
Moongazer
Posts: 10
Joined: 2018-12-03, 18:36

Re: Palemoon doesn't show no longer videos from youtube

Post by Michel » 2020-10-31, 22:11

@moonraker:

The Youtube-stuff worked fine at my last version before this new update, e.g. til yesterday.

As one can see, You work with an older version, which worked find at my system too.

Try the update and report...

Bye
Michael
OpenSuSE Tumbleweed - KDE Plasma

vannilla
Board Warrior
Board Warrior
Posts: 1274
Joined: 2018-05-05, 13:29

Re: Palemoon doesn't show no longer videos from youtube

Post by vannilla » 2020-10-31, 22:23

Well, with 28.15.0 it works on my end, so I'd really say it's either something on your end, or the video itself has some properties that are incompatible with Pale Moon (like in viewtopic.php?f=3&t=25403&p=201647#p201417 ).
The video I tried (some trash italian rap that was popular long ago due to its trashiness): https://www.youtube.com/watch?v=adQrPESgQ_M
See if it works for you too; shouldn't be region locked.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4415
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Palemoon doesn't show no longer videos from youtube

Post by Night Wing » 2020-10-31, 22:43

I know on the Linux Mint forums, there has been some discussion on the kernel 5.9 and most say it is brand new and might not work on some people's hardware and get along with their software. Some on the Mint forums consider kernel 5.9 to be "bleeding edge".

As for me, I'm using kernel 5.4.0-52-generic, which is supported until April of 2025 and I have no problems when viewing YouTube videos.

At this time, I'm using 64 bit linux Pale Moon 28.15.0 running in linux Mint 20 (Ulyana) Xfce. The only extensions I use are NoSquint and uBlock Origin with UBO enabled for YouTube.
Linux Mint 20 (Ulyana) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2319
Joined: 2012-06-28, 01:20

Re: Palemoon doesn't show no longer videos from youtube

Post by ron_1 » 2020-10-31, 23:07

Youtube still works for me. Pale Moon 28.15.0 and Devuan GNU/Linux 2.1.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 690
Joined: 2015-08-01, 18:33
Location: California

Re: Palemoon doesn't show no longer videos from youtube

Post by stevepusser » 2020-11-01, 05:28

Also works fine here on MX Linux 19 -- Pale Moon 28.15.0 from the MX Repo.

User avatar
Michel
Moongazer
Moongazer
Posts: 10
Joined: 2018-12-03, 18:36

Re: Palemoon doesn't show no longer videos from youtube

Post by Michel » 2020-11-01, 07:37

Hi all,

thanks for your response. I don't think, that the kernel makes the problem, as other browsers work fine and without problems.

I think, for me palemoon is done, if will have to go back to Firefox.

Bye
Michael
OpenSuSE Tumbleweed - KDE Plasma

User avatar
moonbat
Moon Magic practitioner
Moon Magic practitioner
Posts: 2396
Joined: 2015-12-09, 15:45

Re: Palemoon doesn't show no longer videos from youtube

Post by moonbat » 2020-11-01, 09:03

Michel wrote:
2020-11-01, 07:37
Hi all,

thanks for your response. I don't think, that the kernel makes the problem, as other browsers work fine and without problems.

I think, for me palemoon is done, if will have to go back to Firefox.

Bye
Michael
If you're still around, provide an example of a video that works for you in the other browsers but not Pale Moon. If there's anything DRM enabled, it won't play because Pale Moon doesn't support DRM.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 20 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
Advanced URL Builder(fork)|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

User avatar
Michel
Moongazer
Moongazer
Posts: 10
Joined: 2018-12-03, 18:36

Re: Palemoon doesn't show no longer videos from youtube

Post by Michel » 2020-11-01, 11:21

Hi,

the following video of a friends model-sailplane doesn't work for example:

https://www.youtube.com/watch?v=oKuh9LRbCZY&t=174s

Screenshot:
https://highlaender.bplaced.net/michels ... 120742.jpg

The error-message means:
"Your browser does not currently recognize any of the available video formats.
Click here for our HTML5 Video FAQ."


Screenshot of Firefox and the same video:
https://highlaender.bplaced.net/michels ... 120927.jpg
OpenSuSE Tumbleweed - KDE Plasma

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28495
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Palemoon doesn't show no longer videos from youtube

Post by Moonchild » 2020-11-01, 11:27

Well it's definitely working on Windows, so we can rule out DRM.
That leaves having the correct codecs available on your Linux system, which I can't personally help with.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4415
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Palemoon doesn't show no longer videos from youtube

Post by Night Wing » 2020-11-01, 12:03

@ Michel

I clicked on you sailplane video link and it plays for me without any problems in my 64 bit linux Pale Moon 28.15.0 so the problem could be related to your codecs when using your openSuse Tumbleweed distro.
Linux Mint 20 (Ulyana) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1585
Joined: 2015-09-30, 23:02
Location: uk.

Re: Palemoon doesn't show no longer videos from youtube

Post by Moonraker » 2020-11-01, 12:08

The video works perfectly for me..i use puppy linux 32bit.
Have you got the following codecs installed..?
libavcodec-ffmpeg
libavcodec-ffmpeg-extra.
Xenial puppy linux 32-bit.

Pale moon 28.15.0

User avatar
Michel
Moongazer
Moongazer
Posts: 10
Joined: 2018-12-03, 18:36

Re: Palemoon doesn't show no longer videos from youtube

Post by Michel » 2020-11-01, 15:33

Hello,

the codecs were installed, they have different names on OpenSuSE (libavcodec56, ...57 and ...58 and identical libavdevice with the same numbers. It took some time to figure out that.

As last maybe possible solution i deleted Palemoon from the Computer, started the System new and installed Palemoon new.

Now the videos run. I don't know, what the error was.

As i mentioned, the errorfree running of the videos on other browsers on Linux made missing codecs impropable.

This error of a propably faulty software-installation is the first of it's kind in my now 19 Years of Linux (completely without MS-Windows)...

Thanks for Your help.
Have a nice day.
Greetings from rainy Bavaria/Germany.
Michael
OpenSuSE Tumbleweed - KDE Plasma

Post Reply