Ctrl+Shift+a - Bug?

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
fatboy
Lunatic
Lunatic
Posts: 284
Joined: 2017-12-19, 08:03

Ctrl+Shift+a - Bug?

Post by fatboy » 2020-10-01, 17:41

Good Day Folks,

I am running the extracted tarball Pale Moon version 28.14.1 (64 bit) on Arch Linux.
Not sure what is happening here, but sometimes, when I have one blank tab open the shortcut key for add-ons (Ctrl+Shift+a) is unresponsive. Then when I open a second tab, press C+S+a again, the browser responds.
Here is what I am seeing:
Palemoon_error.png
I also spotted this at the bottom of my error console:
Palemoon_error_2.png
I cleared the browser cache, closed the browser, re-opened it. Repeated the procedure above by pressing C+S+a (but this time PM responded as expected). This is what I got in the error console:
Palemoon_error_3.png
I hope this info helps.
Systemd Free - PCLINUXOS & Artix Linux

vannilla
Board Warrior
Board Warrior
Posts: 1186
Joined: 2018-05-05, 13:29

Re: Ctrl+Shift+a - Bug?

Post by vannilla » 2020-10-01, 18:12

I had this happen a few times prior to 28.14, and if I remember correctly it was because the UI wasn't focused according to the window manager definition of focus, so there was no keyboard input or anyway the keybindings set by the UI weren't working.
When it happens again try clicking anywhere on an empty space, rather than opening a new tab, and see if it works. If it does it's not really a Pale Moon issue.

User avatar
fatboy
Lunatic
Lunatic
Posts: 284
Joined: 2017-12-19, 08:03

Re: Ctrl+Shift+a - Bug?

Post by fatboy » 2020-10-02, 07:40

OK Cool, I will make sure that PM is focused when I execute the shortcut again, but I think you are right. The windows was maybe unfocused.
Systemd Free - PCLINUXOS & Artix Linux

Post Reply