I need version 28.12.0-2 and Language Pack Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
Craftsman
Moongazer
Moongazer
Posts: 11
Joined: 2020-02-10, 11:31

I need version 28.12.0-2 and Language Pack

Post by Craftsman » 2020-09-06, 13:16

Hi,

I am using Debian 9 / 64 bit.
Where can I get the version 28.12.0-2 /64 bit and the Language Pack for it?

They are missing here:
http://archive.palemoon.org/palemoon/28.x/
http://archive.palemoon.org/palemoon/langpacks/28.x/

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2476
Joined: 2015-09-26, 04:51
Location: U.S.

Re: I need version 28.12.0-2 and Language Pack

Post by coffeebreak » 2020-09-06, 14:54

28.12.0 does not appear to have been archived (or archived yet).

(There is no "-2" version among the linux binaries distributed directly by this project.)

Why do you want to downgrade from 28.13.0?

Edit:
Btw, If you are using Steve Pusser's builds and the problem is this, please wait for him to post a corrected build of 28.13.0, or else use the binaries for 28.13.0 published by this project.
Last edited by coffeebreak on 2020-09-06, 15:14, edited 1 time in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 27893
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: I need version 28.12.0-2 and Language Pack

Post by Moonchild » 2020-09-06, 15:10

Sounds like I should just shut down the archive server because people keep defaulting to it when they should be looking elsewhere.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2476
Joined: 2015-09-26, 04:51
Location: U.S.

Re: I need version 28.12.0-2 and Language Pack

Post by coffeebreak » 2020-09-06, 15:16

Moonchild wrote:
2020-09-06, 15:10
shut down the archive server
Off-topic:
I hope you don't.

Can't say that I've seen this kind of thing happen frequently.
Please don't punish everyone because of the occasional ignorant post.

User avatar
Craftsman
Moongazer
Moongazer
Posts: 11
Joined: 2020-02-10, 11:31

Re: I need version 28.12.0-2 and Language Pack

Post by Craftsman » 2020-09-06, 15:52

I used version 28.12.0-2 successfully before. This version worked great!
She's on this list bottom, look at him.
I did a Debian update yesterday.
Palemoon has also been updated to version 28.13.0-1.

And I immediately lost the performance of several addons.
These are very important addons for me:

Incompatble Add-ons 2020-09-06.png

This upset me very much :-(
So I want to go back to version 28.12.0-2 to get the important addons working again.

------------------------

Code: Select all

Commit Log for Sat Sep  5 13:46:00 2020

These packages have been updated:
bind9-host (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
dnsutils (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libbind9-140 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libdns-export162 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libdns162 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libfreerdp-common1.1.0 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libfreerdp-plugins-standard (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libfreerdp-utils1.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libisc-export160 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libisc160 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libisccc140 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libisccfg140 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
liblwres141 (1:9.10.3.dfsg.P4-12.3+deb9u6) to 1:9.10.3.dfsg.P4-12.3+deb9u7
libopenexr22 (2.2.0-11+b1) to 2.2.0-11+deb9u1
libvncclient1 (0.9.11+dfsg-1.3~deb9u4) to 0.9.11+dfsg-1.3~deb9u5
libvncserver1 (0.9.11+dfsg-1.3~deb9u4) to 0.9.11+dfsg-1.3~deb9u5
libwinpr-crt0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-environment0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-file0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-handle0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-heap0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-interlocked0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-library0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-path0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-synch0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-sysinfo0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-thread0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libwinpr-utils0.1 (1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3) to 1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4
libx11-6 (2:1.6.4-3+deb9u2) to 2:1.6.4-3+deb9u3
libx11-data (2:1.6.4-3+deb9u2) to 2:1.6.4-3+deb9u3
libx11-dev (2:1.6.4-3+deb9u2) to 2:1.6.4-3+deb9u3
libx11-xcb-dev (2:1.6.4-3+deb9u2) to 2:1.6.4-3+deb9u3
libx11-xcb1 (2:1.6.4-3+deb9u2) to 2:1.6.4-3+deb9u3
     palemoon  (28.12.0-2) to 28.13.0-1
xserver-common (2:1.19.2-1+deb9u5) to 2:1.19.2-1+deb9u6
xserver-xorg-core (2:1.19.2-1+deb9u5) to 2:1.19.2-1+deb9u6
xserver-xorg-legacy (2:1.19.2-1+deb9u5) to 2:1.19.2-1+deb9u6

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2476
Joined: 2015-09-26, 04:51
Location: U.S.

Re: I need version 28.12.0-2 and Language Pack

Post by coffeebreak » 2020-09-06, 16:29

Craftsman wrote:
2020-09-06, 15:52
I used version 28.12.0-2 successfully before.
The Pale Moon project does not distribute the binaries you use.
It cannot help you go back to 28.12.0-2.

It sounds like you use the builds by Steve Pusser.
There was a mistake made in the build process for those builds. You must wait for him to put out a corrected build, and then update again. When it is published, he will likely announce it in his own thread. Focus your attention there.

Or as said before...
As an alternative use the binary that this project publishes for 28.13.0.
It will not cause that problem with the extensions.

User avatar
Craftsman
Moongazer
Moongazer
Posts: 11
Joined: 2020-02-10, 11:31

Re: I need version 28.12.0-2 and Language Pack

Post by Craftsman » 2020-09-06, 17:44

Ok. For updating Debian and Pale Moon I have always used such repositories:

Code: Select all

deb http://deb.debian.org/debian/ stretch main stretch-backports
deb http://security.debian.org/debian-security/ stretch/updates main contrib
How can I change the repository to always use your PaleMoon?

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7876
Joined: 2012-10-09, 19:37
Location: Space, maybe..

Re: I need version 28.12.0-2 and Language Pack

Post by New Tobin Paradigm » 2020-09-06, 18:16

Remove the package and then grab the generic binary extract to a suitable writable location and use it
Image
- Mars will never be free until the sands run red with Earther blood! -

Image

User avatar
Craftsman
Moongazer
Moongazer
Posts: 11
Joined: 2020-02-10, 11:31

Re: I need version 28.12.0-2 and Language Pack

Post by Craftsman » 2020-09-06, 19:35

But then I will lose my profiles, bookmarks and history?

And the same question: don't you have any repositories PaleMoon for Debian?

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7876
Joined: 2012-10-09, 19:37
Location: Space, maybe..

Re: I need version 28.12.0-2 and Language Pack

Post by New Tobin Paradigm » 2020-09-06, 20:40

Ignorance.
Image
- Mars will never be free until the sands run red with Earther blood! -

Image

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2262
Joined: 2012-06-28, 01:20

Re: I need version 28.12.0-2 and Language Pack

Post by ron_1 » 2020-09-07, 00:00

Craftsman wrote:
2020-09-06, 19:35
But then I will lose my profiles, bookmarks and history?
No. But if you are concerned about it, back the profile up.
Craftsman wrote:
2020-09-06, 19:35
And the same question: don't you have any repositories PaleMoon for Debian?
No, there's just Steve's. And it's Pale Moon, two words. ;)
Last edited by ron_1 on 2020-09-07, 09:58, edited 1 time in total.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 666
Joined: 2015-08-01, 18:33
Location: California

Re: I need version 28.12.0-2 and Language Pack

Post by stevepusser » 2020-09-07, 03:18

Craftsman wrote:
2020-09-06, 17:44
Ok. For updating Debian and Pale Moon I have always used such repositories:

Code: Select all

deb http://deb.debian.org/debian/ stretch main stretch-backports
deb http://security.debian.org/debian-security/ stretch/updates main contrib
How can I change the repository to always use your PaleMoon?
You must have added my OBS repo, since PM is nowhere in the Debian repositories. The instructions
for my repo don't add it to the regular sources.list file. If you want to see where it lives, install "inxi"
and run "inxi -r" in the terminal.

I tracked down my build problems to a corrupted source download and a missing option to keep those extensions working in the build configuration file that I missed. The builds are now working, so check here to see when they finish:

https://build.opensuse.org/package/show ... r/palemoon

Post Reply