https://alvey.com.au/category/reels locks up DE

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

https://alvey.com.au/category/reels locks up DE

Post by Lunokhod » 2020-08-08, 20:25

I'm guessing this is a Linux probably hardware specific issue from the result, if not move the post. :D On that page it starts loading, then the pointer and everything stops responding, switching tty is not possible and I have to press and hold the power button to forcibly shut down. It's the same in a fresh profile. The page works with Chromium.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 8073
Joined: 2012-10-09, 19:37
Location: I'm.. over there.

Re: https://alvey.com.au/category/reels locks up DE

Post by New Tobin Paradigm » 2020-08-08, 20:39

Sure does chug along initially but doesn't slow down or lock up the UI thread on a trunk build on my system.

My guess is on lessor hardware it might stall and lockup for a bit.
Your computer has too much computer in it and not enough typewriter.
Image

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: https://alvey.com.au/category/reels locks up DE

Post by Lunokhod » 2020-08-08, 21:15

I gave it 5 or 10 minutes - it was slow loading on Chromium. But in Pale Moon it never completed, the page starts out working fine, the first time I got as far as scrolling down and clicking the link for the next page before it stopped, and I thought that was the problem. Plus I was playing audio on YT which kept playing, even though everything had stopped responding to any input, so there was some CPU to spare for that. But next time after rebooting in a clean profile with no other apps or tabs open I waited for it to load then it locked up on it's own. It's a bit old HW but still the lastest fastest mobile C2D, this is more than a bit slow on loading here. :D. Usually it's some graphics bug being triggered that gives a DE lockup.

Code: Select all

$ sudo inxi -v3z
System:    Kernel: 5.7.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Xfce 4.14.2 Distro: Artix Linux 
Machine:   Type: Portable System: Dell product: Precision M4400 v: N/A serial: <filter> 
           Mobo: Dell model: 0NY980 serial: <filter> BIOS: Dell v: A29 date: 06/04/2013 
Battery:   ID-1: BAT0 charge: 69.7 Wh condition: 69.7/73.3 Wh (95%) model: Sanyo DELL U726H8A status: Full 
CPU:       Topology: Dual Core model: Intel Core2 Duo T9900 bits: 64 type: MCP arch: Penryn rev: A L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 bogomips: 12236 
           Speed: 798 MHz min/max: 800/3068 MHz Core speeds (MHz): 1: 1155 2: 1504 
Graphics:  Device-1: NVIDIA G96GLM [Quadro FX 770M] vendor: Dell driver: nouveau v: kernel bus ID: 01:00.0 
           Display: server: X.Org 1.20.8 driver: nouveau unloaded: fbdev,modesetting,vesa resolution: 1440x900~60Hz 
           OpenGL: renderer: NV96 v: 3.3 Mesa 20.1.5 direct render: Yes 
Network:   Device-1: Intel 82567LM Gigabit Network vendor: Dell driver: e1000e v: 3.2.6-k port: efe0 bus ID: 00:19.0 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Ralink RT2760 Wireless 802.11n 1T/2R vendor: Belkin driver: rt2800pci v: 2.3.0 port: df00 bus ID: 04:00.0 
           IF: wlp4s0 state: up mac: <filter> 
           Device-3: Intel Ultimate N WiFi Link 5300 driver: iwlwifi v: kernel port: df00 bus ID: 0c:00.0 
           IF: wlp12s0 state: down mac: <filter> 
Drives:    Local Storage: total: 111.79 GiB used: 38.54 GiB (34.5%) 
Info:      Processes: 205 Uptime: 50m Memory: 7.76 GiB used: 1.67 GiB (21.5%) Init: N/A rc: OpenRC v: 0.42.1 runlevel: default 
           Compilers: gcc: 10.1.0 clang: 10.0.1 Packages: 958 Shell: Bash v: 5.0.17 inxi: 3.1.05 

vannilla
Board Warrior
Board Warrior
Posts: 1193
Joined: 2018-05-05, 13:29

Re: https://alvey.com.au/category/reels locks up DE

Post by vannilla » 2020-08-08, 23:19

If you use a lighterweight graphical environment (or even plain X :o ) does it lock up?
I mean stuff like dwm where only the most minimum is done.
You don't have to use that stuff, just test it out.

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: https://alvey.com.au/category/reels locks up DE

Post by Lunokhod » 2020-08-09, 02:14

I tried dwm, and it did lock up just the same. I left it for 15 minutes and it still wouldn't work. The mouse pointer was on a terminal window when it stopped, after a few seconds it changed from an arrow to a I cursor, but other than that nothing happened after the initial stop. Then back with XFCE in a clean profile I toggled the 2 "wasm" prefs in about:config to false as they have recently changed, but there was no difference. Then I tried with the console open. Leaving the page at the top, it seemed to load OK and kept working, eventually showing "done" in the status bar and the final entries were a couple of "post" things. Then when I scrolled down it stayed normal, until I came to a line of fishing reels that had one of the pictures missing, When I got to that, it froze up again. This is in the unstable Pale Moon btw, I haven't tried the stable one to compare that.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28159
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: https://alvey.com.au/category/reels locks up DE

Post by Moonchild » 2020-08-09, 13:11

Well it's wordpress with broken resource loading which prevents certain libs from being loaded.
The culprit seems to be this:

Code: Select all

document.write( "<script src="/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr" + "ipt>" );
using double quotes in the string you are trying to write doesn't work if you delimit it with double quotes.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: https://alvey.com.au/category/reels locks up DE

Post by Lunokhod » 2020-08-09, 20:05

I have emailed the Alvey website to let them know, thank you.

Post Reply