eBay 200 item search often misses "to" price

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

eBay 200 item search often misses "to" price

Post by Lunokhod » 2020-06-05, 01:46

On eBay if I search for say "hdmi lead" as a Buy it now and filter according to price then I get zillions of results saying 0.99 to 99.99 or whatever. All the "to" results are multi listings invariably containing some cheap widget that isn't an hdmi lead for 0.99 and would actually charge 99.99 etc for a lead. So I hit 200 listings per page at the bottom and start scrolling though pages looking for ads that are just a single price and not multi listings as a shortcut. :coffee: But often the "to 99.99" bit gets missed out so they all say "0.99" on 200 listings per page. If I refresh the page they might appear - or they might not. It isn't a problem on 100 or 50 listings per page. It didn't seem to happen at all when I tried with Chromium for a few minutes to compare. I guess this is partly a timing issue so might not be easily reproducible depending on your connection speed. I've seen this behaviour earlier this year as well doing similar searches.

User avatar
adesh
Board Warrior
Board Warrior
Posts: 1233
Joined: 2017-06-06, 07:38

Re: eBay 200 item search often misses "to" price

Post by adesh » 2020-06-05, 10:11

Unclear. Some screenshots may help.
Also eBay has region specific sites, so telling which one and providing the exact link you are on may also be necessary.


User avatar
adesh
Board Warrior
Board Warrior
Posts: 1233
Joined: 2017-06-06, 07:38

Re: eBay 200 item search often misses "to" price

Post by adesh » 2020-06-05, 15:51

I get "to" results on 50-per-page results also. I'm not sure if there is an browser issue but others can also check as well.
To me it looks like that's how the site wants to behave.
Screenshot 2020-06-05 at 9.19.16 PM.png

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: eBay 200 item search often misses "to" price

Post by Lunokhod » 2020-06-05, 18:37

The problem is when the "to xxx" price is missing, it's supposed to be there. But when I search with 200 listings per page, it randomly appears or doesn't appear when I refresh the page. The page seems to be drawn before all the data is present sometimes, it doesn't happen if I choose 100 or 50 listings per page. I guess there is some timeout that says OK, draw the page with what's available, even if it's not fully downloaded. There are some other elements missing on the page too, if you cycle between my 2 screenshots in an image viewer you can see them appear and disappear.

User avatar
andyprough
Newbie
Newbie
Posts: 6
Joined: 2020-05-31, 04:33

Re: eBay 200 item search often misses "to" price

Post by andyprough » 2020-06-05, 20:10

Lunokhod wrote:
2020-06-05, 18:37
The problem is when the "to xxx" price is missing, it's supposed to be there. But when I search with 200 listings per page, it randomly appears or doesn't appear when I refresh the page. The page seems to be drawn before all the data is present sometimes, it doesn't happen if I choose 100 or 50 listings per page. I guess there is some timeout that says OK, draw the page with what's available, even if it's not fully downloaded. There are some other elements missing on the page too, if you cycle between my 2 screenshots in an image viewer you can see them appear and disappear.
Are you using the PureURL extension for Palemoon? I am, and the "to $..." part of the price disappears if I have PureURL set to "Intercept Requests", but the "to $..." part of the price re-appears if I uncheck "Intercept Requests" on PureURL. Since the job of PureURL is to strip garbage referer tracking fields like 'utm_source' from links, I have to wonder if Ebay is doing something sketchy with the way they display those prices.

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: eBay 200 item search often misses "to" price

Post by Lunokhod » 2020-06-06, 02:26

Trying in a clean profile the first time I went to the page there were no to prices. Reloading the page they were there, reloaded again, still there, and again, now they were gone. So that is with Pale Moon with no extensions, everything default, no cache or cookies.
But trying some more with other browsers, now I can get the same effect in both Firefox (which I hadn't tried before) and Chromium. It is a bit random though and can work or not work for a while. So probably it's something to do with the page itself.

User avatar
moonbat
Moon Magic practitioner
Moon Magic practitioner
Posts: 2315
Joined: 2015-12-09, 15:45

Re: eBay 200 item search often misses "to" price

Post by moonbat » 2020-06-06, 04:51

andyprough wrote:
2020-06-05, 20:10
Are you using the PureURL extension for Palemoon? I am, and the "to $..." part of the price disappears if I have PureURL set to "Intercept Requests", but the "to $..." part of the price re-appears if I uncheck "Intercept Requests" on PureURL. Since the job of PureURL is to strip garbage referer tracking fields like 'utm_source' from links, I have to wonder if Ebay is doing something sketchy with the way they display those prices.
Could you enable logging in Pure URL and then post the original and stripped links for this from the error console? I'll see whether the default parameters are any that are interfering with this. To do this, turn on logging, clear the error console, then visit the page and filter the error console log for PureURL:
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 20 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
Advanced URL Builder(fork)|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28213
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: eBay 200 item search often misses "to" price

Post by Moonchild » 2020-06-06, 12:05

I think since this is a specific issue that only occurs with a large number of items, that it is a problem with something taking too long (either server-side or client-side) and as a result not displaying. Whether server-side or client-side, this will be a problem with site content - the browser will only display what it is instructed to do.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
andyprough
Newbie
Newbie
Posts: 6
Joined: 2020-05-31, 04:33

Re: eBay 200 item search often misses "to" price

Post by andyprough » 2020-06-06, 16:04

moonbat wrote:
2020-06-06, 04:51
Could you enable logging in Pure URL and then post the original and stripped links for this from the error console? I'll see whether the default parameters are any that are interfering with this. To do this, turn on logging, clear the error console, then visit the page and filter the error console log for PureURL:
No errors, warnings, or messages related to PureURL. Just a

Code: Select all

ReferenceError: raptor is not defined
repeated several times, and a warning about

Code: Select all

Warning: Strict-Transport-Security: The site specified a header that could not be parsed successfully.
repeated a couple of times. These show up in the error console whether PureURL is set for Intercept Requests or not.

User avatar
moonbat
Moon Magic practitioner
Moon Magic practitioner
Posts: 2315
Joined: 2015-12-09, 15:45

Re: eBay 200 item search often misses "to" price

Post by moonbat » 2020-06-06, 16:08

Hope you're looking in the Error Console and not the developer or browser console (Tools-Web Developer-Error Console).
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 20 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
Advanced URL Builder(fork)|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

User avatar
andyprough
Newbie
Newbie
Posts: 6
Joined: 2020-05-31, 04:33

Re: eBay 200 item search often misses "to" price

Post by andyprough » 2020-06-06, 17:14

moonbat wrote:
2020-06-06, 16:08
Hope you're looking in the Error Console and not the developer or browser console (Tools-Web Developer-Error Console).
Here's a screenshot.
Attachments
snapshot4.jpg

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28213
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: eBay 200 item search often misses "to" price

Post by Moonchild » 2020-06-06, 18:37

moonbat wrote:
2020-06-06, 16:08
Hope you're looking in the Error Console and not the developer or browser console (Tools-Web Developer-Error Console).
In this case you -want- the webconsole.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
andyprough
Newbie
Newbie
Posts: 6
Joined: 2020-05-31, 04:33

Re: eBay 200 item search often misses "to" price

Post by andyprough » 2020-06-06, 19:42

Moonchild wrote:
2020-06-06, 18:37
In this case you -want- the webconsole.
webconsole gives similar messages -

Code: Select all

Strict-Transport-Security: The site specified a header that could not be parsed successfully.[Learn More] i.html
ReferenceError: raptor is not defined[Learn More]  i.html:11265:1
ReferenceError: raptor is not defined[Learn More]  i.html:11266:3
ReferenceError: raptor is not defined[Learn More]  i.html:11273:5

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: eBay 200 item search often misses "to" price

Post by Lunokhod » 2020-06-07, 01:03

I installed Pure URL and the behaviour was unchanged for me. 25, 50 or 100 per page were OK, but on 200 the to prices would randomly appear or not when I refreshed the page. Sometimes I got a run of 5 or 6 in a row with no change.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28213
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: eBay 200 item search often misses "to" price

Post by Moonchild » 2020-06-07, 02:50

Lunokhod wrote:
2020-06-07, 01:03
I installed Pure URL and the behaviour was unchanged for me. 25, 50 or 100 per page were OK, but on 200 the to prices would randomly appear or not when I refreshed the page. Sometimes I got a run of 5 or 6 in a row with no change.
Moonchild wrote:
2020-06-06, 12:05
I think since this is a specific issue that only occurs with a large number of items, that it is a problem with something taking too long (either server-side or client-side) and as a result not displaying. Whether server-side or client-side, this will be a problem with site content - the browser will only display what it is instructed to do.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
Lunokhod
Lunatic
Lunatic
Posts: 298
Joined: 2017-04-20, 21:25
Contact:

Re: eBay 200 item search often misses "to" price

Post by Lunokhod » 2020-06-07, 19:46

Yes, I saw that, but wondered if PureURL would affect the timing and I would see the same effect with 100 listings, or all the time with 200, but didn't observe any obvious change. It's looking like a webpage issue for eBay to deal with though, so is just of passing interest from a Pale Moon perspective I suppose. Thank you for your help in determining this.

Post Reply