Cannot install to Linux Lite 5.0

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-03, 08:24

For some reason I cannot install PM to LL 5.0 from the command line. I have been successful with previous series, but now when I try I get various error messages. Has the method changed? Almost all methods seem to be out of date.

User avatar
adesh
Board Warrior
Board Warrior
Posts: 1222
Joined: 2017-06-06, 07:38

Re: Cannot install to Linux Lite 5.0

Post by adesh » 2020-06-03, 09:40

Download, extract and run.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28125
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Cannot install to Linux Lite 5.0

Post by Moonchild » 2020-06-03, 09:40

At the very least if you are asking for help and get error messages, post the error messages.
We don't have crystal balls or cameras in your home so we can magically see your screen.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 8039
Joined: 2012-10-09, 19:37
Location: I'm.. over there.

Re: Cannot install to Linux Lite 5.0

Post by New Tobin Paradigm » 2020-06-03, 10:01

Off-topic:
Moonchild wrote:
2020-06-03, 09:40
We don't have crystal balls or cameras in your home so we can magically see your screen.
Like Google and Amazon?
Your computer has too much computer in it and not enough typewriter.
Image

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1537
Joined: 2015-09-30, 23:02
Location: uk.

Re: Cannot install to Linux Lite 5.0

Post by Moonraker » 2020-06-03, 13:44

I think pale moon is in the linux lite repos.
Xenial puppy linux 32-bit.

Pale moon 28.9.3

User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Re: Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-04, 00:11

Moonchild wrote:
2020-06-03, 09:40
At the very least if you are asking for help and get error messages, post the error messages.
We don't have crystal balls or cameras in your home so we can magically see your screen.
Yeah, I should know better. Sorry about that.
I am "distro hopping" and have already moved on to MX Linux, which makes adding PM easy, No idea why some distros make you jump through hoops. I know PM does not have the following that some browsers do, but LL (which I like otherwise) makes it especially hard. Since, as it has been pointed out, users spend more time on their browsers that any other software program, that one thing can put one off a distro.

User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Re: Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-04, 00:16

Moonraker wrote:
2020-06-03, 13:44
I think pale moon is in the linux lite repos.
Not anywhere I could find.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 673
Joined: 2015-08-01, 18:33
Location: California

Re: Cannot install to Linux Lite 5.0

Post by stevepusser » 2020-06-04, 02:12

Since LL is based on Ubuntu, follow the instructions to add the OBS repo and key I maintain for Ubuntu and Debian. The Net says the very latest LL 5.0 is based on 20.04, and the previous version on 18.04. Be careful to copy and paste the generated code for the correct release, people have done that for the wrong version before...

I'm also the MX Linux packager, BTW, so the packages should be essentially the same. (that doesn't mean they are interchangeable between distros--compiling from the source makes them bespoke for each release)

You could also suggest that LL add Pale Moon to their repos, as it doesn't take that long to build from source--a small fraction of the time that Chromium-based browsers take, for example.

User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Re: Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-04, 03:45

Moderator note: Unnecessary quoting removed. See forum rules.

I've added your repository in the past. I've never had a problem with it with several Linux distros , but LL 5.0 (and 4.8) for some reason will not cooperate. Your suggestion of suggesting that LL add it to their repository. is good. I'll follow up on that.

User avatar
adesh
Board Warrior
Board Warrior
Posts: 1222
Joined: 2017-06-06, 07:38

Re: Cannot install to Linux Lite 5.0

Post by adesh » 2020-06-04, 09:10

Alternatively, if you wish, you can download the package from http://linux.palemoon.org/download/mainline/ and extract it using tar in some user writable location and then run the palemoon file inside. Choice is yours!

Also, you need to be concrete in telling us what exactly are you doing and what errors or behaviour you are encountering. Unless we have enough details, we can only give suggestions which may or may not apply to you.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 673
Joined: 2015-08-01, 18:33
Location: California

Re: Cannot install to Linux Lite 5.0

Post by stevepusser » 2020-06-05, 02:32

nevadacrab wrote:
2020-06-04, 03:45
....
I've added your repository in the past. I've never had a problem with it with several Linux distros , but LL 5.0 (and 4.8) for some reason will not cooperate. ...
It's probably some simple problem for LL, but we can't begin to fix that without some sort of information.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 673
Joined: 2015-08-01, 18:33
Location: California

Re: Cannot install to Linux Lite 5.0

Post by stevepusser » 2020-06-05, 03:51

FWIW, I just started up the LL 5.0 iso in a Live session in gnome-boxes on my MX Linux host, and copypasted the directions to add the OBS repo and its key there, then installed Pale Moon without any problems.

So I'm sorta inclined to think PEBKAC, unless it's a Net issue on your end.

User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Re: Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-06, 03:45

Moderator note: Unnecessary quoting removed. See forum rules.

I think part of the problem is there are varied instructions on how to add your repository. I may have mucked up my copy of LL. As I said, I have had no problems with LL in the past.

It well may have been an ID 10 T error. :shock:

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 673
Joined: 2015-08-01, 18:33
Location: California

Re: Cannot install to Linux Lite 5.0

Post by stevepusser » 2020-06-06, 04:14

Varied instructions? Well, post the ones you're using, the version of LL, and I'll tell you if they're good.

The instructions that the OBS provides do work--those are the ones I copypasted in the LL live session.

These ones for LL 5.0, for example:

Code: Select all

echo 'deb http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_20.04/ /' | sudo tee /etc/apt/sources.list.d/home:stevenpusser.list

sudo wget -nv https://download.opensuse.org/repositories/home:stevenpusser/xUbuntu_20.04/Release.key -O "/etc/apt/trusted.gpg.d/home:stevenpusser.asc"

sudo apt update

sudo apt install palemoon

User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Re: Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-06, 23:09

Moderator note: Unnecessary quoting removed. See forum rules.

By "varied instructions" I mean the instructions for various types of Debian and Ubuntu.
I installed MX Linux on my "experimental" laptop, but I may set up LL on a dual boot, and run the instructions you provided. Thanks for your patience.

User avatar
stevepusser
Project Contributor
Project Contributor
Posts: 673
Joined: 2015-08-01, 18:33
Location: California

Re: Cannot install to Linux Lite 5.0

Post by stevepusser » 2020-06-07, 03:11

Well, I do provide the repo for various releases of Ubuntu and Debian, and the instructions have to be different for each different release. But it's just a matter of copying and pasting the instructions that the OBS generates for your particular release, taking care to copypaste the correct ones. https://software.opensuse.org//download ... e=palemoon

Yes, we made it extra easy to install Pale Moon in MX Linux, but that's our whole schtick. LL could also do it, but it takes some extra effort one way or another.

User avatar
nevadacrab
Moon lover
Moon lover
Posts: 77
Joined: 2012-05-26, 11:49
Location: Henderson, Nevada, USA

Re: Cannot install to Linux Lite 5.0

Post by nevadacrab » 2020-06-07, 08:07

SUCCESS! Thank you again.

Post Reply