Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderator: trava90

Post Reply
User avatar
Baloo
Moonbather
Moonbather
Posts: 50
Joined: 2017-08-24, 15:02

Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by Baloo » 2020-04-25, 21:23

Hello,

I just wanted to let Steve Pusser know that currently Pale Moon from the Repository is uninstallable in Debian 10 Buster. The Libc6 version that Pale Moon requires to be installed is higher than the one available in the Debian Buster repository. The newer Libc6 is only available in Debian Bullseye and Testing. Apparently I've been told that this specific package is integral to the Debian distro version and is not able to be backported. I've had issues with my machine in other respects when using Debian Testing, so I'm using Buster at the moment but would like to still be able to install Pale Moon.

Is there any way that this can be fixed? Thanks very much.
Image Image

User avatar
stevepusser
Astronaut
Astronaut
Posts: 599
Joined: 2015-08-01, 18:33
Location: California

Re: Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by stevepusser » 2020-04-26, 03:09

You probably accidentally added the Debian testing repository instead of the Debian_10 one. That's unfortunately a common problem due to the way the OBS generates the instructions. You can check which one you have in GUIs such as Synaptic, or directly read the contents in the terminal with

Code: Select all

cat /etc/apt/sources.list.d/home:stevenpusser

User avatar
Baloo
Moonbather
Moonbather
Posts: 50
Joined: 2017-08-24, 15:02

Re: Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by Baloo » 2020-04-27, 13:32

OK, so I removed the source in Software-properties-Gtk and readded it as per the OBS instructions, noting the Debian 10 repository and not the Debian testing one. Here are the results:
root@debian:~# echo 'deb http://download.opensuse.org/repositori ... Debian_10/ /' > /etc/apt/sources.list.d/home:stevenpusser.list
root@debian:~# wget -nv https://download.opensuse.org/repositor ... elease.key -O Release.key

2020-04-27 09:28:14 URL:https://download.opensuse.org/repositor ... elease.key [1109/1109] -> "Release.key" [1]
root@debian:~# apt-key add - < Release.key
OK
root@debian:~# apt-get update
Get:10 http://download.opensuse.org/repositori ... /Debian_10 InRelease [1,547 B]
Fetched 1,016 kB in 4s (242 kB/s)
Reading package lists... Done
root@debian:~# apt-get install palemoon
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
palemoon : Depends: libc6 (>= 2.30) but 2.28-10 is to be installed
Depends: libgcc-s1 (>= 4.0) but it is not installable
Depends: libstdc++6 (>= 9) but 8.3.0-6 is to be installed
Depends: libx11-xcb1 (>= 2:1.6.9) but 2:1.6.7-1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@debian:~#
Same issue when adding the Debian 10 repository. Running Debian 10 Buster. Am I missing something more specific here? Thank you.
Image Image

User avatar
stevepusser
Astronaut
Astronaut
Posts: 599
Joined: 2015-08-01, 18:33
Location: California

Re: Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by stevepusser » 2020-04-28, 04:03

Shoot--I (or anyone, actually) can download and look inside the debs at their internal control file to see if that's true. If so, the OBS is really messing up the Buster builds. Hang on a bit.

Hmm---nope. This is what they report for the 64-bit and 32-bit Intel type builds:

Depends: libavcodec54 | libavcodec-extra54 | libavcodec55 | libavcodec-extra55 | libavcodec56 | libavcodec-extra56 | libavcodec57 | libavcodec-extra57 | libavcodec58 | libavcodec-extra58 | libavcodec-ffmpeg56 | libavcodec-ffmpeg-extra56, libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.28), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.12.6), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.30.0), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libpangoft2-1.0-0 (>= 1.14.0), libstdc++6 (>= 5.2), libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxext6, libxrender1, libxt6

Which is as it should be for Buster--pretty much what i expected, too, otherwise there would be a lot more users reporting the error than just you. Somehow, you're still getting the upstream version. Since they all have the same version number to save me from having to do a separate upload for every single different Debian and Ubuntu release, maybe it's using the saved Bullseye version from your apt cache. To clean that out, try:

Code: Select all

apt clean
with sudo or as root, then try another install.

If that still fails, you can directly download the debs from the download link: choose Debian, and then "grab binary packages directly", and then the Debian 10 deb for your platform at the bottom.

Do you know how to install a local deb file, either with apt on the command line, or with gnome-software, gdebi, deepin-deb-installer, or something similar?

User avatar
Baloo
Moonbather
Moonbather
Posts: 50
Joined: 2017-08-24, 15:02

Re: Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by Baloo » 2020-04-28, 14:33

Thanks very much Steve, I downloaded the .deb file and installed with apt-get and now it works fine. However, I'm still baffled as to why this keeps pulling from Upstream in the repository, as I'd like to have it update with apt-get update and upgrade of course....deleted the source.list.d files from your repository and readded, also did apt clean, no dice. Still wants to pull from upstream. Not sure what the deal is to be honest. But thank you for your assistance with this!
Image Image

User avatar
stevepusser
Astronaut
Astronaut
Posts: 599
Joined: 2015-08-01, 18:33
Location: California

Re: Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by stevepusser » 2020-04-29, 03:00

Baloo wrote:
2020-04-28, 14:33
Thanks very much Steve, I downloaded the .deb file and installed with apt-get and now it works fine. However, I'm still baffled as to why this keeps pulling from Upstream in the repository, as I'd like to have it update with apt-get update and upgrade of course....deleted the source.list.d files from your repository and readded, also did apt clean, no dice. Still wants to pull from upstream. Not sure what the deal is to be honest. But thank you for your assistance with this!
Well, I'm stumped.

User avatar
Baloo
Moonbather
Moonbather
Posts: 50
Joined: 2017-08-24, 15:02

Re: Libc6 Version Required for Pale Moon uninstallable in Debian 10 Buster

Post by Baloo » 2020-04-30, 14:59

Found the issue, had some bad configs in my repository. Working fine now.
Image Image

Post Reply