Another problem with Citibank site

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderator: trava90

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2179
Joined: 2012-06-28, 01:20

Another problem with Citibank site

Post by ron_1 » 2019-12-26, 20:27

Posting this on the Linux board, even though I don't think it's a Linux-type issue. Ever since Monday, Dec 23, I can't access the Citibank website. I get the login screen, but when I try to login I get a screen that says: "We're sorry. Citi.com is temporarily unavailable." It's weird, because this only started on the 23rd, and I've had 28.8.0 since the day it was released. And yes, I've tried it in a new clean profile, and it still doesn't work. However, it does work in Basilisk. Should I try modifying the UA override for Citi? If so, what should I change it to?

EDIT
I tried changing the UA override to:

Code: Select all

Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0 (Pale Moon)
but that didn't work.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4231
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Another problem with Citibank site

Post by Night Wing » 2019-12-26, 21:15

Have you tried this over ride code?

Code: Select all

Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2179
Joined: 2012-06-28, 01:20

Re: Another problem with Citibank site

Post by ron_1 » 2019-12-26, 21:37

That didn't work either, but thanks anyway Night Wing. Any other suggestions?

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1689
Joined: 2012-08-19, 20:32

Re: Another problem with Citibank site

Post by back2themoon » 2019-12-26, 23:41

Try Windows overrides:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.9) Gecko/20100101 Firefox/52.9 PaleMoon/28.8.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.9) Gecko/20100101 Firefox/60.9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:4.4) Goanna/20170101 PaleMoon/28.8.0
Mozilla/5.0 (Windows NT 6.1; Trident/7.0; rv:11.0) like Gecko
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

...and so on. These are some of PM's in-built overrides.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2179
Joined: 2012-06-28, 01:20

Re: Another problem with Citibank site

Post by ron_1 » 2019-12-27, 01:06

None of those worked. I also tried:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:71.0) Gecko/20100101 Firefox/71.0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:71.0) Gecko/20100101 Firefox/71.0

but these didn't work either. I'm beginning to think something else is going on, but I don't have a clue what it could be. I just hope it keeps working in Basilisk cause I'd hate to have to use Firefox.

Is anybody else (on Windows or Linux) who uses Citibank experiencing this, or just me?

pshipwrite
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: 2018-04-18, 21:34

Re: Another problem with Citibank site

Post by pshipwrite » 2019-12-27, 18:40

ron_1, I am experiencing the same Citibank login problem on Windows 7 with PM 28.8.0. I searched the Pale Moon forums for Citi and found your posts here in the "Pale Moon for Linux" forum. I suspect Citi updated their website browser security checks around December 23rd. Like you, I have tried numerous UA overrides for citi.com but none have worked.

I am also using another browser as a workaround (Opera). I hope this issue can be resolved since PM is my primary browser.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1689
Joined: 2012-08-19, 20:32

Re: Another problem with Citibank site

Post by back2themoon » 2019-12-27, 20:22

pshipwrite wrote:
2019-12-27, 18:40
I hope this issue can be resolved since PM is my primary browser.
Make sure to contact the bank...
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

pshipwrite
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: 2018-04-18, 21:34

Re: Another problem with Citibank site

Post by pshipwrite » 2019-12-27, 20:32

back2themoon, I have contacted Citibank in previous years when such "UA sniffing" problems occurred. However, Citi was not at all responsive. Their customer service representatives simply said I must use Google Chrome, Mozilla Firefox, Safari, or Internet Explorer (or Microsoft Edge if on Windows 10) - Citigroup does NOT support any other browser. I tried to reason with them that their browser security checks should be based on functionality not on browser self-identification but to no avail.
Last edited by pshipwrite on 2019-12-27, 20:37, edited 1 time in total.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1689
Joined: 2012-08-19, 20:32

Re: Another problem with Citibank site

Post by back2themoon » 2019-12-27, 20:36

Well, in such a case, I'd rather switch bank than browser. I mean, they make tons of money and don't even bother to listen to their customers for a simple matter? I'm lucky enough to use two banks that both work fine with Pale Moon (as they should - they're not doing me any favours).
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x64 • Emsisoft Anti-Malware

pshipwrite
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: 2018-04-18, 21:34

Re: Another problem with Citibank site

Post by pshipwrite » 2019-12-27, 20:38

I agree with you, back2themoon, I would switch to another bank if I could. However, given the unique financial relationship I have with Citi, that is not possible at this time.

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2179
Joined: 2012-06-28, 01:20

Re: Another problem with Citibank site

Post by ron_1 » 2019-12-27, 21:04

I'd like to know if it's not UA sniffing causing this, what is?

pshipwrite
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: 2018-04-18, 21:34

Re: Another problem with Citibank site

Post by pshipwrite » 2019-12-27, 21:16

Yes, I'm not sure the problem is solely UA sniffing. Having tried a gazillion UA overrides, reason and logic says something else may be going on.

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2179
Joined: 2012-06-28, 01:20

Re: Another problem with Citibank site

Post by ron_1 » 2019-12-29, 15:50

Is there anything in the Web Developer (under Tools menu option) that I can look at that might shed some light on this?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26674
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Another problem with Citibank site

Post by Moonchild » 2019-12-29, 20:49

Citibank has been an on-going problematic site for us and they have no intention of being browser-agnostic or even being in any way reasonable to their clients when it comes to on-line banking.
Contacting them has proven less than useful -- if you are using them and want to use their on-line banking, please use one of their very short list of "approved" browsers. There really isn't much else to do about it as they will continue to target only those browsers and will continue to explicitly block other web clients when they can.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2179
Joined: 2012-06-28, 01:20

Re: Another problem with Citibank site

Post by ron_1 » 2019-12-29, 21:41

Yeah, I know MC. Right now my big concern is that sooner or later it won't work in Basilisk either.

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3598
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Another problem with Citibank site

Post by Pallid Planetoid » 2019-12-30, 02:00

back2themoon wrote:
2019-12-27, 20:22
pshipwrite wrote:
2019-12-27, 18:40
I hope this issue can be resolved since PM is my primary browser.
Make sure to contact the bank...
Citibank isn't going to care about supporting Pale Moon -- they are just going to say that PM isn't an acceptable browser and that will be the end of it.
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3598
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Another problem with Citibank site

Post by Pallid Planetoid » 2019-12-30, 02:11

pshipwrite wrote:
2019-12-27, 20:38
I agree with you, back2themoon, I would switch to another bank if I could. However, given the unique financial relationship I have with Citi, that is not possible at this time.
First of all -- point of reference; this recent issue also occurs in Windows (in my case Win10).

Back to my reply to the suggestion of changing banks:

I'm not about to quit Citibank considering I've had an account with them since 1957 (over 60 years) and as such have a unique relationship including a special account that no one else can have that is both free and provides me with interest on my balance at the same time. Because of my long history with Citibank I've relegated myself to using my "Open with...." add-on to open the login page in another browser by just right-clicking on the login page in Pale Moon and selecting anyone of a number of alternate browsers that work with Citibank. This allows me to keep using Pale Moon for everything (which is my priority) and simply redirecting Citibank to an alternate browser to account for this new issue that has recently cropped up.

What I'm hoping is that at some point down-the-road whatever change has created this problem will be addressed (likely inadvertently) by Citibank since the issue may be unintended consequences of some change to their login page (which has occurred in the past i.e. weird log-off behavior was present for some time that eventually resolved itself).

That said, however -- I'm also wondering if the PM 28.8 update may be contributing to the problem instead of any Citibank modifications to their web-page.

This issue has started very close in proximity of time to the PM 28.8 update when thinking back to when this all started. And the issue persists in Safe-Mode and using a new clean profile for what that's worth.....

So if anyone is still using the prior release of PM and are using Citibank -- please post your results using the bank -- thanks in advance.
:thumbup:

Question answered below...
Last edited by Pallid Planetoid on 2019-12-30, 04:21, edited 1 time in total.
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3598
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Another problem with Citibank site

Post by Pallid Planetoid » 2019-12-30, 04:20

Pallid Planetoid wrote:
2019-12-30, 02:11
.... I'm also wondering if the PM 28.8 update may be contributing to the problem instead of any Citibank modifications to their web-page.

This issue has started very close in proximity of time to the PM 28.8 update when thinking back to when this all started. And the issue persists in Safe-Mode and using a new clean profile for what that's worth.....

So if anyone is still using the prior release of PM and are using Citibank -- please post your results using the bank -- thanks in advance. :thumbup:
No need --- Refer to this post regarding same topic involving Windows viewtopic.php?f=3&t=23513&p=180719#p180719 that answers this question (same issue present in the prior Pale Moon release).
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3598
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Another problem with Citibank site

Post by Pallid Planetoid » 2019-12-31, 02:13

ron_1 wrote:
2019-12-29, 15:50
Is there anything in the Web Developer (under Tools menu option) that I can look at that might shed some light on this?
For what it's worth this is what I get for errors in the Web Console:

Code: Select all

Timestamp: 12/30/2019 6:06:58 PM
Error: ReferenceError: mboxCreate is not defined
Source File: https://online.citi.com/US/JPS/portal/Index.do?Promo_ID=SPBL
Line: 948
Timestamp: 12/30/2019 6:07:02 PM
Error: TypeError: document.getElementById(...) is null
Source File: chrome://butwhymod/content/browser.js
Line: 28
Timestamp: 12/30/2019 6:07:46 PM
Error: TypeError: document.getElementById(...) is null
Source File: chrome://butwhymod/content/browser.js
Line: 28
The first two errors are the result of rendering the log-in page and the third (last) error the result of attempting to login (which produces the error in question: "We're sorry. Citi.com is temporarily unavailable" etc etc....)
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 3598
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: Another problem with Citibank site

Post by Pallid Planetoid » 2019-12-31, 02:28

ron_1 wrote:
2019-12-29, 21:41
Yeah, I know MC. Right now my big concern is that sooner or later it won't work in Basilisk either.
Hmm, another perspective would be to approach the situation from the opposite direction --- that is to say (in full recognition that they are not the same browser just as most browsers are not the same in many respects); if the page works in a little known XUL browser like Basilisk then one could surmise there might be a way to make the same page work an another better known XUL browser like Pale Moon. :think: (that is, from the perspective of a neophyte.... :eh: ;))
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

Post Reply