palemoon + devuan + alsa, no sound Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderator: trava90

Post Reply
User avatar
nubjunk
Newbie
Newbie
Posts: 3
Joined: 2019-12-13, 02:10

palemoon + devuan + alsa, no sound

Post by nubjunk » 2019-12-13, 02:48

Sorry, I know this has been covered. I've been all through the threads in the forum, and I can't find anything that's helped. I have absolutely no sound in palemoon.
This is the tar.xz of version 28.7.1, the stevenpusser debian repo version 28.8.0, and the source with --disable-pulseaudio and --enable-alsa of version 28.8.0.
In all versions when I check about:support it always says Audio Backend: alsa.
I've tried Preferences -> Advanced -> Use hardware acceleration when available enabled and disabled, User Agent Mode: Firefox Compatibility, and Native. Preferences -> Content -> Enable Media Source Extensions (MSE) disabled and enabled.
Vivaldi works fine, vlc works fine, mplayer works fine, you get the idea.

Code: Select all

prompt$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
sysdefault:CARD=NVidia_2
    HDA NVidia, ALC262 Analog
    Default Audio Device
front:CARD=NVidia_2,DEV=0
    HDA NVidia, ALC262 Analog
    Front speakers
    ...

Code: Select all

prompt$ aplay -l 
card 0: NVidia_2 [HDA NVidia], device 0: ALC262 Analog [ALC262 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia_2 [HDA NVidia], device 1: ALC262 Digital [ALC262 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  ...

Code: Select all

prompt$ cat asound.conf
pcm.!default {
        type hw
        card NVidia_2
        device 0
}
ctl.!default {
        type hw
        card NVidia_2
}

User avatar
Tokia
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: 2018-08-16, 12:02

Re: palemoon + devuan + alsa, no sound

Post by Tokia » 2019-12-13, 08:29

x86_64 Devuan + ALSA, Pale Moon 28.8.0 user here. I don't have any alsa issue on Youtube.

Start Pale Moon from terminal. See if you can get any errors output there.

or Download a binary copy PM from : http://linux.palemoon.org/download/mainline/
Backup your existing settings (.moonchild productions) on a folder and test Audio with new profile from above link by just run the executable.
Edit: My alsa-utils is plain, no config on home or other tweaks.
- OS: FreeBSD | WM: CWM & Devuan | WM: Fluxbox (lean & mean)
- I only play 96Hz WAV/FLAC via DAC player or DeaDBeeF on Linux
- Pale Moon (latest version)
- Nothing beats peace and quiet - Tomoki Sakurai

User avatar
191129ASa
New to the forum
New to the forum
Posts: 1
Joined: 2019-12-13, 17:53

Re: palemoon + devuan + alsa, no sound

Post by 191129ASa » 2019-12-13, 17:57

Hello, I had the same exact problem a while back.

The culprit was my .asoundrc file.

I changed the syntax from this:

pcm.!default {
type hw
card X
}

ctl.!default {
type hw
card X
}

to this:

defaults.pcm.card X
defaults.ctl.card X

User avatar
nubjunk
Newbie
Newbie
Posts: 3
Joined: 2019-12-13, 02:10

Re: palemoon + devuan + alsa, no sound

Post by nubjunk » 2019-12-13, 21:40

191129ASa wrote:
2019-12-13, 17:57
changing:
standard

Code: Select all

pcm.!default {
    type hw
    card #
}
ctl.!default {
    type hw
    card #
}
to this:
abbreviated

Code: Select all

defaults.pcm.card #
defaults.ctl.card #
resolves the problem.
I had a look at this, it does solve the problem, thank you. Also I tried a few things, just for more clarity:
  1. Using a name for the card instead of an index in the abbreviated format doesn't work.
  2. Having an asound.conf file in etc in the standard format prevents this from working.
  3. Using indexes in the standard format doesn't work.

User avatar
nubjunk
Newbie
Newbie
Posts: 3
Joined: 2019-12-13, 02:10

Re: palemoon + devuan + alsa, no sound

Post by nubjunk » 2019-12-13, 21:49

Tokia wrote:
2019-12-13, 08:29
x86_64 Devuan + ALSA, Pale Moon 28.8.0 user here. I don't have any alsa issue on Youtube.

Start Pale Moon from terminal. See if you can get any errors output there.

or Download a binary copy PM from : http://linux.palemoon.org/download/mainline/
Backup your existing settings (.moonchild productions) on a folder and test Audio with new profile from above link by just run the executable.
Edit: My alsa-utils is plain, no config on home or other tweaks.
I should have been more clear in my origional post, I am launching from a terminal, there are no errors.
I'd really like to know how to convince palemoon to produce errors as it seems like there should be some.

User avatar
Tokia
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: 2018-08-16, 12:02

Re: palemoon + devuan + alsa, no sound

Post by Tokia » 2019-12-14, 06:31

nubjunk wrote:
2019-12-13, 21:49
I should have been more clear in my origional post, I am launching from a terminal, there are no errors.
I'd really like to know how to convince palemoon to produce errors as it seems like there should be some.
First glad "191129ASa" posted a better solutions aswell glad you've fixed it.

I think probably the issue isn't lying with Alsa base per se, so Pale Moon sees it as OK like other tools you mentioned so there's nothing to output.

The last time i used an ".asoundrc" on my /home folder it was for System sound equalized something like alsaequal, i wanted to use an equalizer for ALSA, but haven't had any issue with this package on Pale Moon. I remember to make adjust on my then ".asoundrc", but i no longer have that config on my new system.

Other ALSA tools-package in your system or any possible configuration on your side may have made the conflict with browser, the fact that Pale Moon does not reflect i think she sees as layer over ALSA base so fails to perceive it?

Well, those are just shoots in the dark, since we've no outputs all these remain just assumptions.
Since "191129ASa" come out with a fix, remains to be observed by browser maintainers to make any changes if needed.

I wish someone could come up with a better explanation so we'll get a more accurate answer.

Regards!
- OS: FreeBSD | WM: CWM & Devuan | WM: Fluxbox (lean & mean)
- I only play 96Hz WAV/FLAC via DAC player or DeaDBeeF on Linux
- Pale Moon (latest version)
- Nothing beats peace and quiet - Tomoki Sakurai

Post Reply