Various login issues

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
jpirie
Newbie
Newbie
Posts: 4
Joined: 2019-11-01, 09:12

Various login issues

Unread post by jpirie » 2019-11-01, 09:30

Good day everyone.
I am experiencing increasing difficulties in using PaleMoon to log in to password protected web sites. I thought I was using the wrong password on a site recently until I reverted to Firefox and all went well.
I have conducted a brief test this morning and find the following:
www.thinkbroadband.com Can't log in at all, I get a CSRF attack detected warning which is not present on other browsers
www.testmy.net I get a "Something Went Wrong" popup and no login. Fine with other browsers
Facebook.com appeared to log in but when I try and do anything I get asked to log in again and again over and over.
{b}www.twitter.com[/b] cycles straight back to the login dialogue even after my receiving and entering a one time text login PIN
www.amazon.com Same as Facebook, I get in but then get requests to log in at every turn
The list goes on so I suspect there is an issue either between Pale Moon and my system setup or Pale Moon Linux in general which I see is unlikely or others would be mentioning it :D

Any helpful insights welcomed.
For now though, it's back to Firefox.

James

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24837
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Various login issues

Unread post by Moonchild » 2019-11-01, 09:48

Or, the more likely scenario (since there are no other widespread reports of these issues), you're having a browser configuration and/or extensions in Pale Moon that are causing these problems , like content blockers, cookie settings, cache settings, etc. etc.

Try with add-ons disabled, using a new profile, or in safe mode.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1136
Joined: 2015-09-30, 23:02
Location: Lincolnshire.UK.

Re: Various login issues

Unread post by Moonraker » 2019-11-01, 10:17

Do you have noscript installed by any chance ?.
Those sites work perfectly fine for me and i just have ublock origin installed.
Xenial puppy linux 32-bit.
Tahrpup 6.0.5.32 bit.
Pale moon 28.7.2

User avatar
moonbat
Astronaut
Astronaut
Posts: 738
Joined: 2015-12-09, 15:45
Location: Australia

Re: Various login issues

Unread post by moonbat » 2019-11-01, 10:46

Moonraker wrote:
2019-11-01, 10:17
Do you have noscript installed by any chance ?.
Those sites work perfectly fine for me and i just have ublock origin installed.
Seems likely..I've never seen a CSRF warning anywhere else. I used Noscript long ago with Seamonkey.

@ OP - please read this thread for why NoScript isn't supported with Pale Moon.
You can use eMatrix, which does the same job by blocking all content by default (so you have to unblock different items for each site you frequent - scripts, cookies, frames, XMLHttpRequests and media).
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

User avatar
jpirie
Newbie
Newbie
Posts: 4
Joined: 2019-11-01, 09:12

Re: Various login issues

Unread post by jpirie » 2019-11-06, 22:14

Hello again everyone who responded.
I went through my addons and, apart from UBlock, I only had a user agent switcher which I use to be able to post pictures on Instagram from my P.C.

Anyway, I deleted the agent switcher and the problems disappeared.
I apologise for not having thought of this before posting in here.

*Must Do Better :)

Back to Pale Moon.

J

User avatar
sailfst
Newbie
Newbie
Posts: 5
Joined: 2019-11-08, 21:47

Re: Various login issues

Unread post by sailfst » 2019-11-08, 21:52

I am experiencing the same problem as well with the new version logging into banking sites.
I DO NOT have a user agent switcher.

User avatar
jpirie
Newbie
Newbie
Posts: 4
Joined: 2019-11-01, 09:12

Re: Various login issues

Unread post by jpirie » 2019-11-09, 08:11

Hi sailfst,
It's pretty safe to say therefore that this is not related to any Agent Switching addon :) However, it is worth switching off all or any addons and trying the login again.
Just so that I was sure this is not an inherent problem with Palemoon I toddled off and logged in to my bank site at www.rbsdigital.com which worked as well as it ever does, by which I mean the layers of security one has to wade through to get there in any browser, which is, of course, a good thing.

So, not much help to you I'm sorry but is confirming that I can use Palemoon to log on to my banking site.

I wish you well with your problem, I'm sure someone will help you out.

J

User avatar
adesh
Astronaut
Astronaut
Posts: 747
Joined: 2017-06-06, 07:38

Re: Various login issues

Unread post by adesh » 2019-11-09, 08:30

Off-topic:
For all security sensitive applications and for those who are trying to solve PEBCAK, go mainstream and use something which has widespread recognizability, if you want lesser pain in your life. Unless, of course, you are versed enough to bypass those silly checks (but then there is a legal aspect to this). This is sad but it is the current state of things. Banks are the worst offenders in this space. Expect more of this useless security in future!

User avatar
jpirie
Newbie
Newbie
Posts: 4
Joined: 2019-11-01, 09:12

Re: Various login issues

Unread post by jpirie » 2019-11-09, 08:55

But, I have just said, I can log in to my Banking site without issues other than the fact that all such sites are extremely fiddly with their multi layered security checks so, in this respect, Pale Moon works fine for me.
J

User avatar
sailfst
Newbie
Newbie
Posts: 5
Joined: 2019-11-08, 21:47

Re: Various login issues

Unread post by sailfst » 2019-11-09, 20:27

Worked fine for me until I updated to the most recent version.

User avatar
moonbat
Astronaut
Astronaut
Posts: 738
Joined: 2015-12-09, 15:45
Location: Australia

Re: Various login issues

Unread post by moonbat » 2019-11-10, 01:12

sailfst wrote:
2019-11-09, 20:27
Worked fine for me until I updated to the most recent version.
So what's the URL that doesn't work?
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

Post Reply