Palemoon not working properly

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

bilem
Newbie
Newbie
Posts: 6
Joined: 2019-10-10, 08:19
Contact:

Palemoon not working properly

Unread post by bilem » 2019-10-10, 08:34

Hellow, Since a couple of years I'm using Palemoon that I find more efficient than Firefox. Since the last update (28.7.1 64-bit) it doesn't work properly: as an example, I cannot setup my home page. Every time I reopen it I still get the same welcome tabs. When launched from the terminal, I get "1570694784854 addons.xpi WARN Add-on fr-dicollecte@dictionaries.addons.mozilla.org is missing bootstrap method install". I have no idea what to do. finally gave up but I am not happy using a different browser. My OS is UBUNTU 16.04 LTS.
Thanks in advance for any help.

vannilla
Astronaut
Astronaut
Posts: 667
Joined: 2018-05-05, 13:29

Re: Palemoon not working properly

Unread post by vannilla » 2019-10-10, 12:04

What happens if you use safe mode or a new profile?
Can you post your troubleshooting informations?
Check the forum's stickied threads if you don't know how to do it.

bilem
Newbie
Newbie
Posts: 6
Joined: 2019-10-10, 08:19
Contact:

Re: Palemoon not working properly

Unread post by bilem » 2019-10-10, 13:21

Thank you vanilla for considering my question.
I fear that your answer does not help me. I do not know what to do in safe mode: the command palemoon does not operate. It would be kind of you to go into more details?

User avatar
moonbat
Astronaut
Astronaut
Posts: 562
Joined: 2015-12-09, 15:45
Location: Australia

Re: Palemoon not working properly

Unread post by moonbat » 2019-10-10, 13:41

He means starting Pale Moon in safe mode (i.e. with extensions disabled), not rebooting the OS to safe mode!
Please look at the stickied topics in the general forum - there are instructions on how to provide a bug report including starting the browser.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

bilem
Newbie
Newbie
Posts: 6
Joined: 2019-10-10, 08:19
Contact:

Re: Palemoon not working properly

Unread post by bilem » 2019-10-10, 14:10

I attached a file containing the trouble shooting information report. Is that which is needed?
Thank you both.
Attachments
troubleshooting_information.txt
(2.9 KiB) Downloaded 14 times

vannilla
Astronaut
Astronaut
Posts: 667
Joined: 2018-05-05, 13:29

Re: Palemoon not working properly

Unread post by vannilla » 2019-10-10, 17:38

Did you take the infos while in safe mode?
If so, can you do it while not in safe mode?
If not, I can't really find anything strange there, so maybe check if the profile directory is writable.

bilem
Newbie
Newbie
Posts: 6
Joined: 2019-10-10, 08:19
Contact:

Re: Palemoon not working properly

Unread post by bilem » 2019-10-11, 07:32

Finally, I adopted your second suggestion, vannilla: I created a new profile. Since then, I use Palemoon again and it looks OK, excepted a couple of adjustments I'll have to do. For example, the icon in the launcher is not as expected, consisting of a grey square with a question mark. Detail!
I am still wondering how Palemoon was corrupted on three of mine computers after the last update...
Anyway, thanks a lot for your help.

User avatar
moonbat
Astronaut
Astronaut
Posts: 562
Joined: 2015-12-09, 15:45
Location: Australia

Re: Palemoon not working properly

Unread post by moonbat » 2019-10-11, 10:15

bilem wrote:
2019-10-11, 07:32
For example, the icon in the launcher is not as expected, consisting of a grey square with a question mark. Detail!
Did the launcher icon get created by itself? I'm on Mint 19.2 Xfce and didn't face this. You can of course edit the launcher and set the icon - it is under <install location>/browser/icons/
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

bilem
Newbie
Newbie
Posts: 6
Joined: 2019-10-10, 08:19
Contact:

Re: Palemoon not working properly

Unread post by bilem » 2019-10-11, 11:23

I already checked that the right icon is at the right place. Therefore, it is more complicated than that. There are 5 palemoon.png which are symlinks towards various image files. In addition, previously I was able to open a new window by right clicking the icon of the launcher. Right clinking does not offer this choice anymore. This shows that something more subtle occurs.
I think that I will be waiting for the next update of palemoon and see then what happens.
Thank you moonbat for your contribution.

vannilla
Astronaut
Astronaut
Posts: 667
Joined: 2018-05-05, 13:29

Re: Palemoon not working properly

Unread post by vannilla » 2019-10-11, 12:35

Alternatively, a more brutal approach: uninstall Pale Moon (did you use a package manager?), move (or delete) the "$HOME/.moonchild production/" folder, reinstall Pale Moon.
Before reinstalling if you are paranoid you might want to check that anything Pale Moon-related has been deleted. An easy (but relatively slow) way would be to use the "locate" tool (after updating the database.)

bilem
Newbie
Newbie
Posts: 6
Joined: 2019-10-10, 08:19
Contact:

Re: Palemoon not working properly

Unread post by bilem » 2019-10-11, 15:09

I already de/reinstalled the package with aptitude from http://download.opensuse.org/repositori ... ntu_16.04/. Without success! (actually, I did not delete the folder in my home directory.)
As I have most functionalities working, I will not do more for the moment. Let see what happens after the future new version. If you mind, I'll keep you informed then.
Thanks again vannilla and moonbat for your help.

Post Reply