posting bitchute links on mewe hangs PM Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Lew Rockwell Fan
Fanatic
Fanatic
Posts: 174
Joined: 2017-06-14, 15:20

posting bitchute links on mewe hangs PM

Unread post by Lew Rockwell Fan » 2019-08-15, 19:08

Anytime I post a bitchute link at mewe.com PM hangs. I've tried a plain fresh profile & get the same result. When you post a link (meaning paste it in to a text field with or without commentary text) at mewe, it tries to extract some text and an image if there is one, to use as a thumbnail. It's that process that seems to be the problem. I get a wait animation and then the whole browser is unresponsive and remains so. I've tried letting it run for 30 minutes or so. Only way I can get out of it is to use xkill (only way I've tried that worked I mean - I could probably kill it from a terminal). Firefox works fine for this. Dillo apparently won't work there at all because mewe requires javascript. I haven't tried any other browsers.

This sort of freezing has always been an occasional issue for me, but in the past I could kill PM and restart it and it would work. Now it does this consistently on that one site, under this one circumstance. Any suggestions?
"To attempt to silence a man is to pay him homage, for it is an acknowledgement that his arguments are both impossible to answer and impossible to ignore." - John Bryant

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24837
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: posting bitchute links on mewe crashes PM

Unread post by Moonchild » 2019-08-15, 20:42

At 169 posts on this forum, you should be aware of the difference between a crash and a hang. I'll edit the topic title for you.

EDIT: unable to reproduce on Windows; the site spins for a second or so then displays a thumb, description and link, and Pale Moon doesn't hang.
Since you say it occurs semi-regularly for you, it might be something with your specific setup -- posting troubleshooting information etc. will be helpful.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Lew Rockwell Fan
Fanatic
Fanatic
Posts: 174
Joined: 2017-06-14, 15:20

Re: posting bitchute links on mewe hangs PM

Unread post by Lew Rockwell Fan » 2019-10-28, 20:26

Thanks. Whatever the source, the problem went away. What's the best way to gather trouble shooting info anyway? I've tried running in a terminal, but there is little if any output to stdout. There doesn't seem to be any "--verbose" or similar option. Accepting my own reply because there doesn't seem to be any other way to mark "solved".
"To attempt to silence a man is to pay him homage, for it is an acknowledgement that his arguments are both impossible to answer and impossible to ignore." - John Bryant

User avatar
Kathuluforz
Moonbather
Moonbather
Posts: 52
Joined: 2019-06-13, 13:42
Location: Montana

Re: posting bitchute links on mewe hangs PM

Unread post by Kathuluforz » 2019-10-28, 23:36

Just went and tested this @mewe...posted a bitchute vid with little to no problem, just had to allow all on UBO and eMatrix. My first real post there since joining 2 months ago.

Bitchute can be wonky sometimes and some videos just won't play (on any browser) until maybe later or the next day, if at all. Bitchute imo is like the Wild West, you never can really rely on everything always working as intended.

Pale Moon 28.7.1 (64) Win7pro (64)
"Man needs difficulties; they are necessary for health"
Carl Jung

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6189
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: posting bitchute links on mewe hangs PM

Unread post by New Tobin Paradigm » 2019-10-29, 00:01

Or people to use a very simple common sense troubleshooting technique to determine if the problem is the browser or their content blocking or manipulating extension.
Image
- Old and insecure for legitimate and reasonable purposes. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

Lew Rockwell Fan
Fanatic
Fanatic
Posts: 174
Joined: 2017-06-14, 15:20

Re: posting bitchute links on mewe hangs PM

Unread post by Lew Rockwell Fan » 2019-10-30, 18:00

Kathuluforz wrote:
2019-10-28, 23:36
Just went and tested this
Yes, as I wrote, the problem has gone away now. Some update, whether at mewe, bitchute, PM, or some local linux lib, apparently fixed it.
Kathuluforz wrote:
2019-10-28, 23:36
Bitchute can be wonky sometimes and some videos just won't play
Yes, but that's unrelated. I've discussed that with the webtorrent devs & they told me that some of the problematic bitchute pages bizarrely lack the information on their own seeder of last resort so to speak. If that's accurate, I don't understand how they ever get started to begin with for there to be other seeders, but that's what I was told when I submitted a long list of examples of good and bad bitchute links.
New Tobin Paradigm wrote:
2019-10-29, 00:01
Or people to use a very simple common sense troubleshooting technique to determine if the problem is the browser or their content blocking or manipulating extension.
Sure. For example, in this case, as I wrote, I:
- created a fresh, plain PM profile and tested with that, and had the same problem - eliminating extensions as an issue.
- tested with Firefox which worked fine, making PM the logical thing to focus on.
Those are basic steps. Running in a terminal is another, but PM sends little if any info to stdout or stderr unfortunately. A --verbose option would be real handy.

At any rate, it's no longer an issue. I didn't fix it. Either some update to my system did, or somebody changed some code at bitchute or mewe.
"To attempt to silence a man is to pay him homage, for it is an acknowledgement that his arguments are both impossible to answer and impossible to ignore." - John Bryant

Post Reply