[Solved] Can't install Palemoon, broken packages - libc6 ?

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Post Reply
User avatar
DonNadie
Newbie
Newbie
Posts: 3
Joined: 2019-05-19, 12:29

[Solved] Can't install Palemoon, broken packages - libc6 ?

Post by DonNadie » 2019-05-19, 12:44

Code: Select all

$ inxi -Sxxx
System:    Host: Lenovo-ideapad-530S-15IKB Kernel: 4.15.0-50-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 
           Desktop: Cinnamon 4.0.10 wm: muffin 4.0.7 dm: LightDM 1.26.0 Distro: Linux Mint 19.1 Tessa 
           base: Ubuntu 18.04 bionic
In the past I've installed Palemoon several times on different machines running different distros without any problems. I just followed the instructions on this web site

https://software.opensuse.org/download.html?project=home:stevenpusser&package=palemoon


Now suddenly here's what happens:

Code: Select all

$ sudo apt install palemoon
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 palemoon : Depends: libc6 (>= 2.29) but 2.27-3ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

When I try to fix broken packages using Synaptic, I get:
Successfully fixed dependency problems
but when I try to install Palemoon using Synaptic I see the following:
Could not mark all packages for installation or upgrade

The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.

palemoon:
Depends: libc6 (>=2.29) but 2.27-3ubuntu1 is to be installed
In Synaptic under Additional Repositories I see
Opensuse / /
deb http://download.opensuse.org/repositori ... untu_Next/ /
/etc/apt/sources.list.d/home:stevenpusser.list
I don't know much about this stuff but my guess is that the Palemoon package wants libc6 2.27-3ubuntu1 as a dependency but I have a newer version, viz. libc6 2.29 installed.

Whatever the problem is, how do I fix it? TIA.
Last edited by DonNadie on 2019-05-19, 17:46, edited 1 time in total.

RJARRRPCGP
Lunatic
Lunatic
Posts: 312
Joined: 2015-06-22, 19:48
Location: USA (North Springfield, Vermont)
Contact:

Re: Can't install Palemoon, broken packages - libc6 ?

Post by RJARRRPCGP » 2019-05-19, 16:05

DonNadie wrote:
2019-05-19, 12:44
I don't know much about this stuff but my guess is that the Palemoon package wants libc6 2.27-3ubuntu1 as a dependency but I have a newer version, viz. libc6 2.29 installed.
I'm thinking vice-versa, that the one included with Ubuntu Bionic Beaver, has an earlier version of libc6.

User avatar
DonNadie
Newbie
Newbie
Posts: 3
Joined: 2019-05-19, 12:29

Re: Can't install Palemoon, broken packages - libc6 ?

Post by DonNadie » 2019-05-19, 16:23

Whichever way it is, how do I fix it so I can install Palemoon?

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1110
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: Can't install Palemoon, broken packages - libc6 ?

Post by Nigaikaze » 2019-05-19, 17:13

DonNadie wrote:
2019-05-19, 16:23
Whichever way it is, how do I fix it so I can install Palemoon?
You're using Mint 19.1, which is based on Ubuntu 18.04. Make sure that you followed the "For xUbuntu 18.04 run the following:" instructions for adding the repository, because the 18.04 repository is the one you need. It sounds like you added one of the newer repositories instead of that one.
Nichi nichi kore ko jitsu = Every day is a good day.

User avatar
DonNadie
Newbie
Newbie
Posts: 3
Joined: 2019-05-19, 12:29

Re: Can't install Palemoon, broken packages - libc6 ?

Post by DonNadie » 2019-05-19, 17:45

@Nigaikaze - ありがとう Arigatō. Thank you. 10-Q. I stupidly didn't follow the XUbuntu-18.04 instructions for adding the palemoon repository. All is copacetic now that I removed the wrong repository and added the right one.

Post Reply