All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
User avatar
Posts: 355
Joined: 2017-04-20, 21:25

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by Lunokhod » 2019-05-18, 22:56

I don't know if it's helpful but on the graphics side I'm using XFCE and Xorg not Gnome/KDE and Wayland and Nouveau with no xorg.conf.
Mageia apparently (sometimes?) auto generates an xorg.conf, that sort of thing doesn't usually work well on my hardware when I've encountered it, although not in a subtle way.
I tried uninstalling VLC and it's deps so PM was the only video player (although I did have ffmpeg and some other video related things I suppose) and it still kept playing You Tube vids :)
Looking at the PM dev tools console (my new thing to do) while playing a YouTube video with some ads it seemed to "generate" the content, then again at the start of the video proper: [HTTP/2.0 204 No Content 134ms]
So I suppose it makes a video stream according to what spec it thinks you want, based on what is detected, and the ads are done separately. Probably best to take advice from the others who might have more useful suggestions.
Wait, it's all Ohio? Always has been...

User avatar
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-20, 13:17

Hello Everybody,

Good news from me. I think I found the real culprit.
My personal Alsa-Sound configuration (.asoundrc) was a rather complex one. This complex sound configuration actually worked in all 27.x. versions of palemoon and of course every other multimedia software I use, but not in those versions 28.x. of palemoon.
I changed my ALSA configuration to a more simple one and everything is alright now.

The reason for the complex sound configuration was just to split up the sound for two sound cards and also for HDMI output via a beamer.
So, perhaps I had more or less a sound configuration which worked in most cases, but not in all.
I think I should investigate further about alsa configs. ;-)

Thanks to everyone for suggestions,