Palemoon always opens firstrun page.

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
lilgart
Newbie
Newbie
Posts: 3
Joined: 2019-05-02, 14:12

Palemoon always opens firstrun page.

Unread post by lilgart » 2019-05-02, 14:20

Hello,
I have a little problem, my palemoon browser always opens firstrun page every time I open the browser. It never saved my preferences.
And the home page is always back to default, even tho I have changed it hundreds time.

At first, I thought it's a permission issue, so I changed the permission of folder palemoon in home/myuser/.moonchild productions/. But it didnt help me, palemoon still wont save changes I made in preference.

Can anyone help me, please..
thanks in advance

User avatar
karlchen
Moongazer
Moongazer
Posts: 14
Joined: 2019-01-16, 15:55

Re: Palemoon always opens firstrun page.

Unread post by karlchen » 2019-05-03, 16:49

Hello, lilgart.
lilgart wrote:
2019-05-02, 14:20
so I changed the permission of folder palemoon in home/myuser/.moonchild productions/.
You should have posted the exact commandline, which you had used in order to change permissions.
Now we could only guess what you did.

You might like to proceed like this:
  • Close Pale Moon.
  • Open a terminal window.
  • Execute the commandline

    Code: Select all

    sudo chown -R myuser:myuser /home/myuser
    precisely as it has been typed here, with one exception: replace myuser by your real login name.
  • Launch Pale Moon again. - Hopefully it will save your preferences from now on and hopefully the firstrun page will be displayed only once and no longer on later Pale Moon startups.
Regards,
Karl

User avatar
therube
Board Warrior
Board Warrior
Posts: 1006
Joined: 2018-06-08, 17:02

Re: Palemoon always opens firstrun page.

Unread post by therube » 2019-05-03, 17:10

What is the timestamp of prefs.js?

Do you have multiple prefs.js-## (or similar) in your Profile Folder?
Are other files in your Profile Folder dated current?

User avatar
lilgart
Newbie
Newbie
Posts: 3
Joined: 2019-05-02, 14:12

Re: Palemoon always opens firstrun page.

Unread post by lilgart » 2019-05-04, 05:36

karlchen wrote:
2019-05-03, 16:49
You should have posted the exact commandline, which you had used in order to change permissions.
I changed it from file manager (mine is pcmanfm) run in super user mode.
karlchen wrote:
2019-05-03, 16:49
  • Execute the commandline

    Code: Select all

    sudo chown -R myuser:myuser /home/myuser
    precisely as it has been typed here, with one exception: replace myuser by your real login name.
  • Launch Pale Moon again. - Hopefully it will save your preferences from now on and hopefully the firstrun page will be displayed only once and no longer on later Pale Moon startups.
It works, thank you.

User avatar
lilgart
Newbie
Newbie
Posts: 3
Joined: 2019-05-02, 14:12

Re: Palemoon always opens firstrun page.

Unread post by lilgart » 2019-05-04, 05:37

therube wrote:
2019-05-03, 17:10
Do you have multiple prefs.js-## (or similar) in your Profile Folder?
I couldnt even find prefs.js, but never mind it fixed.
Thank you.

User avatar
karlchen
Moongazer
Moongazer
Posts: 14
Joined: 2019-01-16, 15:55

Re: Palemoon always opens firstrun page.

Unread post by karlchen » 2019-05-04, 14:43

Hello, lilgart.
lilgart wrote:
2019-05-04, 05:36
[...]

Code: Select all

sudo chown -R myuser:myuser /home/myuser
[...]
It works, thank you.
Good to learn that your problem has been solved. :)

Background:
Sometimes running a graphical application with root privileges via sudo instead of gksudo or pkexec yields the unwanted side-effect that files / directories in your home directory are no longer owned by you, but by user root. As a consequence, you are no longer permitted to write to your own files.
Recursively re-instating yourself as the owner of everything inside your home directory usually fixes such problems.

Cheers,
Karl

User avatar
adesh
Astronaut
Astronaut
Posts: 671
Joined: 2017-06-06, 07:38

Re: Palemoon always opens firstrun page.

Unread post by adesh » 2019-05-04, 15:27

Never use "sudo". It's dangerous. Unless you own a badge which says qualified-to-use-sudo!

User avatar
karlchen
Moongazer
Moongazer
Posts: 14
Joined: 2019-01-16, 15:55

Re: Palemoon always opens firstrun page.

Unread post by karlchen » 2019-05-04, 20:04

adesh wrote:
2019-05-04, 15:27
Never use "sudo". It's dangerous.
A rule which Linux home users, who usually are their own system administrators, will hardly be able to stick to.
There are cases when you have to get out the screwdriver and open the front hood in order to fix your engine.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23975
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Palemoon always opens firstrun page.

Unread post by Moonchild » 2019-05-04, 20:48

adesh wrote:
2019-05-04, 15:27
Never use "sudo". It's dangerous. Unless you own a badge which says qualified-to-use-sudo!
Except in this case it's required to restore all permissions. not being superuser won't fix this problem ;P
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Post Reply