No sound playback with Pale Moon on Gentoo

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

vannilla
Astronaut
Astronaut
Posts: 667
Joined: 2018-05-05, 13:29

Re: Palemoon on Gentoo

Unread post by vannilla » 2019-03-05, 19:28

segmentation-fault wrote: This means:

IF the pulseaudio USE flag is NOT set, then:

Code: Select all

mozconfig_disable pulseaudio
That's incorrect.

Code: Select all

! use pulseaudio
means that the "pulseaudio" USE flag must be negated, that is, it must have a minus sign prefixed to it, like so:

Code: Select all

-pulseaudio
This is different than not having the pulseaudio flag set.
The reason is that USE flags can be configured both globally and locally. In the first case, a certain USE configuration will be applied to every package (of course if they don't support a certain flag, it's not forcefully applied but just ignored). In the latter case, the configuration applies only to the configured package.
If you ever had to change any file in /etc/portage/package.use (or have package.use as a file instead of directory), those files are used to configure a package locally.
Some packages also define a local USE configuration that is applied before any user-defined configuration. After that there is the global USE variable, then local configurations are applied.
If a package defines "pulseaudio" to be enabled, which means it doesn't have a minus sign prefixed, in its local configuration (not user-defined), then not defining the flag globally or locally (user-defined) means that the package will use pulseaudio.
Of course the viceversa is also true, in that packages can forcefully disable a flag (with the minus sign) and have users enable them in their configurations.

If you use equery, you can see which flags are enabled/disabled for a certain package. If the package is not installed, it will show which flags will be used to build the package.
Using that tool, you can see if you need to explicitly disable a flag or not before installing (or even after installing, by recompiling the package.)

So, beware of "not defining" a variable, as it can drastically change the behaviour of a package. If you aren't sure, always configure your package explicitly with a list of enabled and disabled USE flags.

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 03:36

vannilla wrote:
segmentation-fault wrote: This means:

IF the pulseaudio USE flag is NOT set, then:

Code: Select all

mozconfig_disable pulseaudio
That's incorrect.

Code: Select all

! use pulseaudio
means that the "pulseaudio" USE flag must be negated, that is, it must have a minus sign prefixed to it, like so:

Code: Select all

-pulseaudio
My translation to 'plain english' referred to this piece of code in the 28.4.0 ebuild:

Code: Select all

    if ! use pulseaudio; then
        mozconfig_disable pulseaudio
    fi
and not to the inclusion of the pulseaudio flag in the IUSE variable. You seem to refer to IUSE - even in that case, however, the pulseaudio flag is included in the IUSE variables of all ebuilds of the palemoon overlay that I checked without a prepended minus sign.

My problem is not pulseaudio-related - pulseaudio is currently not running and, as soon as I disable MSE, I can have sound in youtube videos. As soon as I enable it again, sound in youtube is gone - but podcasts continue to work. So it's some kind of misconfiguration between the way audio works in youtube and my ALSA setup.

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 04:06

yami_ wrote:
segmentation-fault wrote:Any debug options to start palemoon and see audio debugging messages
Probably this:

Code: Select all

term% palemoon -console
Started PM with '-console', but did not get anything. Then I went to Tools -> Web Developer -> Error console. There I saw a message saying that '-console' is not a valid option. This explains why I saw no difference.

I went to a youtube page and experimented with and without MSE. There was a warning and an error in both cases:

Code: Select all

Warning: window.controllers is deprecated. Do not use it for UA detection.
Source File: https://www.youtube.com/watch?v=XXXXXXXXX

Error: TypeError: VV.set is not a function
Source File: https://www.youtube.com/yts/jsbin/www-en_US-vflR4S4ml/watch.js
Line: 158
The corresponding line for the error is:

Code: Select all

250],[300,60]],"google_companion_ad_div")){VV.set("ad_type","flash");VV.addService(googletag.companionAds());googletag.enableServices();var b=VV.getSizes();
and it's probably ads related.

So no progress yet... :coffee:

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 04:40

Well there is some progress, after all - but a very embarrassing one... :oops:

It turns out that not all youtube videos have this problem:

With MSE extensions enabled (i.e. with the main checkbox and the two sub-checkboxes being checked all three) and with no pulseaudio running on the system (but still with pulseaudio support enabled through the pulseaudio flag), the following videos do not have sound:

https://www.youtube.com/watch?v=XVnsgxuEZaA
https://www.youtube.com/watch?v=iaPW5v2ztEQ

but this one does have: :shock:

https://www.youtube.com/watch?v=jyK2tBm5LnA

On the one that sound works, I get to see the icon of a speaker on the tab, besides the youtube favicon - on the ones with no sound, no speaker appears on the tab either. So the software (PM? youtube HTML5 player?...) seems to be 'conscious' about the problem... :o

So MSE extensions are the problem and they work with some youtube videos, but not with others... :eh: :coffee:

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6017
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Palemoon on Gentoo

Unread post by New Tobin Paradigm » 2019-03-06, 04:47

Turn off MSE for WebM.. Then give the results for the same test. Mainly, because MSE for WebM is disabled by default for good reason.
Image
- Oh, I've given you no word to keep, Admiral. In my judgment, you simply have no alternative. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

vannilla
Astronaut
Astronaut
Posts: 667
Joined: 2018-05-05, 13:29

Re: Palemoon on Gentoo

Unread post by vannilla » 2019-03-06, 08:05

segmentation-fault wrote:<snip>
Let me rephrase everything:

Code: Select all

if ! use foo
     echo 'foo is not supported'
fi
mean that the flag foo must be "-foo" for the echo command to be executed.
If the global USE (found in make.conf) lists the foo flag as "foo" (without the minus), then that condition is false, so nothing is echoed.
If the global USE flag does not list foo at all, then the package-specific configuration is looked at. That's indeed the IUSE variable.
If IUSE lists "foo" with a minus sign, then "foo is not supported" will be echoed back.
If you add a line to /etc/portage/package.use (or a file inside it if it's a directory) saying "category/package -foo", then no matter what the rest of the system says, "foo is not supported" will be echoed back.

What I'm saying is that not defining a flag means that anything can happen. So either clarify what you mean by "not defining", or explicitly set the flag foo (or pulseaudio, or gtk3, or whatever) to either "foo" or "-foo" in the appropriate place (make.conf, package.use) to add or remove support for the "foo" feature.

We're getting off-track here, but please understand that further Gentoo support can't be given if we can't make clear what USE settings you have.

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 12:58

vannilla wrote: What I'm saying is that not defining a flag means that anything can happen.
Now I see...I fully agree with you about not defining a USE flag. I used the phrase "not defined" quite freely in my 'plain english' translation of the code. Of course I meant "if the USE flag pulseaudio is negated at the time of this check". And of course, whether that USE flag is 'pulseaudio' or '-pulseaudio' is the result of my settings and the IUSE variable in the ebuild. It was not clever to use not defined in the context of explaining the outcome of an IF test here, sorry - my fault.
vannilla wrote: We're getting off-track here, but please understand that further Gentoo support can't be given if we can't make clear what USE settings you have.
This was the first question asked - and answered here. It seems it got buried in the noise, so let me repeat it here:
Walter Dnes wrote:What's the output of emerge -pv palemoon

Code: Select all

emerge -pv palemoon

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ~] www-client/palemoon-28.4.0::palemoon  USE="dbus devtools gtk3 jemalloc official-branding optimize pulseaudio threads -debug -gnome -gtk2 -necko-wifi -valgrind" CPU_FLAGS_X86="sse sse2" 0 KiB
This did not change since then (I rechecked), so we can go on-track now. ;-)

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6017
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Palemoon on Gentoo

Unread post by New Tobin Paradigm » 2019-03-06, 13:04

You could just compile the code with the options as it is intended so that it matches what is officially released and just deal with it having deps.
Image
- Oh, I've given you no word to keep, Admiral. In my judgment, you simply have no alternative. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 13:16

New Tobin Paradigm wrote:Turn off MSE for WebM.. Then give the results for the same test. Mainly, because MSE for WebM is disabled by default for good reason.
I did it - I turned off "MSE for WebM" only. That is "Enable Media Source Extensions (MSE)" and "Enable MSE for MP4 video" remained enabled in the Preferences.

At first I did not restart PM - the results were the same: the two videos that did not play sound, still did not - and the one that did play continued to do so. I noticed that the browser test page at youtube (https://www.youtube.com/html5) still showed all check boxes ticked, even the one for WebM, so I decided to restart PM.

After restarting, the situation is exactly the same as above: the two videos still don't play sound and the one that plays it is still working fine. The youtube test page shows all check boxes ticked too...

Here is a screenschot of the youtube test page and the Video preferences (after the restart):
palemoon-mse-webm.png
New Tobin Paradigm wrote:Mainly, because MSE for WebM is disabled by default for good reason.
I don't remember touching the Video settings in Palemoon (until I was told here to disable them for a test, that is). If you ask me, I would say that all three check boxes are enabled by default... :think:

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: Palemoon on Gentoo

Unread post by yami_ » 2019-03-06, 13:59

segmentation-fault wrote:Started PM with '-console', but did not get anything. Then I went to Tools -> Web Developer -> Error console. There I saw a message saying that '-console' is not a valid option. This explains why I saw no difference.
Yeah, I forgot that -console is not needed for UNIX.
segmentation-fault wrote:At first I did not restart PM - the results were the same: the two videos that did not play sound, still did not - and the one that did play continued to do so. I noticed that the browser test page at youtube (https://www.youtube.com/html5) still showed all check boxes ticked, even the one for WebM, so I decided to restart PM.

After restarting, the situation is exactly the same as above: the two videos still don't play sound and the one that plays it is still working fine. The youtube test page shows all check boxes ticked too...
This is not normal - for me the MSE & WebM VP9 checkbox dissapears when MSE for WebM video is disabled. I do not even need to restart the browser.
segmentation-fault wrote:the following videos do not have sound:

https://www.youtube.com/watch?v=XVnsgxuEZaA
https://www.youtube.com/watch?v=iaPW5v2ztEQ

but this one does have: :shock:

https://www.youtube.com/watch?v=jyK2tBm5LnA
This actually points to MSE for WebM issue, the last video has no audio only WebM streams available:

Code: Select all

[info] Available formats for XVnsgxuEZaA:
format code  extension  resolution note
249          webm       audio only DASH audio   70k , opus @ 50k, 36.60MiB
250          webm       audio only DASH audio   91k , opus @ 70k, 48.38MiB
140          m4a        audio only DASH audio  135k , m4a_dash container, mp4a.40.2@128k, 86.11MiB
171          webm       audio only DASH audio  146k , vorbis@128k, 70.64MiB
251          webm       audio only DASH audio  162k , opus @160k, 92.21MiB
278          webm       256x144    144p   53k , webm container, vp9, 6fps, video only, 17.22MiB
394          mp4        256x144    144p   78k , av01.0.05M.08, 6fps, video only, 24.23MiB
160          mp4        256x144    144p  118k , avc1.4d400b, 6fps, video only, 9.70MiB
395          mp4        426x240    240p  181k , av01.0.05M.08, 6fps, video only, 28.35MiB
242          webm       426x240    240p  250k , vp9, 6fps, video only, 45.87MiB
133          mp4        426x240    240p  264k , avc1.4d4015, 6fps, video only, 20.58MiB
396          mp4        640x360    360p  282k , av01.0.05M.08, 6fps, video only, 51.47MiB
243          webm       640x360    360p  438k , vp9, 6fps, video only, 82.13MiB
397          mp4        854x480    480p  536k , av01.0.05M.08, 6fps, video only, 78.67MiB
134          mp4        640x360    360p  647k , avc1.4d4016, 6fps, video only, 41.99MiB
244          webm       854x480    480p  734k , vp9, 6fps, video only, 84.33MiB
135          mp4        854x480    480p 1057k , avc1.4d4016, 6fps, video only, 68.15MiB
18           mp4        640x360    medium  271k , avc1.42001E, mp4a.40.2@ 96k (44100Hz), 180.41MiB

Code: Select all

[info] Available formats for iaPW5v2ztEQ:
format code  extension  resolution note
249          webm       audio only DASH audio   54k , opus @ 50k, 5.56MiB
250          webm       audio only DASH audio   69k , opus @ 70k, 6.47MiB
140          m4a        audio only DASH audio  128k , m4a_dash container, mp4a.40.2@128k, 14.03MiB
171          webm       audio only DASH audio  133k , vorbis@128k, 11.08MiB
251          webm       audio only DASH audio  135k , opus @160k, 12.55MiB
160          mp4        256x144    144p   86k , avc1.4d400c, 30fps, video only, 2.60MiB
133          mp4        426x240    240p  160k , avc1.4d4015, 30fps, video only, 4.51MiB
134          mp4        640x360    360p  321k , avc1.4d401e, 30fps, video only, 9.89MiB
135          mp4        854x480    480p  579k , avc1.4d401f, 30fps, video only, 17.81MiB
136          mp4        1280x720   720p  973k , avc1.4d401f, 30fps, video only, 31.37MiB
137          mp4        1920x1080  1080p 1865k , avc1.640028, 30fps, video only, 54.88MiB
43           webm       640x360    medium , vp8.0, vorbis@128k, 43.86MiB
18           mp4        640x360    medium  357k , avc1.42001E, mp4a.40.2@ 96k (44100Hz), 39.44MiB
22           mp4        1280x720   hd720  410k , avc1.64001F, mp4a.40.2@192k (44100Hz)

Code: Select all

[info] Available formats for jyK2tBm5LnA:
format code  extension  resolution note
139          m4a        audio only DASH audio   50k , m4a_dash container, mp4a.40.5@ 48k (22050Hz), 985.35KiB
140          m4a        audio only DASH audio  129k , m4a_dash container, mp4a.40.2@128k (44100Hz), 2.56MiB
160          mp4        256x144    DASH video  108k , mp4_dash container, avc1.4d400b, 25fps, video only
133          mp4        426x240    DASH video  242k , mp4_dash container, avc1.4d400c, 25fps, video only
134          mp4        640x360    DASH video  306k , mp4_dash container, avc1.4d401e, 25fps, video only, 1.90MiB
135          mp4        854x480    DASH video 1155k , mp4_dash container, avc1.4d4014, 25fps, video only
136          mp4        1280x720   DASH video 2310k , mp4_dash container, avc1.4d4016, 25fps, video only
137          mp4        1920x1080  DASH video 2625k , mp4_dash container, avc1.640028, 25fps, video only, 13.57MiB
43           webm       640x360    medium , vp8.0, vorbis@128k, 4.44MiB
18           mp4        640x360    medium  238k , avc1.42001E, mp4a.40.2@ 96k (44100Hz), 4.80MiB
22           mp4        1280x720   hd720  827k , avc1.64001F, mp4a.40.2@192k (44100Hz)
cat came back from Berkeley waving flags -- rob pike

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 14:56

Wow, we are about to nail this down... :)

More progress to report: those three video settings seem to be independent of each other, although, from their arrangement, one would expect that not checking "Enable Media Source Extensions (MSE)" would disable both "Enable MSE for MP4 video" and "Enable MSE for WebM video" - but this is not the case. We have thus 8 (=2^3) different settings to test:
  • three for each one setting being enabled alone,
  • three for each one setting being disabled, with the other two ones enabled,
  • one for all three enabled,
  • and one for all three disabled
Are there really so many independent states in the configuration space?

Just out of curiosity, I tested the combination:
  • Enable Media Source Extensions (MSE): not checked
  • Enable MSE for MP4 video: checked
  • Enable MSE for WebM video: not checked
and this one works! :shock: :thumbup: :D

All three videos now play with sound - "Audio backend" is alsa in about:support, pulseaudio USE flag is set, but pulseaudio is not running. The youtube HTML5 test page at https://www.youtube.com/html5 now shows all three MSE-related check boxes in red:
palemoon-mse-webm-2.png
To me, all this means:

You have to make youtube disable the MSE check boxes (i.e. show a red exclamation point in them) - whether you do it by disabling all three check boxes in the Video settings of Palemoon, or by only leaving "Enable MSE for MP4 video" checked, is up to you.

However, I confess that I don't really understand what is the sense of this last configuration - to me not checking "Enable Media Source Extensions (MSE)" should imply unchecking both check boxes below it. Did I encounter a bug after all? ;)

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: Palemoon on Gentoo

Unread post by yami_ » 2019-03-06, 15:15

segmentation-fault wrote:and this one works! :shock: :thumbup: :D
Well, this one works, because it disables MSE, and we already know that disabling MSE fixes your issue. Also, the state of media.mediasource.mp4.enabled and media.mediasource.webm.enabled does not matter when media.mediasource.enabled is false.
segmentation-fault wrote:those three video settings seem to be independent of each other
They are not. This is probably one of the reasons why you should not use GTK3 as the UI-backend for Pale Moon.
EDIT: Try to set media.benchmark.vp9.threshold to something like 999999999, then enable both MSE and MSE for MP4 and disable MSE for WebM, restart the browser and check if YouTube's HTML5 video test says that MSE for WebM is enabled.
cat came back from Berkeley waving flags -- rob pike

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-06, 20:30

yami_ wrote:Try to set media.benchmark.vp9.threshold to something like 999999999, then enable both MSE and MSE for MP4 and disable MSE for WebM, restart the browser and check if YouTube's HTML5 video test says that MSE for WebM is enabled.
Did as requested (Note: media.benchmark.vp9.threshold can be changed in about:config). For youtube, MSE for WebM is disabled, all the rest enabled. Now the two videos that did not have sound are still not playing audio, while the third (the one that worked) still works.
palemoon-mse-webm-3.png
I confess I have no idea, neither of what I tried, nor of what the results now mean... :oops:

But one thing I find hard to believe: that GTK3 is somehow the culprit for not getting checkbox dependencies right in a preferences dialog...

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: Palemoon on Gentoo

Unread post by yami_ » 2019-03-06, 20:49

segmentation-fault wrote:But one thing I find hard to believe: that GTK3 is somehow the culprit for not getting checkbox dependencies right in a preferences dialog...
In both WINAPI and GTK2 versions of the software these two check boxes will be disabled when when you disable the main one.
segmentation-fault wrote:Now the two videos that did not have sound are still not playing audio, while the third (the one that worked) still works.
Hmm... Can you set media.mediasource.webm.audio.enabled to false and try again?
cat came back from Berkeley waving flags -- rob pike

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-07, 00:12

yami_ wrote:
segmentation-fault wrote:But one thing I find hard to believe: that GTK3 is somehow the culprit for not getting checkbox dependencies right in a preferences dialog...
In both WINAPI and GTK2 versions of the software these two check boxes will be disabled when when you disable the main one.
One can file a bug. One can also implement a method that gets triggered as soon as one changes the state of the main checkbox - a method that checks the states of the other two check boxes and toggles them, if it is the wrong one. Now wrap that into a compiler directive that will include it if HAS_GTK3 (or whatever it's called) is set - and move on. Eventually, the bug will be ironed out and the wrapped code will not be necessary anymore.

Give me a patch and I can test it for you here - that's one of the advantages of running Gentoo. :)
yami_ wrote:Hmm... Can you set media.mediasource.webm.audio.enabled to false and try again?
Did it. The result of the youtube test page looks exactly the same as in my last post - same is true for the Video checkboxes in the Preferences dialog. Setup (ALSA, pulseaudio, USE flags etc.) is the same of course. What changes however is this: even without a browser restart, all three videos now have audio! :D :thumbup:

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-07, 00:35

New Tobin Paradigm wrote:You could just compile the code with the options as it is intended so that it matches what is officially released and just deal with it having deps.
One of the things that attracted me to Gentoo back then (more than 10 years ago) was the strong belief of its followers to the saying that "Gentoo is about choice". Personally, I still strongly support this vision - but maybe I am part of a dying minority...

Choices are there to be part of our decisions. If I am supposed to compile everything with the "official" choices - then what the hell are choices there for?

:arrow: [EDIT] This blog entry says it better: Gentoo Ought to be About Choice:
There will always be conflict when we need to pick a default, but we must view defaults as conveniences and not endorsements.

vannilla
Astronaut
Astronaut
Posts: 667
Joined: 2018-05-05, 13:29

Re: Palemoon on Gentoo

Unread post by vannilla » 2019-03-07, 07:58

I agree with you about choice (and the Pale Moon motto is "your browser, your way" too), but when we try to solve a problem, the first thing that is always checked (not just in Pale Moon, but in every software ever) is the user's configuration.
Are we sure the problem is the browser, and not some setting?
That's why you have to test this issue using the default build configuration.
As I said before, it might be a GTK+3 problem, and the only way to know that is having you build Pale Moon with the GTK+2 toolkit and test it again.
The problem exists only for you, as reported earlier, so you are the only one that can run the tests we suggest.
If it turns out the problem is not the GTK+ version, then it might be a real bug in the browser. But until you compile Pale Moon with the default configuration and test it out, there's no way to know and thus no way to offer a solution.
Same for every option you added or changed to the default configuration.

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: Palemoon on Gentoo

Unread post by yami_ » 2019-03-07, 12:04

segmentation-fault wrote:Did it. The result of the youtube test page looks exactly the same as in my last post - same is true for the Video checkboxes in the Preferences dialog. Setup (ALSA, pulseaudio, USE flags etc.) is the same of course. What changes however is this: even without a browser restart, all three videos now have audio! :D :thumbup:
So it looks like that media.mediasource.webm.audio.enabled might be the only preference you need to modify to get audio in those YouTube videos. You should be able to reset both media.benchmark.vp9.threshold and media.mediasource.webm.enabled to their default values and still have the audio. Now, if you want to do more testing enable media.mediasource.webm.audio.enabled, go to this website and check if you get the sound while playing those samples. Normally only the "CAF" sample will not work. I suspect that in your case the "OPUS" and "WebMv2" samples would also not work.
cat came back from Berkeley waving flags -- rob pike

User avatar
segmentation-fault
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2019-01-31, 16:32

Re: Palemoon on Gentoo

Unread post by segmentation-fault » 2019-03-07, 14:17

yami_ wrote:So it looks like that media.mediasource.webm.audio.enabled might be the only preference you need to modify to get audio in those YouTube videos.
To get sound in those youtube videos that offer WebM, both options media.mediasource.webm.audio.enabled and media.mediasource.webm.enabled should be disabled. I cannot have media.mediasource.webm.enabled enabled and get sound in them, I have to disable it. This unticks the "Enable MSE for WebM video" in Preferences -> Content under "Video", it seems. But, just unticking the checkbox for "Enable MSE for WebM video" may not be enough - I have to make sure that media.mediasource.webm.audio.enabled and media.mediasource.webm.enabled are both disabled in about:config.

media.benchmark.vp9.threshold can be set back to its default (150). I don't know, however, why it tells me that media.benchmark.vp9.fps and media.benchmark.vp9.versioncheck are now 'user_set' and not default, with values 206 and 3 respectively...I certainly did not touch them and don't know what their defaults are.
yami_ wrote: Now, if you want to do more testing enable media.mediasource.webm.audio.enabled, go to this website and check if you get the sound while playing those samples. Normally only the "CAF" sample will not work. I suspect that in your case the "OPUS" and "WebMv2" samples would also not work.
No matter which one of the 4 possible enabled/disabled configurations for both media.mediasource.webm.audio.enabled and media.mediasource.webm.enabled I choose, the result on that page is the same: I can listen to MP3 audio only - the rest shows 'Playing' when clicked, the speaker icon appears for a short moment on the tab, but then it disappears and no sound can be heard (no progress is also seen in the audio player on the page). Opening Tools -> Web Developer -> Web Console, I see these errors:

Code: Select all

Media resource https://hpr.dogphilosophy.net/test/opus.opus could not be decoded.
Media resource https://hpr.dogphilosophy.net/test/weba.weba could not be decoded.
Media resource https://hpr.dogphilosophy.net/test/webmv2.webm could not be decoded.
Media resource https://hpr.dogphilosophy.net/test/ogg.ogg could not be decoded.
Media resource https://hpr.dogphilosophy.net/test/wav.wav could not be decoded.
Media resource https://hpr.dogphilosophy.net/test/flac.flac could not be decoded.
HTTP “Content-Type” of “audio/x-caf” is not supported. Load of media resource https://hpr.dogphilosophy.net/test/cafopus.caf failed.
Cannot play media. No decoders for requested formats: audio/x-caf
While the error for CAF was expected, the rest makes me suspicious. Do I miss some special codecs package?

yami_
Astronaut
Astronaut
Posts: 505
Joined: 2018-04-26, 11:05

Re: Palemoon on Gentoo

Unread post by yami_ » 2019-03-07, 15:27

segmentation-fault wrote: Do I miss some special codecs package?
If I correctly understand how UXP decodes audio then support for at least opus and vorbis should be build in. FFmpeg can probably be used as a fallback. What USE flags did you use while building FFmpeg?
cat came back from Berkeley waving flags -- rob pike

Post Reply