No webm/vp9/opus support?

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

tooshorttoolong
Fanatic
Fanatic
Posts: 130
Joined: 2017-09-11, 14:28

No webm/vp9/opus support?

Unread post by tooshorttoolong » 2019-02-10, 10:21

Hello, when I try to play the video on this page: https://fosdem.org/2019/schedule/event/ ... ster_game/
I’m told "No video with supported format and MIME type found".

If I use youtube-dl to get the video I get a webm with vp9 and opus inside.

I have MSE enabled, PM 28.3.1 64 bit (official build), on Gentoo.

jars_
Fanatic
Fanatic
Posts: 241
Joined: 2016-12-27, 00:12

Re: No webm/vp9/opus support?

Unread post by jars_ » 2019-02-10, 11:01

on my Win7 - video plays. but Console has an errors

Code: Select all

Загрузка смешанного (небезопасного) отображаемого содержимого «http://bofh.nikhef.nl/events/FOSDEM/2019/K.1.105/blockbuster_game.webm» на защищённой странице
- wich is actualy a video link Mixed content - Warnings in Web Console
Check your setting(about:config) filter "mixed"
security.mixed_content.block_active_content
security.mixed_content.block_display_content

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3881
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: No webm/vp9/opus support?

Unread post by Night Wing » 2019-02-10, 11:11

@ tooshorttoolong

When I clicked on the you link you provided, it took me to the site. Once on the page I clicked on the start button for the video, it immediately enlarged and the 50 minute video started to play for me (with audio) after waiting about 6 seconds of time.

I'm using the video settings for linux Pale Moon (28.3.1) which in my case for video are below:

Under Video (which are all enabled with a check mark):

1) Enable Media Source Extensions (MSE)
2) Enable MSE for MP4 video
3) Enable MSE for WebM video

I don't use Gentoo. I'm using 64 bit linux Pale Moon 28.3.1 running in 64 bit linux Mint 19.1 (Tessa) Xfce.

BTW, thanks for providing the direct clickable link.
Last edited by Night Wing on 2019-02-10, 13:24, edited 1 time in total.
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

tooshorttoolong
Fanatic
Fanatic
Posts: 130
Joined: 2017-09-11, 14:28

Re: No webm/vp9/opus support?

Unread post by tooshorttoolong » 2019-02-10, 12:58

jars_ wrote:on my Win7 - video plays. but Console has an errors
I do get this in the console:
I see some of the mirrors are http, not https… However security.mixed_content.block_display_content is set to false, and setting the other setting to false too does not change anything.

@Night Wing, thanks for testing. I wonder why it’s working for you and not for me.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3881
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: No webm/vp9/opus support?

Unread post by Night Wing » 2019-02-10, 13:18

tooshorttoolong wrote:@Night Wing, thanks for testing. I wonder why it’s working for you and not for me.
Linux distros are "different" from one another. You're using Gentoo and I'm using Mint. When I installed Mint, the codecs for video and sound were done by default upon installation for Mint. And when the video was playing for me, my uBlock Origin 1.16.4.8 adlocker was enabled too.
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23690
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: No webm/vp9/opus support?

Unread post by Moonchild » 2019-02-10, 16:41

The people at fosdem clearly didn't get the memo how to use CSP.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it: Image

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
"I'm afraid you have me mistaken for someone who can be shamed by a child." -- Quillspawn

ron_1
Board Warrior
Board Warrior
Posts: 1996
Joined: 2012-06-28, 01:20

Re: No webm/vp9/opus support?

Unread post by ron_1 » 2019-02-10, 17:22

FTR, it works for me also on Devuan ascii.

Walter Dnes
Astronaut
Astronaut
Posts: 603
Joined: 2015-07-30, 20:29
Location: Vaughan, ON, Canada

Re: No webm/vp9/opus support?

Unread post by Walter Dnes » 2019-02-10, 19:32

I'm running Gentoo, and it works for me. I believe that PM talks to ffmpeg, so it may be a problem with ffmpeg on your system. "emerge -pv ffmpeg" shows that I have the following USE flags enabled...
X bzip2 encode gpl hardcoded-tables network opengl postproc threads truetype vaapi vpx webp x264 x265 zlib

The "vpx webp x264 x265" flags, and especially "vpx webp" are probably the most critical flags. Does your ffmpeg have them enabled?
There's a right way
There's a wrong way
And then there's my way

Walter Dnes
Astronaut
Astronaut
Posts: 603
Joined: 2015-07-30, 20:29
Location: Vaughan, ON, Canada

Re: No webm/vp9/opus support?

Unread post by Walter Dnes » 2019-02-10, 19:57

One more item; there is an "opus" flag, but I don't have it enabled for ffmpeg.
There's a right way
There's a wrong way
And then there's my way

tooshorttoolong
Fanatic
Fanatic
Posts: 130
Joined: 2017-09-11, 14:28

Re: No webm/vp9/opus support?

Unread post by tooshorttoolong » 2019-02-10, 20:44

Walter Dnes wrote:The "vpx webp x264 x265" flags, and especially "vpx webp" are probably the most critical flags. Does your ffmpeg have them enabled?
Yep, I have vpx and opus enabled. webp is not enabled but I doubt it is needed since it’s for still pictures.
mpv which depends on ffmpeg is perfectly able to play the video.

However maybe the problem is I have ffmpeg 4.1 installed and not 3.3.6?

Post Reply