Youtube videos complaining about lack of support

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
coltson
Moongazer
Moongazer
Posts: 8
Joined: 2018-10-06, 13:03

Youtube videos complaining about lack of support

Unread post by coltson » 2018-12-21, 14:02

Hello, I have been trying to run youtube videos on palemoon and I keep receiving a message similar to this:
At the moment, your web browser does not recognize the available video formats. Click here to see the frequently asked questions about videos in html5 format
What can be done (if anything) to solve this issue? I am running palemoon 27.9.4SSE. And I cannot move to a 28.x palemoon

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1072
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: Youtube videos complaining about lack of support

Unread post by Nigaikaze » 2018-12-21, 14:21

Are you still running this on Ubuntu 10.04?

Posting the output of Help > Troubleshooting Information might help, but there's no guarantee that we'll be able to find a solution for an out-of-date Pale Moon running on an out-of-date OS.
Nichi nichi kore ko jitsu = Every day is a good day.

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1553
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: Youtube videos complaining about lack of support

Unread post by trava90 » 2018-12-21, 15:16

Other than upgrading to a supported distro and Pale Moon 28 there’s not likely to be anything you can do. Are the FFmpeg packages installed on your system?

roytam1
Fanatic
Fanatic
Posts: 153
Joined: 2015-03-11, 07:01
Location: Hong Kong

Re: Youtube videos complaining about lack of support

Unread post by roytam1 » 2018-12-21, 16:08

trava90 wrote:Other than upgrading to a supported distro and Pale Moon 28 there’s not likely to be anything you can do. Are the FFmpeg packages installed on your system?
since he is running SSE edition, 28 is no-go for SSE-only system?

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3877
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Youtube videos complaining about lack of support

Unread post by Night Wing » 2018-12-21, 17:14

FWIW, yesterday I upgraded to 64 bit linux Mint 19.1 (Tessa) Xfce and I use 64 bit linux Pale Moon (28.2.2). I have no problems viewing YouTube videos. No prompts from YouTube at all. Since I prefer the new YouTube interface where I can access YT's "Dark Theme", I changed my user agent since the default Pale Moon user agent for YT will not show the new YT interface. For YT, I use the user agent below in "about:config" (without the quote marks). In the Search field, I type the following:

Code: Select all

general.useragent.override.youtube.com
And then change the default YouTube user agent for YouTube to the one below:

Code: Select all

Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0 (Pale Moon)
Linux Mint 19.1 (Tessa) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

User avatar
coltson
Moongazer
Moongazer
Posts: 8
Joined: 2018-10-06, 13:03

Re: Youtube videos complaining about lack of support

Unread post by coltson » 2018-12-24, 12:26

Nigaikaze wrote:Are you still running this on Ubuntu 10.04?

Posting the output of Help > Troubleshooting Information might help, but there's no guarantee that we'll be able to find a solution for an out-of-date Pale Moon running on an out-of-date OS.
Yes, as I said previously, moving out is not simple.

The output:
Application Basics
------------------

Name: Pale Moon
Version: 27.9.4SSE
Build ID: 20180717181801
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.9.4SSE
OS: Linux 2.6.32-38-generic
Multiprocess Windows: 0/1 (default: false)
Safe Mode: false

Extensions
----------

Graphics
--------

Adapter Description: Tungsten Graphics, Inc -- Mesa DRI Intel(R) G41 GEM 20091221 2009Q4 x86/MMX/SSE2
Device ID: Mesa DRI Intel(R) G41 GEM 20091221 2009Q4 x86/MMX/SSE2
Driver Version: 2.1 Mesa 7.7.1
GPU Accelerated Windows: 0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version Mesa 7.10.3 or newer.
Vendor ID: Tungsten Graphics, Inc
WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version Mesa 7.10.3 or newer.
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 13312
browser.cache.disk.smart_size_cached_value: 266240
browser.cache.disk.smart_size.enabled: false
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.download.importedFromSqlite: true
browser.places.importBookmarksHTML: false
browser.places.smartBookmarksVersion: 4
browser.search.useDBForOrder: true
browser.startup.homepage: /media/34GB/backup/bookmarks3.html
browser.startup.homepage_override.buildID: 20180717181801
browser.startup.homepage_override.mstone: 3.4.2
dom.mozApps.used: true
extensions.lastAppVersion: 27.9.4SSE
general.useragent.override.youtube.com: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0 (Pale Moon)
image.http.accept: image/webp,image/jxr,image/png,image/*;q=0.8,*/*;q=0.5
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1545653413
places.history.expiration.transient_current_max_pages: 10000
plugin.importedState: true
plugin.soname.list: libXt.so:libXext.so
privacy.cpd.formdata: false
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1544106741

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 1

Library Versions
----------------

NSPR
Expected minimum version: 4.16
Version in use: 4.16

NSS
Expected minimum version: 3.32.1
Version in use: 3.32.1

NSSSMIME
Expected minimum version: 3.32.1
Version in use: 3.32.1

NSSSSL
Expected minimum version: 3.32.1
Version in use: 3.32.1

NSSUTIL
Expected minimum version: 3.32.1
Version in use: 3.32.1

Experimental Features
---------------------
Are the FFmpeg packages installed on your system?
Not the packages, but I do have ffmpeg here.
In the Search field, I type the following:

Code: Select all
general.useragent.override.youtube.com


And then change the default YouTube user agent for YouTube to the one below:

Code: Select all
Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0 (Pale Moon)
Unfortunatelly, it did not work.

Post Reply