No audio in html-pages

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
Michel
Newbie
Newbie
Posts: 5
Joined: Mon, 03 Dec 2018, 18:36

No audio in html-pages

Unread postby Michel » Mon, 03 Dec 2018, 18:48

Hi all,

my Palemoon (28.2.1 64bit OpenSuSE Tumbleweed) doesn't play audio, when in an html-page inserted like the following:



Code: Select all

<html>
  <head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8">
    <title>Titeltext</title>
  </head>
  <body bgcolor="#000000" alink="#006600" vlink="#993300" text="#996633" link="#996633">
    <br>
    <br>
    <br>
   
    <audio autoplay preload="auto" hidden="true" style=" width:0px;">
   <source src="audio/Wirwuenschen.mp3" type="audio/mp3">
   Your browser does not support the audio element.
</audio><br />
   
   <br>
    <table cellspacing="2" cellpadding="10" border="0" align="center" width="90%">
      <tbody>
        <tr>
          <td align="center" valign="top"><a href="index.html"><img
                alt="" src="bilder/12345.jpg" border="0" width="870"
                height="850"></a></td>
        </tr>
........      </tbody>
    </table>
    <br>
    <br>
  </body>
  <meta http-equiv="refresh" content="2 URL=index.html">
</html>




I tried several different possibilities from different sources, wikis etc., but none works.

Anybody an idea for the reason? Konqueror plays the mp3-file well. I don't know, wether Firefox does it, because of the missing audio-support for Linux and i don't want to install the pulseaudio-stuff, as it is senseless rag.

User avatar
therube
Astronaut
Astronaut
Posts: 683
Joined: Fri, 08 Jun 2018, 17:02

Re: No audio in html-pages

Unread postby therube » Tue, 04 Dec 2018, 02:06

Try:

Code: Select all

<audio autoplay loop>
      <source src="RamblingSailor.ogg">
</audio>

User avatar
Michel
Newbie
Newbie
Posts: 5
Joined: Mon, 03 Dec 2018, 18:36

Re: No audio in html-pages

Unread postby Michel » Tue, 04 Dec 2018, 06:50

Thanks for the hint. But the reason was different.

The reason, why it didn't work (with the inspector PM seems to ignore the audio-part) was a entry in the config of PM. With about:config one finds two autoplay-entries, which are set to "false". Setting them to "true" makes it working.

Thanks for the help.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: bellarmin, Frasier and 9 guests