Making PM default browser on Debian

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
loxodont
Lunatic
Lunatic
Posts: 459
Joined: Sat, 26 Jul 2014, 23:03
Location: Mare Serenitatis

Making PM default browser on Debian

Unread postby loxodont » Tue, 09 Oct 2018, 19:51

There's a question on the german language board about making (and keeping) Pale Moon the default browser on Debian (stable)
viewtopic.php?f=7&t=20624

berni says he installed Pale Moon deb package and set it to default browser when asked, but it seems to switch back to Firefox somehow ...
I never used Debian and don't know the mentioned terminal commands, so can anyone here help with this?
I'll translate it then to the original post.
thx

User avatar
stevepusser
Lunatic
Lunatic
Posts: 449
Joined: Sat, 01 Aug 2015, 18:33
Location: California

Re: Making PM default browser on Debian

Unread postby stevepusser » Thu, 11 Oct 2018, 20:15

loxodont wrote:There's a question on the german language board about making (and keeping) Pale Moon the default browser on Debian (stable)
viewtopic.php?f=7&t=20624

berni says he installed Pale Moon deb package and set it to default browser when asked, but it seems to switch back to Firefox somehow ...
I never used Debian and don't know the mentioned terminal commands, so can anyone here help with this?
I'll translate it then to the original post.
thx


Possibly he may have to set it as the default browser in the desktop environment's settings, or as the default "x-www-browser" in the Debian alternatives system (galternatives is a nice GUI for this; KDE users can use kalternatives)

User avatar
loxodont
Lunatic
Lunatic
Posts: 459
Joined: Sat, 26 Jul 2014, 23:03
Location: Mare Serenitatis

Re: Making PM default browser on Debian

Unread postby loxodont » Fri, 12 Oct 2018, 09:35

thx steve, I'll tell him.

User avatar
berni
Moongazer
Moongazer
Posts: 14
Joined: Tue, 02 Oct 2018, 10:08

Re: Making PM default browser on Debian

Unread postby berni » Fri, 04 Jan 2019, 11:58

I'm answering here directly, 'caus I think it's easier without having loxodont as a proxy (thanks for that anyway).

Possibly he may have to set it as the default browser in the desktop environment's settings, or as the default "x-www-browser" in the Debian alternatives system (galternatives is a nice GUI for this; KDE users can use kalternatives)


This is not, what I'm looking for. I don't want to change the system wide default browser (which influences other users), but the default browser on my local account.

Meanwhile I found out, that PM creates a file called ~/.config/mimeapps.list when I click on "Make Pale Moon the default browser" in Settings->Advanced.

With the command "xdg-settings get default-web-browser" I can query the default browser. Here some protocol:

$> xdg-settings get default-web-browser
firefox-esr.desktop
[Now I clicked on "Make Pale Moon the default browser"]
$> xdg-settings get default-web-browser
/usr/bin/xdg-mime: 912: local: Moon-XYVHQZ.desktop: bad variable name
firefox-esr.desktop


Investigating on that error message, I found out that the space in "Pale Moon" in the file ~/.config/mimeapps.list causes the trouble. The shell script /usr/bin/xdg-mime seems to consider that space as a separator and not part of the entry. Now I replaced that space by a minus and "xdg-settings get default-web-browser" works:

$> xdg-settings get default-web-browser
userapp-Pale-Moon-XYVHQZ.desktop


But still firefox is lounched, probably, because the minus-sign is wrong and PM cannot be found.

vannilla
Lunatic
Lunatic
Posts: 257
Joined: Sat, 05 May 2018, 13:29

Re: Making PM default browser on Debian

Unread postby vannilla » Fri, 04 Jan 2019, 12:26

Isn't that entry the name of a file?
You'd also have to change the file's name to match the changes you applied.
(I'm not 100% sure it's the cause since my system does it in a different way, but it's worth taking a look.)

User avatar
Moonraker
Keeps coming back
Keeps coming back
Posts: 938
Joined: Wed, 30 Sep 2015, 23:02
Location: Lincolnshire.UK.

Re: Making PM default browser on Debian

Unread postby Moonraker » Fri, 04 Jan 2019, 12:38

Have you tried uninstalling firefox and then see what happens.?.perhaps not much help but maybe a reinstall would help.sorry its not much help.
Xenial puppy linux 32-bit.
Pale moon 27.9.0

User avatar
murga
New to the forum
New to the forum
Posts: 2
Joined: Thu, 06 Dec 2018, 08:33

Re: Making PM default browser on Debian

Unread postby murga » Fri, 04 Jan 2019, 13:05

File on path /etc/alternatives/x-www-browser link to /usr/bin/firefox or palemoon

User avatar
berni
Moongazer
Moongazer
Posts: 14
Joined: Tue, 02 Oct 2018, 10:08

Re: Making PM default browser on Debian

Unread postby berni » Fri, 04 Jan 2019, 13:28

vannilla wrote:Isn't that entry the name of a file?
You'd also have to change the file's name to match the changes you applied.
(I'm not 100% sure it's the cause since my system does it in a different way, but it's worth taking a look.)


I found this file at ~/.local/share/applications/ renamed it and it works, when I use xdg-open but unfortunatley not, when clicking a link in my email program... It seems to use a different approch to find out about the default browser...

As a side note: I think, pale moon should rename that file and the entries in mimeapps.list too. In my eyes the space there is a bug.

Now, I will continue to investigate, how my e-mail program starts the default browser...

PS: The e-mail program has some preferences which I changed from "firefox" to "xdg-open". Now it works.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 4 guests