Problem with "Preferences" in version 28 Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

greyowl
Fanatic
Fanatic
Posts: 152
Joined: Sun, 06 Oct 2013, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread postby greyowl » Mon, 20 Aug 2018, 01:07

spacy01 wrote:Final solution! In about:config find browser.preferences.animateFadeIn, set as true. Problem solved! :thumbup:


The solution works for me with antiX. Brilliant!
Thank you for the help.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Mon, 20 Aug 2018, 03:55

@greyowl, you are welcome! :thumbup:

User avatar
therube
Astronaut
Astronaut
Posts: 500
Joined: Fri, 08 Jun 2018, 17:02

Re: Problem with "Preferences" in version 28

Unread postby therube » Mon, 20 Aug 2018, 12:27

spacy01 wrote:Final solution! In about:config find browser.preferences.animateFadeIn, set as true. Problem solved!

Curious, what was it that led you to come up with that Pref?

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Mon, 20 Aug 2018, 12:35

I was tired and desperate, just type "preferences" in about:config search box. There was just a few results i started with first one...

User avatar
LS650V
Newbie
Newbie
Posts: 4
Joined: Sun, 19 Aug 2018, 08:50

Re: Problem with "Preferences" in version 28

Unread postby LS650V » Mon, 20 Aug 2018, 23:44

Thanks spacy01. Your solution also worked for me in Lubuntu 16.04 LTS.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Tue, 21 Aug 2018, 04:09

@LS650V, you are welcome, glad that worked! :thumbup:

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21930
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Problem with "Preferences" in version 28

Unread postby Moonchild » Tue, 21 Aug 2018, 13:52

animateFadein is a Mac-only setting. It should not be used on other operating systems. Why was it set to true?
Last edited by Moonchild on Tue, 21 Aug 2018, 13:53, edited 1 time in total.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

greyowl
Fanatic
Fanatic
Posts: 152
Joined: Sun, 06 Oct 2013, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread postby greyowl » Tue, 21 Aug 2018, 13:55

Moonchild wrote:animateFadein is a Mac-only setting. It should not be used on other operating systems. Why was it set to true?


Is this a bug that will be fixed in the next update?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21930
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Problem with "Preferences" in version 28

Unread postby Moonchild » Tue, 21 Aug 2018, 14:00

greyowl wrote:Is this a bug that will be fixed in the next update?

No it's not a bug - the default is false.

I was asking how come that some people on Linux have this set to a different value than default?
Last edited by Moonchild on Tue, 21 Aug 2018, 14:02, edited 1 time in total.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

greyowl
Fanatic
Fanatic
Posts: 152
Joined: Sun, 06 Oct 2013, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread postby greyowl » Tue, 21 Aug 2018, 14:03

Moonchild wrote:
greyowl wrote:Is this a bug that will be fixed in the next update?

No it's not a bug - the default is false.


Since changing the setting to true corrects the problem with Preferences, does there not need to be something changed in PM to correct the problem with preferences.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3529
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problem with "Preferences" in version 28

Unread postby Night Wing » Tue, 21 Aug 2018, 14:12

Moonchild wrote:I was asking how come that some people on Linux have this set to a different value than default?


I have the default settings which come with 64 bit linux Pale Moon 28.0.0 which I use in 64 bit linux Mint 19 and Preferences work without any problems. Maybe Mac's act differently in linux Pale Moon since all of my computers were originally Windows computers which came with Windows 7.
Linux Mint 19 (Tara) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32-Bit windows Pale Moon

greyowl
Fanatic
Fanatic
Posts: 152
Joined: Sun, 06 Oct 2013, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread postby greyowl » Tue, 21 Aug 2018, 14:19

Moonchild wrote:animateFadein is a Mac-only setting. It should not be used on other operating systems. Why was it set to true?


Sorry. I did not understand your post.

There is a problem with Linux 32 bit PM where in Preferences in non-functional. It was discovered by Spacy01, that changing the setting to true corrected the problem with Preferences so that it now functions correctly.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Tue, 21 Aug 2018, 14:33

Moonchild wrote:animateFadein is a Mac-only setting. It should not be used on other operating systems. Why was it set to true?


@Moonchild, i'm sorry, but i don't get it...

I never used Mac on my life, from ten years i use only Linux distros (current one is Manjaro with Xfce, 64-bit), and i had never heard about animateFadein before! I fixed my problem by incident, when change it, and share the solution! When i change this animateFadein to true, preferences window became responsive! I have no idea why is that happened!

Also, this is only partially fix of the problem, some buttons still are not clickable, counter on install addons button still dosen't work, and can't type in some text fields. Please, look at it!

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Tue, 21 Aug 2018, 14:36

Also, everything works on live usb with Linux Mint 64-bit with xfce, and on Linux Mint Debian Edition 64-bit with Cinnamon. On Manjaro live usb, problem persist!

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1494
Joined: Mon, 20 May 2013, 18:19
Location: Earth
Contact:

Re: Problem with "Preferences" in version 28

Unread postby trava90 » Tue, 21 Aug 2018, 14:37

greyowl wrote:There is a problem with Linux 32 bit PM where in Preferences in non-functional. It was discovered by Spacy01, that changing the setting to true corrected the problem with Preferences so that it now functions correctly.

It's not limited to 32-bit (spacy01 is using 64-bit build), nor is it reproducible on all systems (I can't reproduce the problem on any of the 5 systems I've tried).

spacy01 wrote:Also, this is only partially fix of the problem, some buttons still are not clickable, counter on install addons button still dosen't work, and can't type in some text fields. Please, look at it!

@spacy01 do all these problems still manifest themselves in a new profile with default preferences?
Last edited by trava90 on Tue, 21 Aug 2018, 14:37, edited 1 time in total.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Tue, 21 Aug 2018, 14:41

Yes, this issues exist, with brand new profile. They exist even on live usb session...

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1494
Joined: Mon, 20 May 2013, 18:19
Location: Earth
Contact:

Re: Problem with "Preferences" in version 28

Unread postby trava90 » Tue, 21 Aug 2018, 14:50

Are there any messages displayed in the error console or terminal window (if Pale Moon is started from the terminal) when trying to switch tabs in the preferences?

Also are you using the latest release of Manjaro? One of the systems I tried to reproduce this issue on is a fully updated 64-bit Manjaro XFCE.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Tue, 21 Aug 2018, 15:17

No, there is no errors nor in terminal, nor in the browser console. Actually, the browser preferences and other stuff works, but the changes not be displayed, until you reopen the window.

Yes, i use the latest Manjaro and i update it regularly! When i figured out, that actually Pale Moon works, and the problem persist even on live usb session, i suspect the integrated intel video and the Manjaro's X settings. But i'm not sure how to check it and how to compare it with Debian's driver version and X settings...

smoki
Apollo supporter
Apollo supporter
Posts: 30
Joined: Fri, 19 Jan 2018, 05:34

Re: Problem with "Preferences" in version 28

Unread postby smoki » Tue, 21 Aug 2018, 15:55

AFAIK Debian use modesetting ddx by default for intel GPUs, but if you are using intel ddx on Manjaro these two drivers certainly behave differently (different pluses/minuses but different bugs too)
Last edited by smoki on Tue, 21 Aug 2018, 15:58, edited 2 times in total.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Wed, 22 Aug 2018, 07:52

Finally, i figured it out! :) It wasn't Pale Moon issue...

I uninstall default intel video-linux driver and install video-vesa driver, from "manjaro settings > hardware configuration" and generate xorg.conf file, now everything works just fine, regardless 'animateFadein' setting. :)


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 7 guests