Problem with "Preferences" in version 28 Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Wed, 22 Aug 2018, 12:38

With AUR version of the xf86-video-intel, Pale Moon works like a charm! ;)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21930
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Problem with "Preferences" in version 28

Unread postby Moonchild » Wed, 22 Aug 2018, 14:32

I'm sorry if I misunderstood the issue - I read it like the issue would occur if you had animateFadeIn set to true, and not that it would be solved by it.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Wed, 22 Aug 2018, 14:52

Moonchild wrote:I'm sorry if I misunderstood the issue - I read it like the issue would occur if you had animateFadeIn set to true, and not that it would be solved by it.


It's ok! :) Finally i figured it out. It was the xf86-video-intel driver. Seems like the git version is newer then Manjaro's repositories version. With the new version of driver, all problems gone. Just took me a lot of time to find the root of issues. Thanks on all, that tried to help me. :thumbup:
Last edited by spacy01 on Wed, 22 Aug 2018, 14:53, edited 1 time in total.

User avatar
therube
Astronaut
Astronaut
Posts: 500
Joined: Fri, 08 Jun 2018, 17:02

Re: Problem with "Preferences" in version 28

Unread postby therube » Wed, 22 Aug 2018, 15:08

Heh, OK, curious again.
What pointed you towards the video driver issue?


(On my end, Win7, I just updated my Intel video driver, & surprisingly to me, it does seem to positively affected video playback.)

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Wed, 22 Aug 2018, 15:28

Well... Desperate times, desperate measures... :D

When debug something, started from the most common reasons, and go to less common. So, i started with PM in safe mod, delete cache, create a new profile, start checking about:config, type in forums, tried different distros (check previous comments) and see that in one new arch based distro, called Anarchy Linux, PM works correctly, start check settings, packages, drivers and found that they not use xf86-video-intel driver... So i uninstall xf86-video-intel, generate xorg.conf file, to be able to start DE, and voila - all PM functions start to working correctly. I keep digging and found that AUR version of xf86-video-intel driver is different (newer) than Manjaro repos... I compile and install new driver and that was it. :thumbup:

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3529
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problem with "Preferences" in version 28

Unread postby Night Wing » Wed, 22 Aug 2018, 16:39

@ spacy01

Off-topic:
With your previous comments on how you solved your problem with linux Pale Moon, I'd say you would make an excellent detective if you were interested in that field.
Linux Mint 19 (Tara) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32-Bit windows Pale Moon

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Wed, 22 Aug 2018, 16:47

@Night Wing, thank you! :thumbup: But perhaps i'm just a stubborn... :D

greyowl
Fanatic
Fanatic
Posts: 152
Joined: Sun, 06 Oct 2013, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread postby greyowl » Wed, 22 Aug 2018, 17:35

@Spacy01
I used your earlier solution-- In about:config find browser.preferences.animateFadeIn, set as true--and now the Preferences is working fine.

I am however curious about your second solution and whether it is a better solution and could be applied to my laptop.

I am a novice so I don't know how to trouble shoot and change video drivers. I am using a Dell Latitude D610 laptop and Linux antiX 32 bit.

Is there really any advantage for me to try to go further with this issue?

Thanks for the advice.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3529
Joined: Mon, 03 Oct 2011, 10:19
Location: Texas, USA

Re: Problem with "Preferences" in version 28

Unread postby Night Wing » Wed, 22 Aug 2018, 17:42

spacy01 wrote:But perhaps i'm just a stubborn... :D


Off-topic:
Mixed in with being tenacious. ;)

adjective: tenacious

1) tending to keep a firm hold of something; clinging or adhering closely.

"a tenacious grip"

2) not readily relinquishing a position, principle, or course of action; determined.

"you're tenacious and you get at the truth"
Linux Mint 19 (Tara) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1, 64 Bit (Backup OS) with 32-Bit windows Pale Moon

User avatar
stevepusser
Lunatic
Lunatic
Posts: 387
Joined: Sat, 01 Aug 2015, 18:33
Location: California

Re: Problem with "Preferences" in version 28

Unread postby stevepusser » Wed, 22 Aug 2018, 19:17

greyowl wrote:@Spacy01
I used your earlier solution-- In about:config find browser.preferences.animateFadeIn, set as true--and now the Preferences is working fine.

I am however curious about your second solution and whether it is a better solution and could be applied to my laptop.

I am a novice so I don't know how to trouble shoot and change video drivers. I am using a Dell Latitude D610 laptop and Linux antiX 32 bit.

Is there really any advantage for me to try to go further with this issue?

Thanks for the advice.


Is this just an issue for Intel GPUs? Debian and thus antiX defaults to the kernel's "modesetting" driver instead of the "intel" "i915" driver provided by the xserver-xorg-video-intel package if you have Intel Haswell (second generation) or higher, so there's a lot of variables involved, since part of the driver is in whatever version of the kernel you're running, part could depend on what version of that xserver package you have, and part of it is the xorg/Mesa stack versions. All of these have various backports available for antiX and MX, but running "inxi -G" in antiX will show what your situation is at present.

greyowl
Fanatic
Fanatic
Posts: 152
Joined: Sun, 06 Oct 2013, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread postby greyowl » Wed, 22 Aug 2018, 19:23

stevepusser wrote:
greyowl wrote:@Spacy01
I used your earlier solution-- In about:config find browser.preferences.animateFadeIn, set as true--and now the Preferences is working fine.

I am however curious about your second solution and whether it is a better solution and could be applied to my laptop.

I am a novice so I don't know how to trouble shoot and change video drivers. I am using a Dell Latitude D610 laptop and Linux antiX 32 bit.

Is there really any advantage for me to try to go further with this issue?

Thanks for the advice.


Is this just an issue for Intel GPUs? Debian and thus antiX defaults to the kernel's "modesetting" driver instead of the "intel" "i915" driver provided by the xserver-xorg-video-intel package if you have Intel Haswell (second generation) or higher, so there's a lot of variables involved, since part of the driver is in whatever version of the kernel you're running, part could depend on what version of that xserver package you have, and part of it is the xorg/Mesa stack versions. All of these have various backports available for antiX and MX, but running "inxi -G" in antiX will show what your situation is at present.


Below is the result of inxi -G:
$ inxi -G
Graphics:
Card-1: Intel Mobile 915GM/GMS/910GML Express Graphics driver: i915 v: kernel
Display: server: X.Org 1.19.2 driver: intel unloaded: fbdev,modesetting,vesa
resolution: 1024x768~60Hz
OpenGL: renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 v: 2.1 Mesa 13.0.6

Can you advise me on whether the driver I am using is OK?
Last edited by greyowl on Wed, 22 Aug 2018, 19:24, edited 1 time in total.

User avatar
spacy01
Apollo supporter
Apollo supporter
Posts: 39
Joined: Tue, 02 Feb 2016, 11:42

Re: Problem with "Preferences" in version 28

Unread postby spacy01 » Thu, 23 Aug 2018, 04:11

greyowl wrote:@Spacy01
I used your earlier solution-- In about:config find browser.preferences.animateFadeIn, set as true--and now the Preferences is working fine.

I am however curious about your second solution and whether it is a better solution and could be applied to my laptop.

I am a novice so I don't know how to trouble shoot and change video drivers. I am using a Dell Latitude D610 laptop and Linux antiX 32 bit.

Is there really any advantage for me to try to go further with this issue?

Thanks for the advice.


Oh man, if it not broken, not fix it. Do you really need to change the driver? Is everything working ok? Is PM working ok? If now all works fine, don't change anything, if you have troubles, screen tearing, screen flickers, then do your research, see installed version and current version are the same.

I needed another solution, because i still had troubles, i cannot type in text boxes, cannot select from combo-boxes and so on... But if for you now everything working well, just enjoy on your system. :)

Actually, AntiX is Debian based, i never used it, i don't use Debian based distro from long time and cannot give you a specific advice.

smoki
Apollo supporter
Apollo supporter
Posts: 30
Joined: Fri, 19 Jan 2018, 05:34

Re: Problem with "Preferences" in version 28

Unread postby smoki » Thu, 23 Aug 2018, 04:15

stevepusser wrote: Is this just an issue for Intel GPUs?


I can't reproduce it on AMD hardware i tried Debian 8 32bit using fglrx driver nor on Debian 9 64bit using radeon driver, there is no this issue. So it seems so, seems ver 28.0 of PM uncover some bug in some version of intel's ddx.

@greyowl uses intel ddx on antiX
@spacy01 uses intel ddx on Manjaro
@LS650V if LS650V also uses intel ddx on Lubuntu, then we have a clear winner :D

Solution (according to spacy01) is to upgrade intel ddx or if some of them have GEN4+ intel GPUs these might also try modesetting driver too (that is default on Debian 9+/Ubuntu 16.10+/Fedora... anyway)

greyowl seems to have year 2005. laptop and well that is GEN3 GPU so there is no modesetting for that, thus only if he can try newer intel ddx.

User avatar
stevepusser
Lunatic
Lunatic
Posts: 387
Joined: Sat, 01 Aug 2015, 18:33
Location: California

Re: Problem with "Preferences" in version 28

Unread postby stevepusser » Thu, 23 Aug 2018, 18:32

Yeah...but I have doubts that they've made any fixes for that hardware that old in a newer driver.

FWIW, even the Sid version of xserver-xorg-video-intel was buggy on my new eighth-generation Coffee Lake Intel GPU, but I managed a build of a git pull from last month and the bugs seem squashed: http://mxrepo.com/mx/experimental/pool/ ... deo-intel/ (note: that driver is built against other backported libraries in that experimental repo and should not be just downloaded and installed on vanilla Debian/antiX/MX/etc.)

smoki
Apollo supporter
Apollo supporter
Posts: 30
Joined: Fri, 19 Jan 2018, 05:34

Re: Problem with "Preferences" in version 28

Unread postby smoki » Sun, 26 Aug 2018, 10:36

stevepusser wrote:Yeah...but I have doubts that they've made any fixes for that hardware that old in a newer driver.


It does not hurt to try, none tried it yet seems with that old hardware and now there is another one:

viewtopic.php?f=37&t=20149

Fujitsu Lifebook S7110... that is GMA 950, so again GEN3 and same issue :D

User avatar
Fede-Venice
Newbie
Newbie
Posts: 6
Joined: Sat, 25 Aug 2018, 19:34

Re: Problem with "Preferences" in version 28

Unread postby Fede-Venice » Sun, 26 Aug 2018, 14:51

Great spacy01! Thank You all. Now the tool window go, but the browser is still more slowly than 27.9
Last edited by Fede-Venice on Sun, 26 Aug 2018, 15:23, edited 2 times in total.

User avatar
LS650V
Newbie
Newbie
Posts: 4
Joined: Sun, 19 Aug 2018, 08:50

Re: Problem with "Preferences" in version 28

Unread postby LS650V » Fri, 07 Sep 2018, 21:49

Should I be using another video driver? If so, how do I change it? The browser.preferences.animateFadeIn true fix allows me to use the Preferences menu, but I still have other issues. For example, when accessing the Bookmarks pulldown menu, the icons associated with each bookmark do not show up unless I mouse over them.

$ inxi -G
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1280x800@59.91hz
GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2
GLX Version: 1.4 Mesa 18.0.5

$ sudo lshw -C video
*-display:0
description: VGA compatible controller
product: Mobile 915GM/GMS/910GML Express Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:dff00000-dff7ffff ioport:ec38(size=8) memory:c00

Proteus
Newbie
Newbie
Posts: 3
Joined: Mon, 04 Dec 2017, 13:23

Re: Problem with "Preferences" in version 28

Unread postby Proteus » Sun, 09 Sep 2018, 11:54

I've got this problem, too.

System: Lubuntu 16.04.5

inxi -G
Graphics: Card: Intel 82852/855GM Integrated Graphics Device
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1400x1050@60.02hz
GLX Renderer: Mesa DRI Intel 852GM/855GM x86/MMX/SSE2
GLX Version: 1.3 Mesa 18.0.5

This setting make dialogs working: user_pref("browser.preferences.animateFadeIn", true);

But the problem persists when starting Pale Moon with the -p option. In the "Choose User Profile" dialog clicking at a user profile changes the selection invisibly, the formerly selected item keeps selected but Pale Moon starts with the profile the user choosed.

This error message was shown when trying palemoon -p in terminal:

Crash Annotation GraphicsCriticalError: |[0][GFX1-]: [OPENGL] Failed to init compositor with reason: FEATURE_FAILURE_OPENGL_COMPILE_SHADER (t=122.992) [GFX1-]: [OPENGL] Failed to init compositor with reason: FEATURE_FAILURE_OPENGL_COMPILE_SHADER
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: (intermediate value)[0] is undefined
Full stack: nsPlacesExpiration.prototype._loadPrefs<@resource://gre/components/nsPlacesExpiration.js:859:30
TaskImpl_run@resource://gre/modules/Task.jsm:319:42
observe@resource://gre/modules/AsyncShutdown.jsm:550:9
addBlocker/moduleBlocker/<@resource://gre/components/nsAsyncShutdown.js:157:15
Promise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:386:5
moduleBlocker@resource://gre/components/nsAsyncShutdown.js:153:29
trigger@resource://gre/modules/AsyncShutdown.jsm:719:23
_wait@resource://gre/modules/AsyncShutdown.jsm:866:7
wait@resource://gre/modules/AsyncShutdown.jsm:850:28
observe@resource://gre/modules/AsyncShutdown.jsm:533:17

*************************

User avatar
LS650V
Newbie
Newbie
Posts: 4
Joined: Sun, 19 Aug 2018, 08:50

Re: Problem with "Preferences" in version 28

Unread postby LS650V » Sun, 09 Sep 2018, 21:39

After doing a little research, I added the line
install i915 /bin/false
to /etc/modprobe.d/blacklist.conf
followed by the following terminal command
$ sudo update-initramfs -u
so the kernel would not load the i915 driver.

Prior to rebooting the computer, I entered terminal command
$ glxgears
to benchmark the existing video driver performance. Full screen performance was 50 frames per second.

After rebooting the computer, I got the following results

$ inxi -G
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller
Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa)
Resolution: 1280x800@76.00hz
GLX Renderer: llvmpipe (LLVM 6.0, 128 bits)
GLX Version: 3.0 Mesa 18.0.5

$ sudo lshw -C video
*-display:0 UNCLAIMED
description: VGA compatible controller
product: Mobile 915GM/GMS/910GML Express Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller cap_list
configuration: latency=0
resources: memory:dff00000-dff7ffff ioport:ec38(size=8) memory:c0000000-cfffffff memory:dfec0000-dfefffff

I again entered terminal command
$ glxgears
and observed full screen performance was 30 frames per second. A definite reduction in performance.

However, with browser.preferences.animateFadeIn set false I did not witness any of the Pale Moon issues I have been seeing. The Pale Moon Preferences menu works fine. Unfortunately with this video driver setup both VLC and gnome-mplayer will not play videos even with the hardware acceleration option disabled. This is a deal breaker for me so I went back to the i915 driver.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: Google [Bot] and 7 guests