Page 3 of 3

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-02, 21:34
by trava90
By default Pale Moon will check for updates but will let you choose to install them (this can be changed in Preferences -> Advanced -> Update).

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-05, 23:26
by wavymoon
It would be very nice if the 'internal updater' had an 'update now' option. Is there a reason to NOT have that available??

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-06, 01:44
by trava90
It does, provided that it finds an update is available.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-06, 23:50
by wavymoon
Well mine found an update but but I do NOT have an UPDATE NOW option. I did get a popup saying 'you do not have system permissions required to install them' . :|

My user is the admin and PM folder is in my home/user folder.

I have just right clicked on folder and set permissions to be most lenient. I will update when I get some response. This would be a case where an update button would be appreciated :roll:

on Mint Matte 19.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-07, 03:33
by trava90
The Update Now option will only be displayed if the directory permissions are correct.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-07, 12:24
by wavymoon
Thanks Trava90
Ok a Catch-22. I will wait and see if there is a change now that I have made a couple of changes (at least I THINK I did).
How long should it take for that to show up, and for that matter just to be sure where should that button be?

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-07, 12:29
by trava90
If memory serves when on the release channel it will check for an update every two days, or you can check manually by going to Help -> About Pale Moon

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-07, 12:48
by wavymoon
And that is where I will find the button??

I am abit confused about the differences betwixt permissions (which I thought should be ok) and ownership which is root . :oops:
I see on another thread that a 'chown' command is used for that. Ineed to read up on this.... :shock:

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-07, 21:55
by wavymoon
I noticed that I now have ver 28.0.0 and 'palemoon is up to date' rather than there is an update goto palemoon to get.
I have done the chown command and my palemoon folder is now owned by my user. I will keep my fingers crossed that this will eventually work.... :|

Ok nothing at first but then I rebooted and there was a button and I am now at 28.0.1. :thumbup:


now on to other Mint problems..

Thanks!

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-08, 02:29
by New Tobin Paradigm
Why is this thread still open?

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-08, 07:53
by Moonchild
New Tobin Paradigm wrote:Why is this thread still open?
Because it hasn't been stale long enough yet.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-29, 22:02
by own3mall
Now that pminstaller is no longer maintained, I can't get Pale Moon to update on my Linux server. When I try, the download hangs, and when I close Pale Moon completely, and launch it again, I get an error of "The update could not be installed. Please make sure there are no other copies of Pale Moon running on your computer, and then restart Pale Moon to try again." There are no other copies of Pale Moon that are running, and I already chowned the /opt/palemoon directory to the proper owner and group.

I'm not sure what else to do. :( Anyone know? I'm still running 28.0.0 64-bit on Ubuntu 14.04 from an installation which was originally created by pminstaller.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-09-30, 21:27
by stevepusser
That's odd. PM 28+ won't build unless you have gcc-4.9 or greater, and Trusty only has 4.8 unless you add a PPA. Does it run fine on your gcc-4.8?

Re: NOTICE: pminstaller is no longer maintained

Posted: 2018-10-10, 20:16
by own3mall
It appears to on gcc version 4.8.4. How do I go about getting Pale Moon to update? Is there a log file somewhere that says why it fails to update?

Re: NOTICE: pminstaller is no longer maintained

Posted: 2019-01-27, 17:10
by Duckguy
Hello, I have Pale Moon v25.8.1 (x64), and the installer is v0.2.2. When I try to update I get an error message telling me to "check my network connection."

How do I facilitate this action (update) and is it revertable? I am using some obsolete plug-ins, and if the newer version is incompatible with them I may prefer the old version. My system specs are found in the signature below.

Thanks in advance, Duckguy B'H.
Error message.
Error message.
Screenshot(4).png (17.49 KiB) Viewed 553 times

Installer menu.
Installer menu.
Screenshot(5).png (23.28 KiB) Viewed 553 times

Pale Moon information splash.
Pale Moon information splash.


Re: NOTICE: pminstaller is no longer maintained

Posted: 2019-01-27, 17:42
by Nigaikaze
Duckguy wrote:When I try to update I get an error message telling me to "check my network connection."
How do I facilitate this action (update)
The installer no longer functions. Read the first post in this thread. It tells you how to install PM 28.
Duckguy wrote:is it revertable?
Make a backup of your profile first. If you choose to revert, you'll need to restore your profile and then manually reinstall your old version. Using a profile that has been updated to PM 28 with an earlier version of PM can cause problems.
Duckguy wrote:I have Pale Moon v25.8.1 (x64) ... and if the newer version is incompatible with them I may prefer the old version.
If you revert to the older version, bear in mind it is unsupported and thus you will not receive support for it here.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2019-01-27, 19:56
by Duckguy
Nigaikaze wrote: ... Make a backup of your profile ... choose to revert, you'll need to restore your profile and then manually reinstall your old version ...
How would this be accomplished? Can I simply make a complete copy of the /opt directory or something similar and save it to a separate partition?

I just found out for some reason the /opt directory is empty by the way.

Thanks in advance, B'H.
Terminal screenshot.
Terminal screenshot.
Screenshot(6).png (12.67 KiB) Viewed 509 times

Terminal screenshot.
Terminal screenshot.
Screenshot(7).png (19.37 KiB) Viewed 509 times


Re: NOTICE: pminstaller is no longer maintained

Posted: 2019-01-27, 21:13
by vannilla
Your profile is inside your home, specifically in the ".moonchild productions" folder.
Making a backup of your profile means basically making a copy of that folder somewhere that isn't your home directory.
If you update but want to go back, you have to uninstall the browser, delete the ".moonchild productions" folder completely (rm -r or similar command), then installing the old version and finally making a copy of the backed up profile in your home directory.

Re: NOTICE: pminstaller is no longer maintained

Posted: 2019-01-28, 04:18
by Duckguy
vannilla wrote:... profile is inside your home, specifically in the ".moonchild productions" folder ... a backup of your profile means basically making a copy of that folder ... installing the old version ... in your home directory.
Thank you. That was actually helpful. I just made the copy and set up a new back up folder in my Puppy_Linux directory. :thumbup:

You sir, are a gentleman. B'H.