unable to run palemoon on centos 6

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
jalalmadini
New to the forum
New to the forum
Posts: 1
Joined: Sun, 08 Jul 2018, 16:52

unable to run palemoon on centos 6

Unread postby jalalmadini » Sun, 08 Jul 2018, 16:59

Hello

i have a centos vps and i have installed xrdp to be able to connect to it via remote desktop , it works fine and i tried to install Pale moon (currently using firefox) , i have used the pminstaller tool.

the instalation was "successful" and i got palemoon in my internet tab under applications , but when i try to run it , get a tab for palemoon in the botton bar saying
Starting Pale Moon W.... but it disappears after 15 seconds and palemoon never starts

i have tried to remove it and re-install it and noticed that it gives me some erors at the end of instalation :

Code: Select all

which: no palemoon in (/tmp/pminstaller.lPcfpZ/bin/x86_64:/tmp/pminstaller.lPcfpZ/tools:/tmp/pminstaller.lPcfpZ/bin/x86_64:/tmp/pminstaller.lPcfpZ/tools:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin)
gtk-update-icon-cache: Cache file created successfully.
which: no update-alternatives in (/tmp/pminstaller.lPcfpZ/bin/x86_64:/tmp/pminstaller.lPcfpZ/tools:/tmp/pminstaller.lPcfpZ/bin/x86_64:/tmp/pminstaller.lPcfpZ/tools:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin)
ls: cannot access /usr/share/hunspell: No such file or directory


any idea what is the issue here ?

cheers

User avatar
therube
Astronaut
Astronaut
Posts: 551
Joined: Fri, 08 Jun 2018, 17:02

Re: unable to run palemoon on centos 6

Unread postby therube » Sun, 08 Jul 2018, 20:55

I gather you're getting PM through your distro?
(And suspect they're packaging incorrectly.)

The the download from, http://linux.palemoon.org/.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22012
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: unable to run palemoon on centos 6

Unread postby Moonchild » Sun, 08 Jul 2018, 21:20

therube wrote:I gather you're getting PM through your distro?
(And suspect they're packaging incorrectly.)


No, they are using the pminstaller script supplied by us.
Unfortunately I can't help since Linux isn't my forte and I know very little about the installer -- but alternatively to the installer you can always just download the tarball and unpack it to a writable directory of your choice, and run ./palemoon from there.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

tooshorttoolong
Moon lover
Moon lover
Posts: 97
Joined: Mon, 11 Sep 2017, 14:28

Re: unable to run palemoon on centos 6

Unread postby tooshorttoolong » Mon, 09 Jul 2018, 17:53

Centos is using very old libraries (even older than Debian I believe) so it may be the issue. Try running palemoon from a terminal and see if you get an error message.

Alternatively try running:

Code: Select all

ldd $(which palemoon)

and see if it says some libs are missing.
Last edited by tooshorttoolong on Mon, 09 Jul 2018, 17:54, edited 1 time in total.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 5 guests