Page 1 of 1

palemoon 27.9 on suse linux and plugins

Posted: 2018-06-15, 15:52
by Lucio Chiappetti
Given that I was still using pm 25 on my old machine, I have successfully installed pm 27.9 on a new machine with opensuse leap 42. It looks like I can now access happily the few sites (institutional payslips :mrgreen: and institutional video site) I had problems with the older ones. It is not yet in production under my account on the new machine, but I tested it on a test account first under a fresh run, and then importing my old user profile.

The palemoon addon page was very useful for a preliminary check of the addons. I also found useful the fact the new pm 27.9 classified the extensions as "blue dot" (directly target palemoon) and "orange dot" (firefox compatibility). My extension list was
  • ADL despite marked blue it did not appear in the tools menu, but disabling it and downloading the newer 5.0.1 cured it, and it even got all the old filters ! great !
  • Expire history by days 1.1.1-signed
  • FEBE 10.2
  • Google search link fix
  • I don't care about cookies 2.6.3 marked incompatible fixed, I downloaded the latest one
  • NoSquint marked incompatible fixed, replace with 2.2.1 works fine
  • Saved Password Editor worked immediately
  • Session Manager says to use just did not show up in the menu until a browser restart (that new button is really useful
Concerning the plugins, formerly I had some version of the Shockwave flash plugin and a Java Plug-in 1.6.0_23. For the former I found a nice link in the addon page (thanks again) and installed the latest .so library. For the latter it was a soft-link to some .so library in a system directory, I'll hunt for it later when I'll checked Java on the new system.

I would like to thank everybody for palemoon, its site and the addon site. If one knows what to look for it can find everything !

palemoon 27.9 on suse linux and JAVA plugin

Posted: 2018-07-17, 13:33
by Lucio Chiappetti
I cannot get what I suppose is the default java plugin on opensuse leap 42 work with palemoon 27.9.

On my older opensuse 11 system (with older palemoon) I "installed" the java plugin manually at user level, going to ~/.mozilla/plugins and soflinking to the place in /usr/lib64/.... where it was located. Note that on the old system (some 8 years ago) I replaced the default java (iced tea) with Sun java (from within yast) mainly because it had poorer fonts (look).

On opensuse leap 42 apparently there is no neither installed by default nor anywhere in the yast2 repositories. There is an /etc/alternatives a javaplugin which in turn is a soft-link to some /usr/ So I tried to softlink it in ~/.mozilla/plugins (for a test user which clones my personal account, as well as for root). Palemoon->Tools->Addons->Plugins sees it, but it does not work.

In the test user, it started giving an error

Code: Select all

addons.manager  WARN    Exception calling callback: TypeError: addon is null (chrome://nosquint/content/prefs.js:857:12)   ....
So I disabled temporarily NoSquint. This way palemoon starts, but as soon as I go to a page containing an applet (I tried my page which contains a banner applet compiled long ago I got a long error traceback starting

Code: Select all

openjdk version "1.8.0_171"
OpenJDK Runtime Environment (IcedTea 3.8.0) (build 1.8.0_171-b11 suse-24.1-x86_64)
OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode)
Exception in thread "main" java.lang.InternalError
        at Method)
etc. etc.
and the browser seems frozen.

I tried from root (which has default paths to java and a fresh palemoon profile, and used this test page but the result (error and behaviour) is the same. So at least it does not depend on my own applet.

Any advice or recommendation ?

Edit post: incidentally, appletviewer (same JDK version as the plugin) displays the applet acceptably

Re: palemoon 27.9 on suse linux and plugins

Posted: 2018-07-18, 16:09
by therube
I'll state the little I know (i.e., about zero)...

32-bit browser needs 32-bit Plugins
64-bit browser needs 64-bit Plugins

Not clear just what Java has ? ... index.html.


Check about:plugins & see what that may show?
Check Addons Manager -> Plugins, & see what that may show?