Overriding included libfreetype.

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

BobbyBonsaimind
Newbie
Newbie
Posts: 3
Joined: Fri, 08 Dec 2017, 17:58
Contact:

Overriding included libfreetype.

Postby BobbyBonsaimind » Thu, 10 May 2018, 15:31

I'm trying to override the libfreetype which is included in Pale Moon, but I fail to do so. I'm using the repository provided by Steven Pusser.

Some background, I've upgraded to Ubuntu 16.04 which is coming with libfreetype6 2.6, which unfortunately has a bug which shrinks the line height. There is basically just 1 pixel of space between lines with that libfreetype version. I've change my system to include libfreetype6 2.4, which does not suffer from that bug.

However, Pale Moon seems to use its own libfreetype6 as it does not pick the correct one from my system, neither does it use it if I preload it with LD_PRELOAD, it still has the incorrect line paddings as if it would be using libfreetype6 2.6. Does somebody know how I can get Pale Moon to pick up the correct library?

Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 4 guests