Ubuntu 18.04 failed to load module "canberra-gtk-module"

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

floatingkeyboards
Apollo supporter
Apollo supporter
Posts: 39
Joined: Sun, 07 Jan 2018, 09:59

Ubuntu 18.04 failed to load module "canberra-gtk-module"

Unread postby floatingkeyboards » Sun, 06 May 2018, 03:42

I get these error messages:
failed to load module "canberra-gtk-module"
It also gives the error:
the owner of /home/myUserName/.config/ibus/bus is not root!

I noticed this thread viewtopic.php?f=37&t=17632&p=129674&hilit=canberra+gtk+module#p129674
which gives a suggestion about the first error. Should I have installed those packages before installing Pale Moon? Pale Moon seemed to proceed with the installation even after those errors.

Ubuntu 18.04

tooshorttoolong
Moon lover
Moon lover
Posts: 99
Joined: Mon, 11 Sep 2017, 14:28

Re: Ubuntu 18.04 failed to load module "canberra-gtk-module"

Unread postby tooshorttoolong » Sun, 06 May 2018, 07:14

libcanberra is used to play system sounds and any Gtk application tries to load it automatically at startup. Presumably it is not a hard requirement for Pale Moon.
A quick web search on the error message will give you the instructions to install the module on your distro, if you want that.

As for the second error message, I’m not sure. You’re not running palemoon with sudo, are you? Or is it the installer?
Last edited by tooshorttoolong on Sun, 06 May 2018, 07:19, edited 1 time in total.

floatingkeyboards
Apollo supporter
Apollo supporter
Posts: 39
Joined: Sun, 07 Jan 2018, 09:59

Re: Ubuntu 18.04 failed to load module "canberra-gtk-module"

Unread postby floatingkeyboards » Sat, 12 May 2018, 05:30

Sorry for the delayed response. I was away from my linux machine for a while (it's not my primary computer). When I installed it using the command line I did not use any sudo commands.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 6 guests