No microphone setting at Duolingo with PM

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 840
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY

No microphone setting at Duolingo with PM

Unread postby gracious1 » Sun, 08 Apr 2018, 17:11

I frequently use the site Duolingo for language practice.
I have noticed that when I use Pale Moon, Duolingo cannot detect that I have a microphone, and the Microphone settings do not appear on the Settings page.
Image

In contrast, I used Chromium, and lo and behold the microphone settings appeared.
Image


I am not sure if this is a bug or if I need to adjust a browser pref, or what. :?:

To test this yourself, I believe you will have to create an account at Duolingo. (It's free.)

PM 27.8.2 (64-bit)
Chromium 65.0.3325.181
Ubuntu 14.04.5


UPDATE: Also tried it with Seamonkey 2.49.2 and got no microphone, and with Brave 0.22.13 and did get the microphone.
Last edited by gracious1 on Sun, 08 Apr 2018, 17:33, edited 1 time in total.
Image“We look forward to the time when the Power of Love will replace the Love of Power. Then will our world know the blessings of peace.” ― Wm. Ewart Gladstone

User avatar
Nigaikaze
Keeps coming back
Keeps coming back
Posts: 853
Joined: Sun, 02 Feb 2014, 22:15
Location: Chicago, IL, USA

Re: No microphone setting at Duolingo with PM

Unread postby Nigaikaze » Sun, 08 Apr 2018, 18:13

From what Duolingo itself says:

1. Check that you are using Google Chrome. Microphone exercises only work on Chrome.

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 840
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY

Re: No microphone setting at Duolingo with PM

Unread postby gracious1 » Sun, 08 Apr 2018, 19:09

Nigaikaze wrote:From what Duolingo itself says:

1. Check that you are using Google Chrome. Microphone exercises only work on Chrome.


Well, that's strange. I'm sure I used to use it with different browsers before. :(
Thanks, anyway.
Image“We look forward to the time when the Power of Love will replace the Love of Power. Then will our world know the blessings of peace.” ― Wm. Ewart Gladstone

Walter Dnes
Astronaut
Astronaut
Posts: 569
Joined: Thu, 30 Jul 2015, 20:29
Location: Vaughan, ON, Canada

Re: No microphone setting at Duolingo with PM

Unread postby Walter Dnes » Sun, 08 Apr 2018, 20:26

When all else fails, lie to the website about your user agent...
  • Go to https://www.whatismybrowser.com/detect/what-is-my-user-agent with Chrome and leave the window open. The Chrome user agent string will be in the blue box near the top.
  • In Pale Moon goto about:config and create a text entry general.useragent.override.duolingo.com
  • For the value of the text string copy the entire string in the blue box in the Chrome window
  • Try the website again, and let us know if it helps
There's a right way
There's a wrong way
And then there's my way

User avatar
Moonraker
Keeps coming back
Keeps coming back
Posts: 888
Joined: Wed, 30 Sep 2015, 23:02
Location: Lincolnshire.UK.

Re: No microphone setting at Duolingo with PM

Unread postby Moonraker » Sun, 08 Apr 2018, 20:36

Walter Dnes wrote:When all else fails, lie to the website about your user agent...
  • Go to https://www.whatismybrowser.com/detect/what-is-my-user-agent with Chrome and leave the window open. The Chrome user agent string will be in the blue box near the top.
  • In Pale Moon goto about:config and create a text entry general.useragent.override.duolingo.com
  • For the value of the text string copy the entire string in the blue box in the Chrome window
  • Try the website again, and let us know if it helps

Walter why go through all that if the OP has chrome installed anyway.?
just use chrome for that specific website.
Slacko puppy linux 64bit.
Pale moon 27.9.0

Walter Dnes
Astronaut
Astronaut
Posts: 569
Joined: Thu, 30 Jul 2015, 20:29
Location: Vaughan, ON, Canada

Re: No microphone setting at Duolingo with PM

Unread postby Walter Dnes » Sun, 08 Apr 2018, 23:53

Moonraker wrote:Walter why go through all that if the OP has chrome installed anyway.?
just use chrome for that specific website.

Maybe because he really would rather not be running Chrome and having Google track him. And the answer might also help people who don't have Chrome.

Some web designers are absolute idiots when it comes to user agent sniffing. I don't know if you can get cbc.ca videos outsite of Canada, but here's an example. Try URL http://www.cbc.ca/news/business/telcos-rate-hikes-1.3410425 and play the video with default settings. Either the page doesn't show up at all, or else the audio is very low-pitched. But if I set up a new string in about:config

NAME general.useragent.override.cbc.ca
VALUE Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

...the video plays just fine. And I don't want to be switching back and forth to Firefox/Chrome all the time. Actually, I don't have Firefox or Chrome. On Gentoo Linux, "www-client/chromium" is "unstable" and "www-client/google-chrome" is "missing keyword", which is even less tested than "unstable".
There's a right way
There's a wrong way
And then there's my way

User avatar
eskaton023
Lunatic
Lunatic
Posts: 456
Joined: Fri, 23 Aug 2013, 19:54

Re: No microphone setting at Duolingo with PM

Unread postby eskaton023 » Mon, 09 Apr 2018, 00:28

Is there any way to confirm if this functionality requires WebRTC, because if it does then it will not work in Pale Moon full stop.

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 840
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY

Re: No microphone setting at Duolingo with PM

Unread postby gracious1 » Mon, 09 Apr 2018, 06:29

Walter Dnes wrote:When all else fails, lie to the website about your user agent...
... let us know if it helps[/list]

Moonraker wrote:Walter why go through all that if the OP has chrome installed anyway.?


Moonraker, that is a good point, and I have used Chromium elsewhere when nothing else worked. But of course, I would like to avoid using Chromium except when it is absolutely necessary.

So Walter, I tried your suggestion, but changing the user agent had no effect. So I guess Duolingo is doing proper feature detection?? But which feature is missing, I don't know. (For all I know, it could be WebRTC as eskaton023 suggested.)

FYI, the microphone setting appeared in both Chromium and Brave, as I mentioned before, but it did not appear in Opera, nor in any Gecko/Goanna browsers (SeaMonkey, PM, Waterfox, Fx ESR, etc.)
Image“We look forward to the time when the Power of Love will replace the Love of Power. Then will our world know the blessings of peace.” ― Wm. Ewart Gladstone


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 4 guests