Re: Lichess.org help Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
phanner98
New to the forum
New to the forum
Posts: 2
Joined: Tue, 13 Mar 2018, 15:16

Re: Lichess.org help

Postby phanner98 » Mon, 02 Apr 2018, 01:14

Hey folks,

I have a quick question with regards to palemoon's treatment of lichess.org
My issue is fairly simple. Picture #1 is how it looks in another browser... and picture #2
is how it looks in Palemoon. My question is... how do I get the icons to show up in palemoon like they are in picture #1. I'm far from a internet browser scientist but my intuition tells me it's either A) I don't have the correct font package installed for the recognition of the icons... or B) palemoon isn't detecting the 3rd party icons for this site.

Any help would be appreciated. I would just like to be able to play chess and enjoy the beauty that is palemoon
Thanks in Advance,
Phanner

http://oi67.tinypic.com/9k4cqt.jpg
http://oi67.tinypic.com/10p3hao.jpg

User avatar
adesh
Lunatic
Lunatic
Posts: 443
Joined: Tue, 06 Jun 2017, 07:38

Re: Lichess.org help

Postby adesh » Mon, 02 Apr 2018, 15:53

Some errors from your web console may be helpful. Press F12 and click Console.
Also, do you have any content blocking extensions installed in Pale Moon?

Lew Rockwell Fan
Moonbather
Moonbather
Posts: 58
Joined: Wed, 14 Jun 2017, 15:20

Re: Lichess.org help  Topic is solved

Postby Lew Rockwell Fan » Mon, 02 Apr 2018, 16:51

Perhaps try:
Tools, Prefs, Content tab, under "Fonts & Colors, Advanced button, check "Allow pages to choose their own fonts . . ."
Works for me. Toggling that setting, what I see goes back and forth between pages just like your two images.

Now if you want to make it convenient to toggle that setting, I strongly recommend this extension:
https://addons.mozilla.org/en-US/firefo ... s-buttons/
But, just to be sure, I double checked and doing it manually has the same effect for me.
On another system, not the one I'm booted in ATM, I used Inspector-widget and a custom button extension to duplicate those buttons with my own choice of text title & icon.

BTW, I'd love to be able to save that setting on a per-page basis, so that for example, I could have it default to unchecked (use my font settings) but allow specific pages (or pages with urls matching a regex) to use their own fonts and save those exemptions, but I haven't figured out a way to do that. It would be nice to have an option to actually install those fonts locally too & be able to force websites to use different locally installed fonts. Maybe Stylish could do that. I've never quite figured out how to get Stylish to do tricks.
Last edited by Lew Rockwell Fan on Mon, 02 Apr 2018, 17:04, edited 2 times in total.

User avatar
phanner98
New to the forum
New to the forum
Posts: 2
Joined: Tue, 13 Mar 2018, 15:16

Re: Lichess.org help

Postby phanner98 » Mon, 02 Apr 2018, 17:01

adesh wrote:Some errors from your web console may be helpful. Press F12 and click Console.
Also, do you have any content blocking extensions installed in Pale Moon?


Hi adesh, thanks for the extra set of eyes. It looks like the icons were 3rd party assets specifically for the li-chess site. The f12 trick to read what's actually under the hood was great ,as it allowed me to see the default fonts and emoji packages that are being used.

It looks like someone fixed it... as It seems to be showing the icons on pale moon now. Thank you Moon Man and everyone that had a read. The world is a little bit better :thumbup: (appreciated)

I also forgot to post what extensions that I was using... I guess I take for granted that not everyone wears the tin foil hat that I do and uses Umatrix. :mrgreen: Thank you much ... I'll mark as solved.

*** Ok, it looks like I did have that button to only use my chosen fonts used in pages... and it seems like using the generic fonts and not having that button x'd off works. Thanks for the heads up... I should have know better :)

I tend to be a font snob and like to have helvetica/Akzidenz-Grotesk and source code pro as my defaults... likely the reason for the icons not showing. but it does seem to work with that button off.
Last edited by phanner98 on Mon, 02 Apr 2018, 17:12, edited 2 times in total.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: CraigPD and 8 guests