"The following packages cannot be authenticated"

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

vvstn
New to the forum
New to the forum
Posts: 1
Joined: 2018-03-18, 21:45

"The following packages cannot be authenticated"

Unread post by vvstn » 2018-03-18, 21:48

username~$ sudo apt-get install palemoon
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
palemoon
0 upgraded, 1 newly installed, 0 to remove and 289 not upgraded.
Need to get 0 B/36.7 MB of archives.
After this operation, 104 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
palemoon
Install these packages without verification? [y/N] n
E: Some packages could not be authenticated
Any ideas? I've tried a few solutions from google and they didn't help. Ubuntu 16.04

Thanks!

bgstack15
Apollo supporter
Apollo supporter
Posts: 48
Joined: 2018-01-22, 23:04

Re: "The following packages cannot be authenticated"

Unread post by bgstack15 » 2018-03-19, 13:51

What ppa or repository are you getting them from? It looks like your system does not trust the pgp key (usually implemented on GNU/Linux as gpg) that was used to sign the packages.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: "The following packages cannot be authenticated"

Unread post by stevepusser » 2018-03-20, 02:56

If it's my repo, you must correctly install the repository key as shown in the instructions. If it still has problems, please show us the terminal output of the command to download and install the key.
Last edited by stevepusser on 2018-03-20, 02:57, edited 1 time in total.

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1013
Joined: 2015-09-30, 23:02
Location: Lincolnshire.UK.

Re: "The following packages cannot be authenticated"

Unread post by Moonraker » 2018-03-20, 16:02

Is there any particular reason why you do not use the PM installer on linux.This is how i update pale moon on my linux computer.
Xenial puppy linux 32-bit.
Pale moon 28.5.0.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: "The following packages cannot be authenticated"

Unread post by stevepusser » 2018-03-21, 23:30

Could be because they prefer apt, or that my repo has a few other packages that are patched for Pale Moon support, such as oxygen-gtk and mozplugger.

InstanceOfMichael
New to the forum
New to the forum
Posts: 1
Joined: 2018-06-04, 13:35

Re: "The following packages cannot be authenticated"

Unread post by InstanceOfMichael » 2018-06-04, 13:37

I'm having the same issue:

Code: Select all

$ sudo apt-get update -y
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release                                                                                                             
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease                                                                                                             
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                                                                     
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                                                                   
Hit:6 http://security.ubuntu.com/ubuntu xenial-security InRelease                                                                                                      
Hit:7 http://ppa.launchpad.net/chris-lea/redis-server/ubuntu xenial InRelease                                                              
Hit:8 https://download.docker.com/linux/ubuntu xenial InRelease                                                                                 
Hit:9 http://apt.postgresql.org/pub/repos/apt xenial-pgdg InRelease                                                                             
Hit:10 https://download.sublimetext.com apt/stable/ InRelease                                                                                   
Ign:11 http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  InRelease                              
Hit:12 http://ppa.launchpad.net/costamagnagianfranco/virtualbox-ppa/ubuntu xenial InRelease    
Get:14 http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  Release [1,021 B]                      
Hit:15 http://ppa.launchpad.net/inkscape.dev/stable/ubuntu xenial InRelease                                              
Get:16 http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  Release.gpg [481 B]                   
Hit:17 http://ppa.launchpad.net/nginx/development/ubuntu xenial InRelease                          
Hit:18 http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease                                 
Hit:19 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease                    
Hit:20 http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu xenial InRelease                      
Hit:21 http://packages.blackfire.io/debian any InRelease                                            
Hit:22 http://ppa.launchpad.net/shutter/ppa/ubuntu xenial InRelease           
Hit:23 http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu xenial InRelease
Hit:24 http://ppa.launchpad.net/webupd8team/atom/ubuntu xenial InRelease       
Hit:25 http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu xenial InRelease
Ign:16 http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  Release.gpg
Hit:26 http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  Packages
Hit:27 https://deb.nodesource.com/node_8.x xenial InRelease
Hit:28 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease                                                                                         
Fetched 1,502 B in 7s (213 B/s)                                                                                                                                        
Reading package lists... Done
W: GPG error: http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0FAD31CA8719FCE4
W: The repository 'http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.10  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: "The following packages cannot be authenticated"

Unread post by stevepusser » 2018-06-05, 00:31

Could you show us the results of the commands to download and install the repository key?

Code: Select all

rm -f Release.key && wget -nv https://download.opensuse.org/repositories/home:stevenpusser/xUbuntu_16.04/Release.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update

Locked