-P ProfileName & --profile /path/profile not working Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Lew Rockwell Fan
Moonbather
Moonbather
Posts: 64
Joined: Wed, 14 Jun 2017, 15:20

-P ProfileName & --profile /path/profile not working

Unread postby Lew Rockwell Fan » Tue, 13 Mar 2018, 22:38

I can't get Pale Moon to start directly (as opposed to through the profile manager gui dialog) with any profile but the default.

From "palemoon --help":

Pale Moon options
-P <profile> Start with <profile>.
--profile <path> Start with profile at <path>.
--ProfileManager Start with ProfileManager.

But all 3 of those do pretty much the same thing. If PM is already running they open another tab or window in the same profile. If not, they open the profile manager.

I've also tried lower case -p, --profile='/path/to/profile', changing browser.link.open_newwindow to 2, and adding most possible permutations of --new-instance, --no-remote, & -new-window.

What am I doing wrong?

------
Ubuntu 16.04 built from mini.iso with X, lightdm, and plain Openbox, no DE. amd64. Pale Moon 27.8.1 (64-bit).
Last edited by Lew Rockwell Fan on Tue, 13 Mar 2018, 22:42, edited 1 time in total.

Walter Dnes
Astronaut
Astronaut
Posts: 506
Joined: Thu, 30 Jul 2015, 20:29
Location: Vaughan, ON, Canada

Re: -P ProfileName & --profile /path/profile not working  Topic is solved

Unread postby Walter Dnes » Wed, 14 Mar 2018, 04:52

Lew Rockwell Fan wrote:I can't get Pale Moon to start directly (as opposed to through the profile manager gui dialog) with any profile but the default.

From "palemoon --help":

Pale Moon options
-P <profile> Start with <profile>.
--profile <path> Start with profile at <path>.
--ProfileManager Start with ProfileManager.

I know this is going to sound "picky picky picky", but forcing a specific profile has to be done in conjunction with either "-no-remote" or "-new-instance". Those 2 are equivalant, you can use either/or. Here are some snippets from my ICEWM menu...

/home/waltdnes/pm/palemoon/palemoon -new-instance -p dslr
/home/waltdnes/pm/palemoon/palemoon -new-instance -p graphs
/home/waltdnes/pm/palemoon/palemoon -new-instance -p palemoon
/home/waltdnes/pm/palemoon/palemoon -new-instance -p slashdot
/home/waltdnes/pm/palemoon/palemoon -new-instance -p youtube

As mentioned previously, you can use "-no-remote" in place of "-new-instance". Output from "palemoon --help" mentions this.
There's a right way
There's a wrong way
And then there's my way

Lew Rockwell Fan
Moonbather
Moonbather
Posts: 64
Joined: Wed, 14 Jun 2017, 15:20

Re: -P ProfileName & --profile /path/profile not working

Unread postby Lew Rockwell Fan » Wed, 14 Mar 2018, 06:04

Thanks. In trying to figure why yours worked & mine didn't . . . oh, tell the truth and shame the devil, I was focused so on the command syntax, I hadn't noticed I'd used a lower case letter that should have been a capital in the name of the profile. I'm an idiot sometimes.

It's the kind of goof I'd expect to elicit an error message like "No such profile - starting profile manager" or at least "bad argument" in a terminal, but there was none. Which is why I assumed I'd misunderstood the syntax.
Last edited by Lew Rockwell Fan on Wed, 14 Mar 2018, 07:53, edited 6 times in total.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: Google [Bot] and 3 guests