Washington Post comments section gets no response on PM

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Washington Post comments section gets no response on PM

Unread postby rbguy » Sat, 03 Mar 2018, 23:15

I'm running PM 27.8.0 (32-bit) on Linux Mint 18.3 Cinnamon.
I have no add-ons enabled.
When I click on the comments section at the end of an article in the Washington Post, I get no response.... the comments do not appear.
I do get them using Firefox and Chromium.
I saw this previous post, but it has been of no help to me.
https://forum.palemoon.org/viewtopic.php?f=3&t=16117&p=123812&hilit=washington+post+comments#p123812
Your thoughts on this one are appreciated.
Thanks!!

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Sun, 04 Mar 2018, 02:06

After further playing with it, the only way I can get to see the comments is by clearing all History (including cookies and cache), with time range set to Everything.
It looks like I will have to do it every time I log into the W. Post.
It's kind of a pain, but......

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Sun, 04 Mar 2018, 13:58

Can someone please click on the WP website (below)? Click on any story and go to the bottom, then click on Comments, and let me know if the comments appear.
For all I know, it may be a setting or something that I need to turn on/off on my computer.
Thanks for your help.

https://www.washingtonpost.com/

coffeebreak
Board Warrior
Board Warrior
Posts: 1211
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Washington Post comments section gets no response on PM

Unread postby coffeebreak » Sun, 04 Mar 2018, 15:02

PM 27.8 on Windows 7 x86 here. Checked with this article.

Comments displayed with no trouble here, so long as cookies and local storage (dom.storage.enabled = true) were enabled.

However my situation was unlike yours, in that I don't have a Washington Post account so wasn't logged in.
And the cookies were session cookies (I don't retain cookies or local storage).

User avatar
TwoTankAmin
Astronaut
Astronaut
Posts: 657
Joined: Wed, 23 Jul 2014, 13:56
Location: New York

Re: Washington Post comments section gets no response on PM

Unread postby TwoTankAmin » Sun, 04 Mar 2018, 16:17

Windows 7 Home Premium, P M 27.7.2- comments displayed fine for me. Due to my normal settings for PM and the extensions I use, I sometimes have trouble loading comments on some sites.

This is the article I looked at (I am not a subscriber).

Inside an accused school shooter’s mind: A plot to kill ‘50 or 60. If I get lucky maybe 150.’
By John Woodrow Cox March 3 at 8:26 PM
https://www.washingtonpost.com/local/inside-a-teen-school-shooters-mind-a-plot-to-kill-50-or-60-if-i-get-lucky-maybe-150/2018/03/03/68cc673c-1b27-11e8-ae5a-16e60e4605f3_story.html?utm_term=.41796cac1c6e
Last edited by TwoTankAmin on Sun, 04 Mar 2018, 16:18, edited 1 time in total.
“No one has ever become poor by giving.” Anonymous
“Everyone is entitled to his own opinion, but not to his own facts.”" Daniel Patrick Moynihan
"The good thing about science is that it’s true whether or not you believe in it." Neil DeGrasse Tyson

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Mon, 05 Mar 2018, 01:13

Thanks for your replies coffebreak and Two Tank!

I'm still trying to figure things out here.

When I clear History (including cookies and cache), the comments section works fine the first time.
Any other articles after that though, it doesn't work..... nothing.

coffeebreak
Board Warrior
Board Warrior
Posts: 1211
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Washington Post comments section gets no response on PM

Unread postby coffeebreak » Mon, 05 Mar 2018, 03:29

rbguy wrote:When I clear History (including cookies and cache), the comments section works fine the first time.
Any other articles after that though, it doesn't work..... nothing.

Just loaded comments in half a dozen articles, opened in sequence. Worked fine.
I didn't clear cookies, cache, history etc in between articles.
And as before, no account/not logged in.

From curiosity, does the problem occur both when you're logged in and logged out?
If only when logged in, input from people who have Washington Post accounts would be particularly helpful.

Also...
Have you tried safe mode, or failing that a new profile to check whether any of your extension(s) or settings cause the problem?
Last edited by coffeebreak on Mon, 05 Mar 2018, 04:18, edited 1 time in total.

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Mon, 05 Mar 2018, 15:36

Forgot to mention before that I don't have an account with the W Post.

Interesting thing happened after I read your post. I went back and disabled my only extension, Eclipsed Moon.
It worked. I saw the comments on a few articles I pulled up.
Then I enabled Eclipsed Moon.... and it was still working.
Not what I was expecting. :shock:

Anyway, I'll return back in a few days and post an update either way.

Thanks again for all your help on this problem!!!

User avatar
TwoTankAmin
Astronaut
Astronaut
Posts: 657
Joined: Wed, 23 Jul 2014, 13:56
Location: New York

Re: Washington Post comments section gets no response on PM

Unread postby TwoTankAmin » Mon, 05 Mar 2018, 16:22

In the 1970s I was a partner in a sound company. We did the audio for events, mostly concerts. It incolved a lot of equipment an 1,000s of feet of wires. It was not uncommon for us to hook it all up and began to test everything. A piece of equipment would not work. But when we checked it all out everything in line was operating fine, yet it did not work. Murphy's law.

In the digital age the complexity of devices, the internet, wireless etc. make those days make what I worked with look like toys. I firm;y believe Murphy's law has never been repealed. In fact it seems to work better in the digital age than ever before. There is one law that is broken every day and all day long, however, "If it ain't broke, don;t fix it."
“No one has ever become poor by giving.” Anonymous
“Everyone is entitled to his own opinion, but not to his own facts.”" Daniel Patrick Moynihan
"The good thing about science is that it’s true whether or not you believe in it." Neil DeGrasse Tyson

coffeebreak
Board Warrior
Board Warrior
Posts: 1211
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Washington Post comments section gets no response on PM

Unread postby coffeebreak » Mon, 05 Mar 2018, 21:39

rbguy wrote:Forgot to mention before that I don't have an account with the W Post.

Well...I'd thought that you used the site while logged into an account based on this:
rbguy wrote:It looks like I will have to do it every time I log into the W. Post.


rbguy wrote: I went back and disabled my only extension, Eclipsed Moon.
It worked. I saw the comments on a few articles I pulled up.
Then I enabled Eclipsed Moon.... and it was still working.

Good! Hope it stays that way. :)

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Tue, 06 Mar 2018, 00:00

TwoTankAmin wrote:In the 1970s I was a partner in a sound company. We did the audio for events, mostly concerts. It incolved a lot of equipment an 1,000s of feet of wires. It was not uncommon for us to hook it all up and began to test everything. A piece of equipment would not work. But when we checked it all out everything in line was operating fine, yet it did not work. Murphy's law.

In the digital age the complexity of devices, the internet, wireless etc. make those days make what I worked with look like toys. I firm;y believe Murphy's law has never been repealed. In fact it seems to work better in the digital age than ever before. There is one law that is broken every day and all day long, however, "If it ain't broke, don;t fix it."


It is amazing how it all works, as complex as it can be. I agree with you on, "if it ain't broke, don't fix it" ......... unless I'm playing around with a new Linux dstro. :)

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Tue, 06 Mar 2018, 00:12

coffeebreak wrote:
rbguy wrote:Forgot to mention before that I don't have an account with the W Post.

Well...I'd thought that you used the site while logged into an account based on this:
rbguy wrote:It looks like I will have to do it every time I log into the W. Post.


rbguy wrote: I went back and disabled my only extension, Eclipsed Moon.
It worked. I saw the comments on a few articles I pulled up.
Then I enabled Eclipsed Moon.... and it was still working.

Good! Hope it stays that way. :)


I just read a couple of articles a day, until I'm blocked from reading anymore.
Then when I go back the next day, I can read a few more.

I shouldn't have used the term "log into." More accurate to say "when I look at the website."

Thanks, I'll check it out for a few days and post the results. I don't feel like I've "Solved" anything though. :D

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Wed, 07 Mar 2018, 20:17

It's not working on my Linux system.
I even reinstalled PM and have nothing on it (extensions, etc.)..... just plain vanilla.
I also installed it on a Lubuntu desktop and got the same results.
It's got to be something simple.... no? :?:

Bind17
Newbie
Newbie
Posts: 3
Joined: Fri, 24 Mar 2017, 21:04

Re: Washington Post comments section gets no response on PM

Unread postby Bind17 » Fri, 09 Mar 2018, 18:17

hi,
I have linux mint 17.3 and Palemoon with noscript and ublock origin and 5 more addons
clicking on an article you refferred gave me full access to all comments
after allowin WP in noscript
m

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Washington Post comments section gets no response on PM

Unread postby rbguy » Sat, 10 Mar 2018, 03:16

Bind17,

Thanks for your post!
I added the noscript add-on and allowed WP, and the comments appeared.
Then I disabled noscript and the comments would not appear.
I will be running Pale Moon with the noscript add-on enabled from now on.
I'll be back here if anything changes.
Thanks again.
Last edited by rbguy on Sat, 10 Mar 2018, 03:17, edited 1 time in total.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 4 guests