Audio of some videos play slow Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

mocambo
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: Fri, 17 Mar 2017, 23:03

Audio of some videos play slow

Unread postby mocambo » Wed, 14 Feb 2018, 00:32

Video just works fine but audio is a bit slow and sounds like alien talk.

Flash player is disabled. Youtube and Dailymotion works well.

Here's the example video:
https://kanal2.postimees.ee/pluss/video/?id=73740

Any clue ?

Thank you !

RJARRRPCGP
Fanatic
Fanatic
Posts: 198
Joined: Mon, 22 Jun 2015, 19:48
Location: USA (North Springfield, Vermont)

Re: Audio of some videos play slow

Unread postby RJARRRPCGP » Wed, 14 Feb 2018, 01:46

Is it what I call "the Home Alone 2 effect"?

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 460
Joined: Sun, 24 Sep 2017, 16:35

Re: Audio of some videos play slow

Unread postby SpockFan02 » Wed, 14 Feb 2018, 04:41

Off-topic:
RJARRRPCGP wrote:Is it what I call "the Home Alone 2 effect"?
Heh, was that the one set in New York, when he slowed down a recording of his voice to pretend to be an adult?

RJARRRPCGP
Fanatic
Fanatic
Posts: 198
Joined: Mon, 22 Jun 2015, 19:48
Location: USA (North Springfield, Vermont)

Re: Audio of some videos play slow

Unread postby RJARRRPCGP » Wed, 14 Feb 2018, 11:54

That's the one, LOL.

fillerup
Lunatic
Lunatic
Posts: 456
Joined: Mon, 19 May 2014, 19:14
Location: Finland

Re: Audio of some videos play slow  Topic is solved

Unread postby fillerup » Wed, 14 Feb 2018, 12:05

had this issue the other day on twitter videos, i fixed it by going into pref.js and deleting this line

user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36

no clue why an UA override would be responsible for that, but at least it works

mocambo
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: Fri, 17 Mar 2017, 23:03

Re: Audio of some videos play slow

Unread postby mocambo » Mon, 16 Apr 2018, 22:31

The problem still exists. Some videos still play audio with alien voices.

fillerup wrote:had this issue the other day on twitter videos, i fixed it by going into pref.js and deleting this line

user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.99 Safari/537.36

no clue why an UA override would be responsible for that, but at least it works


Currently using Palemoon 27.8.3. and prefs.js doesnt contain such row.

One more video for referring:
http://publik.delfi.ee/news/mitmesugust ... d=81782853

Any more clue ?

User avatar
WilliamK
Fanatic
Fanatic
Posts: 127
Joined: Fri, 23 Feb 2018, 06:51

Re: Audio of some videos play slow

Unread postby WilliamK » Mon, 16 Apr 2018, 22:59

I have seen videos for a live stream out of sync by as much as 50 secs. It was the finals of a local snooker tournie and I could tell it was 45-50 secs because the referee's score calls were 2 shots out all the way through. I cannot remember if forward or back but it is a common occurrence and may be related to delay caused by the scoreboard overlay.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4771
Joined: Tue, 09 Oct 2012, 19:37

Re: Audio of some videos play slow

Unread postby New Tobin Paradigm » Tue, 17 Apr 2018, 08:57

Do not ever manually edit preferences files.
Image

== We got to install microwave ovens / Custom kitchen deliveries / We got to move these refrigerators / We got to move these color TVs ==
http://binaryoutcast.com/ | http://thereisonlyxul.org/

fillerup
Lunatic
Lunatic
Posts: 456
Joined: Mon, 19 May 2014, 19:14
Location: Finland

Re: Audio of some videos play slow

Unread postby fillerup » Wed, 18 Apr 2018, 02:54

New Tobin Paradigm wrote:Do not ever manually edit preferences files.

i'd like to think i know what i'm doing. or maybe you can explain why it's not a good idea instead of your condescending one liner that sounds like an adult talking down to a child?

mocambo wrote:The problem still exists. Some videos still play audio with alien voices. Any more clue ?

did you search for that specific line or just general.useragent.override? as your profile might have a different override. if you're sure there is no active useragent override, then i can't provide additional help.

worst case scenario you can clone your current profile and tinker with pref.js like i did by deleting off stuff until it works. before doing this, confirm that videos play fine on a fresh profile first
Last edited by fillerup on Wed, 18 Apr 2018, 03:04, edited 1 time in total.

Walter Dnes
Astronaut
Astronaut
Posts: 569
Joined: Thu, 30 Jul 2015, 20:29
Location: Vaughan, ON, Canada

Re: Audio of some videos play slow

Unread postby Walter Dnes » Wed, 18 Apr 2018, 06:28

Actually, in this case, there is an officially documented way of doing it, namely the "user.js" file http://kb.mozillazine.org/User.js_file Entries in this file override entries in "prefs.js". I keep a central copy, symlinked into multiple profile directories. I use it for basic stuff like turning turning ads autoplay off and updating useragents for sites that insist on "a current browser". I have multiple profiles, and it's really nice to be able to make a change in one central location, rather than having to do it umpteen times, once for each profile.
There's a right way
There's a wrong way
And then there's my way

fillerup
Lunatic
Lunatic
Posts: 456
Joined: Mon, 19 May 2014, 19:14
Location: Finland

Re: Audio of some videos play slow

Unread postby fillerup » Wed, 18 Apr 2018, 10:03

Walter Dnes wrote:Actually, in this case, there is an officially documented way of doing it, namely the "user.js" file http://kb.mozillazine.org/User.js_file Entries in this file override entries in "prefs.js". I keep a central copy, symlinked into multiple profile directories. I use it for basic stuff like turning turning ads autoplay off and updating useragents for sites that insist on "a current browser". I have multiple profiles, and it's really nice to be able to make a change in one central location, rather than having to do it umpteen times, once for each profile.

never knew this, seems very handy for certain use cases!

mocambo
Hobby Astronomer
Hobby Astronomer
Posts: 18
Joined: Fri, 17 Mar 2017, 23:03

Re: Audio of some videos play slow

Unread postby mocambo » Wed, 18 Apr 2018, 23:34

fillerup wrote:
mocambo wrote:The problem still exists. Some videos still play audio with alien voices. Any more clue ?

did you search for that specific line or just general.useragent.override? as your profile might have a different override. if you're sure there is no active useragent override, then i can't provide additional help.

worst case scenario you can clone your current profile and tinker with pref.js like i did by deleting off stuff until it works. before doing this, confirm that videos play fine on a fresh profile first


Your method can be considered as a solution.

At a first glance there was no such general.useragent.override you described. But as prefs.js actively changes every time browser restarted, in one moment similar row appeared there and i deleted it. Now all videos are with normal voices. Thanks !
Last edited by mocambo on Wed, 18 Apr 2018, 23:36, edited 1 time in total.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: Google [Bot] and 6 guests