Default browser Issue

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 02:32

I have 5 browsers including PM and I was messing around with the default browser settings and no matter what setting was set in my Linux the default browsers would only switch between FF and PM.

So right now I have 2 default browsers at one time.

When I set Vivaldi as default it does not take the default setting away from PM or FF.

Has anyone heard of or seen this before?

Is this a browser issue or a Linux issue?

Thanks
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 02:51

Probably since SolydXK is based of Debian, check as root (or as sudo, i have no idea what SolydXK setuped by default ):

Code: Select all

update-alternatives --config x-www-browser


Every browser should be listed there if you have installed ALL browsers via proper deb packages and just select default there.

Basically x-www-browser is just a link to the default browser and if something is not listed or not installed via debs or not proper debs and such then just add that alternative first:

Code: Select all

update-alternatives --install /usr/bin/x-www-browser x-www-browser /your/path/to/whatever/browser/executable 20


After that, it should appear in config selection... remember that what x-www-browser opens up is real default for the system and obviously under X, etc...that is what it is to the core and now maybe some GUI also doing all this on SolydXK have no idea about that too :D

It is not Linux issue, every distro do it differently :D ... and issue is mostly that what is default for the system might not be default for the user, here in case of Debian and derivatives basically use alternatives if you want to set something to be default everywhere.
Last edited by smoki on Wed, 31 Jan 2018, 03:31, edited 11 times in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 04:09

Thanks,

I did

Code: Select all

update-alternatives --config x-www-browser

and set it to vivaldi and then reentered update-alternatives --config x-www-browser to check it and logged out and back in, PM is still the default.

But update-alternatives --config x-www-browser did say that PM was auto mode and the others were manual mode.

any other thoughts?
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 04:15

Did you do it as root/sudo?
What 'x-www-browser' command opens up?
PM is the default by what definiton? I mean where you see it as default or what app opens it up as default, etc...?
SolydX EE s based on Debian Testing isn't it? I guess, something might be currently buggy there since it is Testing.

Maybe i can suggest to never set default when browser ask you for and to manage it just with alternatives, as something might be messed up if you do it in one and another way.
Last edited by smoki on Wed, 31 Jan 2018, 04:23, edited 5 times in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 04:26

This:

Code: Select all

$ sudo update-alternatives --config x-www-browser
[sudo] password for troypulk:
There are 5 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                       Priority   Status
------------------------------------------------------------
  0            /usr/bin/palemoon           201       auto mode
  1            /opt/firefox/firefox        70        manual mode
  2            /usr/bin/chromium           40        manual mode
  3            /usr/bin/palemoon           201       manual mode
* 4            /usr/bin/vivaldi-snapshot   0         manual mode
  5            /usr/bin/vivaldi-stable     200       manual mode

Press <enter> to keep the current choice[*], or type selection number:


I mean by default is that both browsers say they are default and clicking a link in Thunar opens PM or FF but not vivaldi even though vivaldi says it's default.
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 04:35

Debian ususally patching various software to open alternatives instead. If x-www-browser command opens up proper default, that is OK.

Now i guess maybe it is app specific issue, maybe it is hard-coded to firefox in Thunar... does Thunar provide some option itself to set default? Or maybe XFCE in general have some specific settings somewhere.
Last edited by smoki on Wed, 31 Jan 2018, 04:39, edited 3 times in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 04:41

Thunar will open the browser I set to default FF or PM but not vivaldi or any other browser.

There is no setting for default browsers in thunar.
Last edited by troypulk on Wed, 31 Jan 2018, 04:41, edited 1 time in total.
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 04:44

troypulk wrote:Thunar will open the browser I set to default FF or PM but not vivaldi or any other browser.

There is no setting for default browsers in thunar.


I searched a bit around, does this exist anymore?

https://docs.xfce.org/xfce/exo/preferred-applications

All this sounds to be like XFCE specific issue, as they like to use that exo-open or something.
Last edited by smoki on Wed, 31 Jan 2018, 04:50, edited 1 time in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 04:51

Yes it's in the settings manager app, it's set to vivaldi and when I make vivaldi default in the browser it changes it in the settings manager app too but when I make PM default it didn't change.
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 05:01

troypulk wrote:Yes it's in the settings manager app, it's set to vivaldi and when I make vivaldi default in the browser it changes it in the settings manager app too but when I make PM default it didn't change.


OK then, which PM deb package / repo you use? Now it looks like deb packaging issue.
Last edited by smoki on Wed, 31 Jan 2018, 05:02, edited 1 time in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 05:06

I installed PM using the pminstaller tool on the main page linux downloads.

I always thought it was just a generic PM for linux.
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 05:16

troypulk wrote: I always thought it was just a generic PM for linux.


It is generic as it is, but Linux distros and DEs are known to goes wild on (non)standards sometimes (exo-open, xdg-open, distros doing their own things, etc...)... but likely you are right and there is a bug somewhere, because if all other browsers respect xfce settings, but just PM don't... maybe that is something PM devs could consider to make better in future or at least packagers or something.

I use Debian with plain Openbox for example, all custom and SpaceFM as file manager... and never spot an issue like this there. But if i change this to some other DE and other file manager i might have some issues like this :D

Yes it's in the settings manager app, it's set to vivaldi and when I make vivaldi default in the browser it changes it in the settings manager app too but when I make PM default it didn't change.


Basically i am not interested in this, i ignore what random browsers wanna do there i always say No if browser asks to make something default there... and do it the way with alternatives ;)
Last edited by smoki on Wed, 31 Jan 2018, 05:34, edited 8 times in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Wed, 31 Jan 2018, 05:29

Should I install
https://software.opensuse.org/download. ... e=palemoon

and see if it works better?
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 06:17

Well, try it - it won't hurt anything i guess.

I think it make sense particulary when you wanna use this much different browsers, to just answer No when browsers ask you for default and do it your way anyway ;)

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Wed, 31 Jan 2018, 08:05

troypulk wrote:This:

Code: Select all

$ sudo update-alternatives --config x-www-browser
[sudo] password for troypulk:
There are 5 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                       Priority   Status
------------------------------------------------------------
  0            /usr/bin/palemoon           201       auto mode
  1            /opt/firefox/firefox        70        manual mode
  2            /usr/bin/chromium           40        manual mode
  3            /usr/bin/palemoon           201       manual mode
* 4            /usr/bin/vivaldi-snapshot   0         manual mode
  5            /usr/bin/vivaldi-stable     200       manual mode

Press <enter> to keep the current choice[*], or type selection number:


I mean by default is that both browsers say they are default and clicking a link in Thunar opens PM or FF but not vivaldi even though vivaldi says it's default.


I didn't spotted that priority is zero for your selected default broswer, so maybe that is why this happen to you... so try maybe to raise priority for that vivaldi-snapshot or what you preffer above elses.

Settings are stored in /var/lib/dpkg/alternatives/x-www-browser, you can edit that also, etc... just be very careful with that config file since it is used by package manager too, as if you edit something improperly package manager might break when some new update of some browesr came in. So edit with caution!!!
Last edited by smoki on Wed, 31 Jan 2018, 08:12, edited 4 times in total.

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 798
Joined: Sun, 15 May 2016, 05:00
Location: bitterly cold upstate NY
Contact:

Re: Default browser Issue

Postby gracious1 » Wed, 31 Jan 2018, 21:20

What does it mean that Pale Moon is listed twice as item 0 and as item 3 in troypulk's list?

I have something similar, with Opera listed twice (as items 0 and 6):

Code: Select all

  Selection    Path                          Priority   Status
------------------------------------------------------------
* 0            /usr/bin/opera                 120       auto mode
  1            /usr/bin/chromium-browser      40        manual mode
  2            /usr/bin/cyberfox              40        manual mode
  3            /usr/bin/firefox               40        manual mode
  4            /usr/bin/firefox-esr           70        manual mode
  5            /usr/bin/midori                39        manual mode
  6            /usr/bin/opera                 120       manual mode
  7            /usr/bin/palemoon              40        manual mode
  8            /usr/bin/uzbl-browser          10        manual mode
  9            /usr/bin/waterfox              40        manual mode
  10           /usr/bin/xombrero              50        manual mode
  11           /usr/bin/yandex-browser-beta   40        manual mode


Selecting a different item does not alter this duplication:

Code: Select all

Press enter to keep the current choice[*], or type selection number: 7
update-alternatives: using /usr/bin/palemoon to provide /usr/bin/x-www-browser (x-www-browser) in manual mode

Code: Select all

  Selection    Path                          Priority   Status
------------------------------------------------------------
  0            /usr/bin/opera                 120       auto mode
  1            /usr/bin/chromium-browser      40        manual mode
  2            /usr/bin/cyberfox              40        manual mode
  3            /usr/bin/firefox               40        manual mode
  4            /usr/bin/firefox-esr           70        manual mode
  5            /usr/bin/midori                39        manual mode
  6            /usr/bin/opera                 120       manual mode
* 7            /usr/bin/palemoon              40        manual mode
  8            /usr/bin/uzbl-browser          10        manual mode
  9            /usr/bin/waterfox              40        manual mode
  10           /usr/bin/xombrero              50        manual mode
  11           /usr/bin/yandex-browser-beta   40        manual mode


I selected 7 for Pale Moon, but Opera is still both 0 and 6. And what is the difference between manual and auto mode? And do I want to make Pale Moon auto mode?
Image“Life is what happens to us while we are making other plans.” ― Allen Saunders

smoki
Hobby Astronomer
Hobby Astronomer
Posts: 20
Joined: Fri, 19 Jan 2018, 05:34

Re: Default browser Issue

Postby smoki » Thu, 01 Feb 2018, 03:06

https://manpages.debian.org/stretch/dpk ... .1.en.html
Each link group is, at any given time, in one of two modes: automatic or manual. When a group is in automatic mode, the alternatives system will automatically decide, as packages are installed and removed, whether and how to update the links. In manual mode, the alternatives system will retain the choice of the administrator and avoid changing the links (except when something is broken).
Link groups are in automatic mode when they are first introduced to the system. If the system administrator makes changes to the system's automatic settings, this will be noticed the next time update-alternatives is run on the changed link's group, and the group will automatically be switched to manual mode.
Each alternative has a priority associated with it. When a link group is in automatic mode, the alternatives pointed to by members of the group will be those which have the highest priority.
When using the --config option, update-alternatives will list all of the choices for the link group of which given name is the master alternative name. The current choice is marked with a ‘*’. You will then be prompted for your choice regarding this link group. Depending on the choice made, the link group might no longer be in auto mode. You will need to use the --auto option in order to return to the automatic mode (or you can rerun --config and select the entry marked as automatic).

automatic mode
When a link group is in automatic mode, the alternatives system ensures that the links in the group point to the highest priority alternative appropriate for the group.

manual mode
When a link group is in manual mode, the alternatives system will not make any changes to the system administrator's settings.
Last edited by smoki on Thu, 01 Feb 2018, 03:14, edited 1 time in total.

User avatar
troypulk
Fanatic
Fanatic
Posts: 229
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default browser Issue

Postby troypulk » Thu, 01 Feb 2018, 05:42

I fixed the priority using this:

Code: Select all

sudo update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/vivaldi-snapshot 201

Code: Select all

$ sudo update-alternatives --config x-www-browser
[sudo] password for troypulk:
There are 5 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                       Priority   Status
------------------------------------------------------------
  0            /usr/bin/vivaldi-snapshot   201       auto mode
  1            /opt/firefox/firefox        70        manual mode
  2            /usr/bin/chromium           40        manual mode
  3            /usr/bin/palemoon           20        manual mode
* 4            /usr/bin/vivaldi-snapshot   201       manual mode
  5            /usr/bin/vivaldi-stable     200       manual mode

Press <enter> to keep the current choice[*], or type selection number:


But Palemoon and vivaldi both say they are default, and they both open different program links like help in thunar and mousepad use palemoon and libreoffice uses vivaldi.

I think I will have to just live with it.
SolydX EE (64-bit)

Pale Moon 27.9.2 (64-bit)


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 6 guests