Flash! Killer of every one of us

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
khronosschoty
Hobby Astronomer
Hobby Astronomer
Posts: 24
Joined: 2016-11-23, 10:37

Re: Flash! Killer of every one of us

Unread post by khronosschoty » 2018-09-02, 22:41

BrianA_MN wrote:
Moonchild wrote:Hah.. slackware -- I'm not surprised you're having issues.
Hah, that's why I'm not using Palemoon. The developer doesn't appreciate the Slackware user and simply derides the distro instead of helping a user asking a simple question. The real help came from another Slackware user not the developer, who should know where PM is looking for the flash. Oh BTW, /lib is not the proper place for 64 bit libraries, so why is Palemoon still using it for the 64 bit distro? Ba-Bye PM
Pale Moon is looking in /usr/lib64/mozilla/plugins/ on 64 bit systems.
Image

vingtzwanzig
Fanatic
Fanatic
Posts: 110
Joined: 2017-04-20, 21:25
Contact:

Re: Flash! Killer of every one of us

Unread post by vingtzwanzig » 2018-09-03, 01:08

I used to get the latest tar.gz for Linux direct from Adobe, (although I was using FireFox then) and followed the instructions provided:
https://get.adobe.com/flashplayer/
That's a simple (ish) and distro independent way to get the latest version as a binary, there are also some prepackaged APT (deb) YUM and rpm options there too.

bgstack15
Apollo supporter
Apollo supporter
Posts: 47
Joined: 2018-01-22, 23:04

Re: Flash! Killer of every one of us

Unread post by bgstack15 » 2018-09-05, 14:28

As khronosschoty alluded to, Pale Moon is checking a particular directory for plugins. I just make a symlink (from my blog https://bgstack15.wordpress.com/2017/12 ... er-plugin/)

Code: Select all

sudo ln -s /usr/lib64/flash-plugin/libflashplayer.so /usr/lib/mozilla/plugins/
Hope that helps. Of course, it assumes you already have the flash plugin installed. I can't help you there: I know nothing about Slackware at present. But once it's installed, just make the symlink and possibly restart the browser. You can check to see if it recognizes it at URL about:plugins.

Locked