Website not opening up completely Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Website not opening up completely

Unread postby rbguy » Mon, 08 Jan 2018, 20:02

I just installed Pale Moon (27.6.2 32-bit) a few hours ago from my Linux Mint Software Manager. I'm running Linux Mint 18.2 Cinn.

I've started using PM and everything is working fine so far except for this. When I click on this link (In my favorites), it does not open up completely..... it's not maximized.
The webpage is compressed so that it only appears on the left side of the monitor screen..... taking up about 2 inches on left side of the screen which is about 18" wide.
I tried FF and Chromium and it works fine there.

http://www.city-data.com/forum/#general-forums

Thanks for your help on this.

User avatar
hobbledehoy899
Fanatic
Fanatic
Posts: 155
Joined: Wed, 27 Jul 2016, 23:18

Re: Website not opening up completely

Unread postby hobbledehoy899 » Mon, 08 Jan 2018, 20:27

Press on the "Desktop version" button that's at the bottom left of the page.

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Website not opening up completely

Unread postby rbguy » Mon, 08 Jan 2018, 20:57

Thanks, that fixed it.

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Website not opening up completely

Unread postby rbguy » Tue, 09 Jan 2018, 13:47

For the record: My opening sentence was wrong. It was not available in the Software Manager. I installed it per directions in this link. No problems.

http://tipsonubuntu.com/2016/07/16/install-pale-moon-ubuntu-16-04/

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 460
Joined: Sun, 24 Sep 2017, 16:35

Re: Website not opening up completely  Topic is solved

Unread postby SpockFan02 » Tue, 09 Jan 2018, 23:36

A user agent override telling city-data.com that Pale Moon is actually Firefox 52.9 will prevent the mobile version of the forum being served in the first place.

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Website not opening up completely

Unread postby rbguy » Wed, 10 Jan 2018, 03:11

Thanks! First time creating a user agent override for me. I found these instructions helpful.

https://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/

It worked. :thumbup:

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 460
Joined: Sun, 24 Sep 2017, 16:35

Re: Website not opening up completely

Unread postby SpockFan02 » Wed, 10 Jan 2018, 03:51


The steps in the Firefox section in that article change your user agent for all sites, whereas you can specify to do it for only city-data.com by naming the preference general.useragent.override.city-data.com. That way, most sites will think you're using Pale Moon (which you are), and only a few others which don't work, serve their mobile site, etc. when they don't recognize a user agent from a popular browser will think you're using something which you're not.

This is all rather unfortunate, since sites that do this are discriminating against users of less-popular browsers. Many of these site-specific overrides are set by default in Pale Moon when it is known to fix problems on these sites. Perhaps someone should contact Advameg, Inc. (owners and operators of City-Data) at errors@city-data.com (for "Errors, corrections, additions") or others@city-data.com ("Other issues") to tell them that the mobile version of their forum is served to browsers with Pale Moon user agents, and ask them to change this.
Last edited by SpockFan02 on Wed, 10 Jan 2018, 03:51, edited 1 time in total.

rbguy
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: Mon, 08 Jan 2018, 19:30

Re: Website not opening up completely

Unread postby rbguy » Wed, 10 Jan 2018, 15:53

general.useragent.override.city-data.com


That's the entry that I used. I'll try and contact them and pass the info along. Thanks again for your help.

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 460
Joined: Sun, 24 Sep 2017, 16:35

Re: Website not opening up completely

Unread postby SpockFan02 » Thu, 11 Jan 2018, 01:52

Alright, cool. :)


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 9 guests