IP-camera video not displaying using Gstreamer

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

New to the forum
New to the forum
Posts: 1
Joined: Wed, 03 Jan 2018, 09:54

IP-camera video not displaying using Gstreamer

Postby bhargavi » Wed, 03 Jan 2018, 10:18

Hi Everyone,

I'm working on linux (ubuntu 14.04).I need video streaming from ip-camera by using Gstreamer.I tried to launch some commands to access my ipcamera in ubuntu pc.But its not able to access and getting error as GstPipeline.I tried some other command with ipaddress and port details mentioned in the command,its not working. Getting an error while executing the command which is mentioned below

1.gst-launch-1.0 rtspsrc location=rtsp:// ! autovideosink

After launching the above command in linux(ubuntu 14.04) getting error as mentioned below.

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not open resource for reading and writing.
Additional debug info:
gstrtspsrc.c(6183): gst_rtspsrc_retrieve_sdp (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
Failed to connect. (Generic error)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

2.gst-launch-1.0 rtsp:// ... ream=0.sdp?

After launching above command in a terminal its getting below error

ERROR: pipeline could not be constructed: Unrecoverable syntax error while parsing pipeline rtsp://

If any one faced same issue in past than please help me how to come out of this issue.

Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 5 guests