Failed to load module "atk-bridge" and "canberra-gtk-module"

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun, 03 Dec 2017, 18:42

Failed to load module "atk-bridge" and "canberra-gtk-module"

Unread postby _z0rk_ » Sun, 03 Dec 2017, 20:45

Pale Moon Version: 27.6.2 (32-bit)
4.9.0-4-amd64 GNU/Linux
Gnome Version 3.22.2
Debian GNU/Linux 9.2 (stretch)

Installed by: https://software.opensuse.org/download. ... e=palemoon
Installed: libcanberra-gtk-module 0.30-3, libatk-bridge2.0-0 2.22.0-2

Starting Pale Moon from CLI generates failed to load module "atk-bridge" and "canberra-gtk-module" errors.
What would cause this?

Thanks!

debian:~$ palemoon
Gtk-Message: Failed to load module "atk-bridge"

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Gtk-Message: Failed to load module "canberra-gtk-module"

User avatar
stevepusser
Lunatic
Lunatic
Posts: 398
Joined: Sat, 01 Aug 2015, 18:33
Location: California

Re: Failed to load module "atk-bridge" and "canberra-gtk-module"

Unread postby stevepusser » Mon, 04 Dec 2017, 19:34

The same Pale Moon starts on the Stretch-based MX 17 beta without any error or warning messages at all, but it has a lot of packages and libraries installed by default, so one or more of them must get rid of them. Using aptitude to search for installed packages with "atk" or "canberra", and extra info removed:

Code: Select all

$ aptitude show '?and(?name(atk), ~i)'

Package: libatk-wrapper-java             
Package: libatkmm-1.6-1v5
Package: gir1.2-atk-1.0
Package: libatk-wrapper-java-jni
Package: libatk1.0-0
Package: libatk-bridge2.0-0
Package: libatk1.0-data


Code: Select all

$ aptitude show '?and(?name(canberra), ~i)'

Package: libcanberra-gtk-module         
Package: libcanberra-gtk3-module
Package: libcanberra-pulse
Package: libcanberra-gtk3-0
Package: libcanberra-gstreamer
Package: libcanberra-gtk0
Package: libcanberra0

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun, 03 Dec 2017, 18:42

Re: Failed to load module "atk-bridge" and "canberra-gtk-module"

Unread postby _z0rk_ » Sun, 10 Dec 2017, 04:10

All packages except libcanberra-gstreamer were already installed. Installing this last missing package did not resolve the errors. Oh well...

Thanks for your suggestion though.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 5 guests