Failed to load module "atk-bridge" and "canberra-gtk-module"

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun Dec 03, 2017 6:42 pm

Failed to load module "atk-bridge" and "canberra-gtk-module"

Postby _z0rk_ » Sun Dec 03, 2017 8:45 pm

Pale Moon Version: 27.6.2 (32-bit)
4.9.0-4-amd64 GNU/Linux
Gnome Version 3.22.2
Debian GNU/Linux 9.2 (stretch)

Installed by: https://software.opensuse.org/download. ... e=palemoon
Installed: libcanberra-gtk-module 0.30-3, libatk-bridge2.0-0 2.22.0-2

Starting Pale Moon from CLI generates failed to load module "atk-bridge" and "canberra-gtk-module" errors.
What would cause this?

Thanks!

debian:~$ palemoon
Gtk-Message: Failed to load module "atk-bridge"

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(pale moon:796): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Gtk-Message: Failed to load module "canberra-gtk-module"

stevepusser
Lunatic
Lunatic
Posts: 267
Joined: Sat Aug 01, 2015 6:33 pm
Location: California

Re: Failed to load module "atk-bridge" and "canberra-gtk-module"

Postby stevepusser » Mon Dec 04, 2017 7:34 pm

The same Pale Moon starts on the Stretch-based MX 17 beta without any error or warning messages at all, but it has a lot of packages and libraries installed by default, so one or more of them must get rid of them. Using aptitude to search for installed packages with "atk" or "canberra", and extra info removed:

Code: Select all

$ aptitude show '?and(?name(atk), ~i)'

Package: libatk-wrapper-java             
Package: libatkmm-1.6-1v5
Package: gir1.2-atk-1.0
Package: libatk-wrapper-java-jni
Package: libatk1.0-0
Package: libatk-bridge2.0-0
Package: libatk1.0-data


Code: Select all

$ aptitude show '?and(?name(canberra), ~i)'

Package: libcanberra-gtk-module         
Package: libcanberra-gtk3-module
Package: libcanberra-pulse
Package: libcanberra-gtk3-0
Package: libcanberra-gstreamer
Package: libcanberra-gtk0
Package: libcanberra0

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun Dec 03, 2017 6:42 pm

Re: Failed to load module "atk-bridge" and "canberra-gtk-module"

Postby _z0rk_ » Sun Dec 10, 2017 4:10 am

All packages except libcanberra-gstreamer were already installed. Installing this last missing package did not resolve the errors. Oh well...

Thanks for your suggestion though.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: amberit and 7 guests