No Audio; Video works Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun Dec 03, 2017 6:42 pm

No Audio; Video works

Postby _z0rk_ » Sun Dec 03, 2017 6:52 pm

Pale Moon Version: 27.6.2 (32-bit)
4.9.0-4-amd64 GNU/Linux
Gnome Version 3.22.2
Debian GNU/Linux 9.2 (stretch)

Installed by: https://software.opensuse.org/download. ... e=palemoon
Installed: libavcodec57, pulseaudio, gstreamer, mplayer
No browser add-on installed

https://www.youtube.com/html5
Selection_014.png


http://www.quirksmode.org/html5/tests/video.html > full video playback, but no audio

It looks to me like I should have all the appropriate dependencies installed. Any ideas?

Thanks!

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 2933
Joined: Mon Oct 03, 2011 10:19 am
Location: Texas, USA

Re: No Audio; Video works

Postby Night Wing » Sun Dec 03, 2017 9:15 pm

From the link you provided, left clicking on all three test videos, they all play video and audio for me using 64 bit linux Pale Moon (27.6.2) running in 64 bit linux Mint 18.2 (Sonya) Xfce.
Linux Mint 18.2 (Sonya) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

Walter Dnes
Lunatic
Lunatic
Posts: 368
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: No Audio; Video works  Topic is solved

Postby Walter Dnes » Sun Dec 03, 2017 9:38 pm

The last post in thread https://forum.palemoon.org/viewtopic.php?f=37&t=9661 shows a solution for someone else with an audio problem. BTW, Pale Moon no longer uses gstreamer. If another program requires it, leave gstreamer installed, but current Pale Moon doesn't use it.

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun Dec 03, 2017 6:42 pm

Re: No Audio; Video works

Postby _z0rk_ » Sun Dec 03, 2017 9:43 pm

Night Wing wrote:From the link you provided, left clicking on all three test videos, they all play video and audio for me using 64 bit linux Pale Moon (27.6.2) running in 64 bit linux Mint 18.2 (Sonya) Xfce.


The previous version of Pale Moon exhibited the same behavior. I've recently installed Pale Moon given an approved installation method (see installed by link above). I don't have any add-ons installed; I didn't mess with about:config or the preference settings; this is plain vanilla. Audio works fine in Firefox ESR and Chrome.

I did notice that with Pale Moon running, Settings > Sound > Applications > No application is currently playing or recording audio. Not sure what to make of it.

Thanks.

_z0rk_
Newbie
Newbie
Posts: 5
Joined: Sun Dec 03, 2017 6:42 pm

Re: No Audio; Video works

Postby _z0rk_ » Sun Dec 03, 2017 10:08 pm

Walter Dnes wrote:The last post in thread https://forum.palemoon.org/viewtopic.php?f=37&t=9661 shows a solution for someone else with an audio problem. BTW, Pale Moon no longer uses gstreamer. If another program requires it, leave gstreamer installed, but current Pale Moon doesn't use it.


I was not using an .asoundrc file; but I've created one and used the same syntax suggested in the link. It worked.
Thanks for the suggestion! :clap:


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: amberit and 7 guests