Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, Indalecio, satrow

Lisguard
New to the forum
New to the forum
Posts: 1
Joined: Wed Sep 27, 2017 10:45 am

Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby Lisguard » Wed Sep 27, 2017 11:11 am

I have just updated to version 27.5.0 on Debian testing using Steven Pusser's deb package:
Version: 27.5.0~repack-1.

I have always had problem with viewing video on the bbc website under palemoon, but reloading the page
always used to work. But now the "circulating busy icon" is displayed continuously: looks like some sort of livelock.

Example: http://www.bbc.co.uk/news/av/science-en ... ch-the-sun
Trying to inspect the element, I see at least one type error: "e.onerror is not a function".
Right click on the image shows:
"2.14.3 1829564.u

unknown

Error 2200

ContinuousPlayPluginHTML.1.22.0 "

I tried searching for any such Plugin but found nothing.

I see a few reports of problems with the bbc site and palemoon. I sthis some sort of problem with the linux version?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 19647
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby Moonchild » Wed Sep 27, 2017 11:50 am

That "plugin" is most likely a server-side plugin on the BBC site.

No problem playing the video on Windows, to add a point of reference here.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

User avatar
lightning slinger
Fanatic
Fanatic
Posts: 138
Joined: Mon Jul 27, 2015 5:50 pm
Location: England

Re: Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby lightning slinger » Wed Sep 27, 2017 12:03 pm

That video works OK for me with PM 27.5.0 installed from pminstaller in Xubuntu 16.04 and Arch Linux Xfce with this shown on right click,when playing.
Attachments
Screenshot_2017-09-27_12-55-22.png
Screenshot_2017-09-27_12-55-22.png (7.8 KiB) Viewed 178 times
Last edited by lightning slinger on Wed Sep 27, 2017 12:10 pm, edited 1 time in total.
Arch Linux Xfce x86_64
Xubuntu 16.04 LTS x86_64

User avatar
RJules3
Moongazer
Moongazer
Posts: 13
Joined: Mon Aug 15, 2016 5:17 am
Location: Germany

Re: Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby RJules3 » Wed Sep 27, 2017 12:09 pm

... I sthis some sort of problem with the linux version?


Just installed Pale Moon 27.5.0 manually via the tar-ball on a Devuan Jessie (MATE desktop environment). I don't have a problem playing the referenced video. So I don't think it to be a 'Linux problem'.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 2820
Joined: Mon Oct 03, 2011 10:19 am
Location: Texas, USA

Re: Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby Night Wing » Wed Sep 27, 2017 12:21 pm

That video plays for me as well with no problems.

I'm using 64 bit linux Pale Moon 27.5.0 running in 64 bit linux Mint 18.2 (Sonya) Xfce.
Linux Mint 18.2 (Sonya) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

tooshorttoolong
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon Sep 11, 2017 2:28 pm

Re: Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby tooshorttoolong » Wed Sep 27, 2017 1:37 pm

Here with PM 27.4.2 on Gentoo Linux, the player tells me I need Flash. I have uMatrix and a few other addons but I enabled everything that seemed relevant…

Anyway thanks to the "Watch with MPV" addon (alias "mpv-youtube-dl-binding", installed thanks to the "Moon Tester Tool" addon) I can just click a button to watch it in my favourite player.

User avatar
Terryphi
Fanatic
Fanatic
Posts: 120
Joined: Wed Aug 26, 2015 6:32 am
Location: Wales, UK

Re: Latest version 27.5.0: ContinuousPlayPluginHTML is broken?

Postby Terryphi » Wed Sep 27, 2017 2:12 pm

@tooshorttoolong The BBC site offers the option of a flash player or an HTML5 player. I use the HTML5 player.
Full details at http://www.bbc.co.uk/html5
Linux Mint 18.1 (and 18.2) 64bit MATE. Latest unstable build of Pale Moon.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 6 guests