Warning: Unresponsive script (Yahoo)

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, Indalecio, satrow

User avatar
troypulk
Fanatic
Fanatic
Posts: 198
Joined: Fri Sep 19, 2014 11:53 pm
Location: Washington State, USA

Warning: Unresponsive script (Yahoo)

Postby troypulk » Fri Sep 01, 2017 1:08 am

When I go to https://www.yahoo.com/ I get a script that freezes PM for about 10 sec. it's this one: Script: https://www.yahoo.com/:2662 (it has a different number every time)

It says:
"A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue."

Can someone using Linux reproduce this on 27.4.2?

What are my options, just ignore or something else?

Thanks
SolydX EE x64

Pale Moon 27.4.2 x64

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 2771
Joined: Mon Oct 03, 2011 10:19 am
Location: Texas, USA

Re: Warning: Unresponsive script

Postby Night Wing » Fri Sep 01, 2017 2:27 am

I clicked on your link and there was no problem. No freezing at all. The Yahoo page loaded fast too. I surfed around on the page and no freezing, no lagging, etc. And all the Yahoo buttons worked.

I'm using 64 bit linux Pale Moon 27.4.2 in 64 bit linux Mint 18.2 (Sonya) in the Xfce desktop environment. The only extensions I use in linux Pale Moon are the old NoSquint (not NoSquint Plus) and Adblock Latitude and AL was enabled.
Linux Mint 18.2 (Sonya) Xfce 64-Bit (Default OS) with 64-Bit linux Pale Moon
Windows 7 SP1 64 Bit (Backup OS) with 32-Bit windows Pale Moon

User avatar
troypulk
Fanatic
Fanatic
Posts: 198
Joined: Fri Sep 19, 2014 11:53 pm
Location: Washington State, USA

Re: Warning: Unresponsive script

Postby troypulk » Fri Sep 01, 2017 6:18 am

Thanks,

It happens in FF as well and in PM safe mode.

I'm not sure what it is other than PM 27.4.2, I tried to downgrade to 27.4.1 but the pminstaller 0.2.3 said that it can't be used to install archived versions and typing in 27.4.1 did not work.
SolydX EE x64

Pale Moon 27.4.2 x64

User avatar
lightning slinger
Fanatic
Fanatic
Posts: 135
Joined: Mon Jul 27, 2015 5:50 pm
Location: England

Re: Warning: Unresponsive script

Postby lightning slinger » Fri Sep 01, 2017 8:12 am

No problem here with your link using PM 27.4.2 in Arch Linux Xfce. Tried with uBlockO and uMatrix on and off and no warning appears either way.
Arch Linux Xfce x86_64
Xubuntu 16.04 LTS x86_64

User avatar
troypulk
Fanatic
Fanatic
Posts: 198
Joined: Fri Sep 19, 2014 11:53 pm
Location: Washington State, USA

Re: Warning: Unresponsive script

Postby troypulk » Fri Sep 01, 2017 3:45 pm

It must be something in my system because I tested yahoo in 27.4.1, 27.0.0 and 26.5.0 and they all freeze when going to yahoo.

This is something new that I just noticed in the past week or so and 27.4.2 didn't freeze when I installed it.

I'm using Debian testing so it's probably from there.
SolydX EE x64

Pale Moon 27.4.2 x64

richardrosa
New to the forum
New to the forum
Posts: 1
Joined: Mon Sep 11, 2017 3:39 pm

Re: Warning: Unresponsive script

Postby richardrosa » Mon Sep 11, 2017 3:52 pm

I am experiencing the same issues with Yahoo & P.M.

Attempt to connect to https://www.yahoo.com/

Browser will hang for about 1 minute. CPU usage goes crazy. Then 'unresponsive script' pops up.
I've disabled ALL add-ins. I've even removed the PM Configuration files and started from a clean configuration,
with the same results

This ONLY seems to happen with Yahoo.
This started happening about a week ago. Prior to that, there were no issues connecting.

I am running Pale Moon v27.4.2 64bit using SUSE Linux v42.2 on an AMD 8 core system.

Richard Rosa

Walter Dnes
Lunatic
Lunatic
Posts: 297
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: Warning: Unresponsive script

Postby Walter Dnes » Mon Sep 11, 2017 4:58 pm

richardrosa wrote:I am experiencing the same issues with Yahoo & P.M.

Attempt to connect to https://www.yahoo.com/

Browser will hang for about 1 minute. CPU usage goes crazy.

I ran into a similar issue with a website on Wordpress. Here's how I dealt with it.
  • Make sure that you have Pale Moon set to open to about:blank to avoid confusion
  • Shut down Pale Moon and all internet-connecting apps for a few minutes to allow connections to expire
  • Open Pale Moon. Did you remember to set it to start at anout:blank?
  • Go to the offending web page (Yahoo/whatever)
  • When you get control of Pale Moon back, open a new empty tab
  • In that empty tab go to about:networking; click through the warning.
You should see a large list of 3rd-party trackers/adsites/etc. Copy the names to a text file for further action. These are the offenders, and are candidates for blockage via /etc/hosts or privoxy or whatever. Notes:
  • Be careful not to block the main website.
  • Be careful about blocking sites with "cdn" in their name. These are Content Distribution Networks and are the actual conduit for many major websites.
  • If you block via the hosts file, divert offending sites to 0.0.0.0 not 127.0.0.1. This puts less load on your computer.
  • Another load-reducer is to go into about:config and toggle two preferences to "false" if they aren't already so; media.autoplay.allowscripted and media.autoplay.enabled. This shuts down autoplaying audio/video. The only downside is that you may need to do extra clicks on Youtube or any video sites that you do want to actually play.

User avatar
troypulk
Fanatic
Fanatic
Posts: 198
Joined: Fri Sep 19, 2014 11:53 pm
Location: Washington State, USA

Re: Warning: Unresponsive script

Postby troypulk » Tue Sep 12, 2017 4:01 am

Walter Dnes wrote:Another load-reducer is to go into about:config and toggle two preferences to "false" if they aren't already so; media.autoplay.allowscripted and media.autoplay.enabled.
This doesn't work for the script error.



about:networking
Hostname Port SPDY SSL Active Idle
udc.yahoo.com 443 true true 0 0
sb.scorecardresearch.com 443 false true 0 1
s.yimg.com 443 true true 0 0
localhost 10391 false false 0 0
http://www.yahoo.com 443 true true 1 0
forum.palemoon.org 443 false true 0 0
comet.yahoo.com 443 false true 0 0
video-api.yql.yahoo.com 443 true true 0 0
ucs.query.yahoo.com 443 false true 0 1
bats.video.yahoo.com 443 true true 0 0
s.yimg.com 443 true true 1 0
s1.yimg.com 443 true true 1 0
s2.yimg.com 443 true true 1 0
comet.yahoo.com 443 false true 0 6
swbrack03.vpg.cdn.yimg.com 443 false true 0 1
s3.yimg.com 443 true true 1 0
yqlmailapps.query.yahoo.com 443 true true 1 0
geo.yahoo.com 443 true true 1 0


So which ones need to be blocked?
SolydX EE x64

Pale Moon 27.4.2 x64

Walter Dnes
Lunatic
Lunatic
Posts: 297
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: Warning: Unresponsive script

Postby Walter Dnes » Tue Sep 12, 2017 5:27 pm

troypulk wrote:So which ones need to be blocked?


To start, let's try the following. If it breaks the site, you may have to back off slightly...
  • If you use Yahoo mail, you may have to unblock yqlmailapps.query.yahoo.com
  • If videos don't play, unblock video-api.yql.yahoo.com and possibly swbrack03.vpg.cdn.yimg.com
udc.yahoo.com
sb.scorecardresearch.com
s.yimg.com
comet.yahoo.com
video-api.yql.yahoo.com
ucs.query.yahoo.com
bats.video.yahoo.com
s1.yimg.com
s2.yimg.com
swbrack03.vpg.cdn.yimg.com
s3.yimg.com
yqlmailapps.query.yahoo.com
geo.yahoo.com


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: Bing [Bot], CraigPD and 9 guests