audio is slowed down on twitter videos. Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, Indalecio, satrow

User avatar
breadmoth
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sun Aug 13, 2017 5:57 pm

audio is slowed down on twitter videos.

Postby breadmoth » Mon Aug 14, 2017 2:50 am

Weird issue with Twitter, when playing back video on that site - the audio is 'slow' - as in someone reduced the speed but the video is fine. Happening on Version: 27.4.1 (64-bit) - clearing cache and history does not resolve. No issue on other browsers such as Firefox, Seamonkey.

Walter Dnes
Lunatic
Lunatic
Posts: 297
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: audio is slowed down on twitter videos.  Topic is solved

Postby Walter Dnes » Mon Aug 14, 2017 5:39 am

breadmoth wrote:Weird issue with Twitter, when playing back video on that site - the audio is 'slow' - as in someone reduced the speed but the video is fine. Happening on Version: 27.4.1 (64-bit) - clearing cache and history does not resolve. No issue on other browsers such as Firefox, Seamonkey.

I solved a similar issue on my machine as follows...
Edit ==> Preferences ==> Content
and UNcheck "Enable Media Source Extensions (MSE)"

User avatar
breadmoth
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sun Aug 13, 2017 5:57 pm

Re: audio is slowed down on twitter videos.

Postby breadmoth » Mon Aug 14, 2017 11:45 pm

I'll try that - thx for the heads up!

User avatar
breadmoth
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sun Aug 13, 2017 5:57 pm

Re: audio is slowed down on twitter videos.

Postby breadmoth » Tue Aug 15, 2017 6:49 pm

Disabling MSE now prevents me from watching livestreams on youtube.
Attachments
Screenshot_2017-08-15_13-48-58.png

Walter Dnes
Lunatic
Lunatic
Posts: 297
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: audio is slowed down on twitter videos.

Postby Walter Dnes » Tue Aug 15, 2017 7:51 pm

breadmoth wrote:Disabling MSE now prevents me from watching livestreams on youtube.

What does https://www.youtube.com/html5 look like? I.e. which items show blue or red? Depending on various tweaks, I always have the top 3 enabled (Blue), and optionally, "Media Source Extensions" and "MSE & H.264"

Try it with a bit more granularity, rather than disabling MSE entirely. In my previous answer try checking only the "Enable" box but not the sub-entries...

Video
[X] Enable Media Source Extensions (MSE)
[ ] Enable MSE for MP4
[ ] Enable MSE for WebM video

You can also try combinations of one or both of the 2 subentries enabled.

User avatar
breadmoth
Hobby Astronomer
Hobby Astronomer
Posts: 21
Joined: Sun Aug 13, 2017 5:57 pm

Re: audio is slowed down on twitter videos.

Postby breadmoth » Tue Aug 15, 2017 8:01 pm

Walter Dnes wrote:
breadmoth wrote:Disabling MSE now prevents me from watching livestreams on youtube.

What does https://www.youtube.com/html5 look like? I.e. which items show blue or red? Depending on various tweaks, I always have the top 3 enabled (Blue), and optionally, "Media Source Extensions" and "MSE & H.264"

Try it with a bit more granularity, rather than disabling MSE entirely. In my previous answer try checking only the "Enable" box but not the sub-entries...

Video
[X] Enable Media Source Extensions (MSE)
[ ] Enable MSE for MP4
[ ] Enable MSE for WebM video

You can also try combinations of one or both of the 2 subentries enabled.


This is what I have right now, since I reverted to enabling MSE to watch a live stream.
Attachments
Screenshot_2017-08-15_15-00-51.png

Walter Dnes
Lunatic
Lunatic
Posts: 297
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: audio is slowed down on twitter videos.

Postby Walter Dnes » Wed Aug 16, 2017 12:51 am

A heavy-handed workaround is to set up separate profiles for Youtube and Twitter, and have different settings optimized for the site(s) that the profile accesses. Your "program launcher" or menu bar can start a specific profile using the command palemoon -no-remote -p <profilename>. If you want to launch the profile manager, the command is palemoon -no-remote -p.

I have 20+ profiles for various sites/functions... no, I don't bring them up simultaneously.

User avatar
slp_se
Newbie
Newbie
Posts: 4
Joined: Mon Apr 11, 2016 2:50 pm
Location: Sweden

Re: audio is slowed down on twitter videos.

Postby slp_se » Wed Aug 16, 2017 11:20 am

breadmoth wrote:Weird issue with Twitter, when playing back video on that site - the audio is 'slow' -


Strangely enough, switching user-agents to a more Firefox-y one fixes the horror-movie effects for me.

https://twitter.com/Space_Station/status/897763384082317312

Using User Agent Overrider to go from the default Palemoon/Gecko UA, to say "Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.1" fixes the audio. I just wish I could find an addon that switches UAs automatically on specific sites.

Walter Dnes
Lunatic
Lunatic
Posts: 297
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: audio is slowed down on twitter videos.

Postby Walter Dnes » Wed Aug 16, 2017 4:48 pm

slp_se wrote:Using User Agent Overrider to go from the default Palemoon/Gecko UA, to say "Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.1" fixes the audio. I just wish I could find an addon that switches UAs automatically on specific sites.

I think you can do that in "about:config". Create a new entry general.useragent.override.twitter.com of type "string", and plug in the value you listed there.

User avatar
slp_se
Newbie
Newbie
Posts: 4
Joined: Mon Apr 11, 2016 2:50 pm
Location: Sweden

Re: audio is slowed down on twitter videos.

Postby slp_se » Wed Aug 16, 2017 5:57 pm

Walter Dnes wrote:I think you can do that in "about:config". Create a new entry general.useragent.override.twitter.com of type "string", and plug in the value you listed there.


Hey, that was fantastic! Thanks a lot, that worked just nicely. :clap:

LL25255252
Moonbather
Moonbather
Posts: 70
Joined: Sat Aug 29, 2015 3:44 am

Re: audio is slowed down on twitter videos.

Postby LL25255252 » Wed Sep 13, 2017 9:10 pm

slp_se wrote:Using User Agent Overrider to go from the default Palemoon/Gecko UA, to say "Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.1" fixes the audio.
I just wish I could find an addon that switches UAs automatically on specific sites.

@slp_se, try UAControl addon - https://addons.mozilla.org/en-US/firefox/addon/uacontrol/ - I'm using it for a couple of months with Pale Moon 27.4.2 on Win 7 x64. It works great.

User avatar
slp_se
Newbie
Newbie
Posts: 4
Joined: Mon Apr 11, 2016 2:50 pm
Location: Sweden

Re: audio is slowed down on twitter videos.

Postby slp_se » Thu Sep 14, 2017 11:58 am

LL25255252 wrote:@slp_se, try UAControl addon - https://addons.mozilla.org/en-US/firefox/addon/uacontrol/ - I'm using it for a couple of months with Pale Moon 27.4.2 on Win 7 x64. It works great.


I think I tried that a while back, but it didn't actually work on my Linux rig. I only have a handful of sites that need the old switcheroo, anyway, so I'll just stick them in manually, per Walter Dnes above.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: CraigPD and 10 guests