PM won't start after "successful" update to 27.3.0 Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, Indalecio, satrow

yellowfinch
Moongazer
Moongazer
Posts: 8
Joined: Mon Jan 09, 2017 5:05 pm

PM won't start after "successful" update to 27.3.0

Postby yellowfinch » Thu Jul 06, 2017 1:45 am

I've used pminstaller.sh before (to update from 27.0.3 to 27.2.1), but this time, after what seemed like a normal process, PM won't start at all. Instead, a plain window shows up, with this message:

Code: Select all

Erreur d'analyse XML : entité non définie
Emplacement : chrome://browser/content/browser.xul
Numéro de ligne 1573, Colonne 15 :              <menuitem id="menu_openPermissions"
--------------^

I've searched this forum for "browser.xul" and found one thread from January 2016 that cites a similar message but that instance of PM, while said to be broken, was at least loading and was somewhat useable, so it seems to be a different situation.

What should I do?

I saw in the "Manual installation" instructions that the first step would be to uninstall. Wouldn' that delete the profile as well?

Any clues would be much appreciated.

Walter Dnes
Lunatic
Lunatic
Posts: 267
Joined: Thu Jul 30, 2015 8:29 pm
Location: Vaughan, ON, Canada

Re: PM won't start after "successful" update to 27.3.0

Postby Walter Dnes » Thu Jul 06, 2017 2:22 am

There's a similar thread thread viewtopic.php?t=15504 It involves unstable build but it has the same error message, except in English. The solution to the problem was to disable the language pack. Is the French language pack official?

Uninstalling Pale Moon should not delete the user profile(s). You can have multiple versions installed simultaneously. You do not have to delete the previous version. Since I am the only person using my machine, I prefer to install in my home directory. This does not need root permission.

Code: Select all

mkdir $HOME/pm2730
mv palemoon*.bz2 $HOME/pm2730
cd $HOME/pm2730
tar -xvjf palemoon*.bz2

To start from command line the command is $HOME/pm2730/palemoon/palemoon or if you want to start a specific profile $HOME/pm2730/palemoon/palemoon -no-remote -p profilename with the actual "profilename". The command can also be put into whatever program launcher you use. You can have multiple windows from the same, or different versions running simultaneously, but they must be different profiles.

khronosschoty
Hobby Astronomer
Hobby Astronomer
Posts: 15
Joined: Wed Nov 23, 2016 10:37 am

Re: PM won't start after "successful" update to 27.3.0

Postby khronosschoty » Thu Jul 06, 2017 2:30 am

It was pointed out to me that, "it is a langpack issue".

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 18958
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: PM won't start after "successful" update to 27.3.0  Topic is solved

Postby Moonchild » Thu Jul 06, 2017 2:34 am

It's a language pack issue.

You should have been served an updated language pack a while back (unless, of course, you disable checking for add-on updates, in which case this will remain a risk) that would include the current strings needed. Reinstalling the browser won't help you because your profile is where the language pack lives, so that won't solve your issue.

What you should do is start Pale Moon in safe mode (start with SHIFT held down or from the command-line with -safe-mode) and remove the language pack. Restart normally, then install the latest language pack available, and make sure you enable updates for add-ons in the add-on manager.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.
Image

yellowfinch
Moongazer
Moongazer
Posts: 8
Joined: Mon Jan 09, 2017 5:05 pm

Re: PM won't start after "successful" update to 27.3.0

Postby yellowfinch » Thu Jul 06, 2017 12:02 pm

Thank you very much! Removing the language pack from safe mode solved it. I will probably continue using it in English from now on.

For the record:
    Yes, it was an official language pack.
    Yes, I had disabled add-on updates. When I see an option that I think will help prevent unpleasant surprises, I use it.
By the way: I would mark the thread as SOLVED, but I don't see the tick mark mentioned in t=10762.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: FranklinDM and 6 guests