UXP support for Linux (GTK3 & Ubuntu)

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, Indalecio, satrow

User avatar
gracious1
Lunatic
Lunatic
Posts: 385
Joined: Sun May 15, 2016 5:00 am
Location: gloomy upstate NY
Contact:

UXP support for Linux (GTK3 & Ubuntu)

Postby gracious1 » Fri Jun 23, 2017 12:03 am

According to Moonchild's announcement, Basilisk will utilize GTK3. Does this mean that Basilisk and the new UXP platform will not be compatible with Ubuntu 14.04 (running default Unity desktop environment)? What about 16.04 (again, running default Unity desktop environment)? (Sorry if this is a stoopid question).
ImageBe not the first by whom the new are tried, nor yet the last to lay the old aside. — Alexander Pope

User avatar
adesh
Fanatic
Fanatic
Posts: 221
Joined: Tue Jun 06, 2017 7:38 am

Re: UXP support for Linux (GTK3 & Ubuntu)

Postby adesh » Fri Jun 23, 2017 4:58 pm

Most Linux distributions have GTK3 installed by default since there are a lot of applications which will not work without it. Whether Basilisk will function properly depends on the GTK3 version the team is targeting and the version of GTK3 installed on your system. If the two versions are not compatible, you might face issues with Basilisk.
Having said that, most likely it will run just fine on your Ubuntu systems. :)

stevepusser
Fanatic
Fanatic
Posts: 234
Joined: Sat Aug 01, 2015 6:33 pm
Location: California

Re: UXP support for Linux (GTK3 & Ubuntu)

Postby stevepusser » Fri Jun 23, 2017 10:20 pm

Trusty has GTK+3 3.10.8, 16.04 Xenial has 3.18.

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1293
Joined: Mon May 20, 2013 6:19 pm
Location: Earth
Contact:

Re: UXP support for Linux (GTK3 & Ubuntu)

Postby trava90 » Sat Jun 24, 2017 1:47 am

The build system for Basilisk requires at least GTK 3.4. The version we will actually build against is yet to be determined.

stevepusser
Fanatic
Fanatic
Posts: 234
Joined: Sat Aug 01, 2015 6:33 pm
Location: California

Re: UXP support for Linux (GTK3 & Ubuntu)

Postby stevepusser » Thu Jun 29, 2017 5:51 pm

OK, good. That means that builds from source should still be possible if GTK+3 is at least 3.4--the aging Debian 7 just squeaks in with 3.4.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: Makberto and 4 guests