Default File manager to "open containing folder" Topic is solved

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Laurentius
Newbie
Newbie
Posts: 4
Joined: Sat, 15 Apr 2017, 15:23

Default File manager to "open containing folder"  Topic is solved

Postby Laurentius » Sat, 15 Apr 2017, 15:42

Hello.
I would like to know how to tell Pale moon which file manager to use when clicking "open containing folder" on the downloads dialog.
I usually use the XFCE D.E. which has Thunar as default file manager. For some needs i usually have another file manager installed like Caja, Nemo, or Nautilus.

I want pale moon to use Thunar, my DE default FM to "open containing folder". Instead, pale moon (and firefox) always use any of the other installed FMs. I always find that thunar is the last choice (only when there is no other FM installed) to the "open containing folder" action.
How can i cofigure that?.

I have the same issue with firefox and couldn't solve it yet, after trying lot of things like editing /usr/sare/applications/mimeinfo.cache (the inode/directory line).
No luck yet with the mozilla support.

Thanks.
Linux Mint 17.3, 18.1 XFCE 4.12.

PS. Please tell me if i should move this post to another forum. Or just do it. i'll then look for it.

User avatar
0strodamus
Moon lover
Moon lover
Posts: 91
Joined: Wed, 19 Nov 2014, 19:48
Location: US

Re: Default File manager to "open containing folder"

Postby 0strodamus » Sun, 16 Apr 2017, 23:54

On my system, Pale Moon is using ~/.local/share/applications/exo-file-manager.desktop to launch Thunar. What launches if you run "exo-open --launch FileManager" from xfce4-terminal? I could be wrong, but I don't think the problem you're experiencing has anything to do with Pale Moon.
archlinux | OpenRC | TOMOYO Linux | Xfce

Nihil Verum Nisi Mors

Laurentius
Newbie
Newbie
Posts: 4
Joined: Sat, 15 Apr 2017, 15:23

Re: Default File manager to "open containing folder"

Postby Laurentius » Tue, 18 Apr 2017, 00:15

If i run "exo-open --launch FileManager" from xfce4-terminal, Thunar launches.
The file exo-file-manager.desktop wasn't al my ~/.local/share/applications/ folder. I found it at /usr/share/applications/. I copied it to ~/.local/share/applications/. Then logged out and in again, but Pale moon (and Firefox) still opens another file manager (nemo) from the Downloads dialog.

I didn't mean to say it was a pale-moon problem or something like that. I think it more related to the O.S.
I just want to anderstand how it Pale Moon (and Firefox) or the O.S. works to be able to configure wihich file-manager it calls from the Downloads dialog.
May be i posted my question in a wrong place of the forum.

Thank you for you answer.

User avatar
troypulk
Fanatic
Fanatic
Posts: 227
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default File manager to "open containing folder"

Postby troypulk » Tue, 18 Apr 2017, 03:59

In PM go to Preferences and click on applications and you can chose what file manger to use with what app you want.

This is how PM chooses.
SolydX EE (64-bit)

Pale Moon 27.9.0 (64-bit)

Toa-Nuva
Fanatic
Fanatic
Posts: 173
Joined: Thu, 04 Jun 2015, 18:12

Re: Default File manager to "open containing folder"

Postby Toa-Nuva » Tue, 18 Apr 2017, 07:45

I had a similar problem recently after setting up a new Linux installation. The fix was rather simple, though: I just opened Xfce's "preferred applications" menu; in the "Utilities" tab you can choose your preferred file manager. In my case, Thunar was already selected, but I had to switch to a different file manager and then switch back to Thunar... And that fixed it, for some reason.

Off-topic:
Actually, in my case, I don't even have any file manager other than Thunar installed in the first place. But for some reason, Pale Moon opened Filelight instead, which is a disk usage analyzer tool. In the "preferred applications" menu, Thunar was the only available choice, and I actually had to add Filelight to the list so I could switch away from and back to Thunar.

User avatar
0strodamus
Moon lover
Moon lover
Posts: 91
Joined: Wed, 19 Nov 2014, 19:48
Location: US

Re: Default File manager to "open containing folder"

Postby 0strodamus » Wed, 19 Apr 2017, 02:37

Laurentius wrote:Thank you for you answer.

You're welcome. Sorry that what I posted wasn't any help and I hope one of the other suggestions you've received will work.
archlinux | OpenRC | TOMOYO Linux | Xfce

Nihil Verum Nisi Mors

Laurentius
Newbie
Newbie
Posts: 4
Joined: Sat, 15 Apr 2017, 15:23

Re: Default File manager to "open containing folder"

Postby Laurentius » Wed, 19 Apr 2017, 02:40

sadly, ythe workaround of Toa-Nuva didn't work for me.

Neither I could find any line related to the file manager at PM Preferences / Applications. Which one could it be troypulk?

User avatar
troypulk
Fanatic
Fanatic
Posts: 227
Joined: Fri, 19 Sep 2014, 23:53
Location: Washington State, USA

Re: Default File manager to "open containing folder"

Postby troypulk » Wed, 19 Apr 2017, 04:05

I would like to know how to tell Pale moon which file manager to use when clicking "open containing folder" on the downloads dialog.


In the down load dialog window choose "open with" then click on the little window and choose other.

After this navigate to your /usr/bin/ folder and choose thunar then ok, this should use thunar to open the file/folder you want.
SolydX EE (64-bit)

Pale Moon 27.9.0 (64-bit)

Laurentius
Newbie
Newbie
Posts: 4
Joined: Sat, 15 Apr 2017, 15:23

Re: Default File manager to "open containing folder" (SOLVED)

Postby Laurentius » Wed, 19 Apr 2017, 22:40

Well. I think i found it, finally.
This did the trick, both for PM and FF:

Code: Select all

xdg-mime default Thunar-folder-handler.desktop inode/directory


as suggested by th.sigit here: https://askubuntu.com/questions/73979/s ... le-manager

Thank you!


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 7 guests