https://gab.ai doesn't render

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Uppity
Moonbather
Moonbather
Posts: 54
Joined: Wed Apr 23, 2014 8:50 pm
Location: ussa

https://gab.ai doesn't render

Postby Uppity » Sun Jan 01, 2017 11:56 pm

gab.ai is an alternative to twitter censorship.

It doesn't render in Pale Moon nor Firefox.
It does render in Brave, but Brave is a long way from prime time,
I don't recall what it does in other browsers.

I'm guessing this is a site specific problem, rather than a browser problem.

There were a few sites that failed to render, a couple of months ago.
Gab is now the only site that fails to render.
Windows 8 is gone. Linux Mint 17.3, Cinnamon, Pale Moon 27.0.3 (x64)
Kernel: 3.19.0-32 (generic)
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Intel Centrino Wireless-N 2230.

User avatar
helloimustbegoing
Board Warrior
Board Warrior
Posts: 1660
Joined: Thu Jun 28, 2012 1:20 am

Re: https://gab.ai doesn't render

Postby helloimustbegoing » Mon Jan 02, 2017 1:00 am

It seems to render just fine for me. I'm on Pale Moon 27.03 (also renders fine in FF). Is your signature up to date? It says you're on Pale Moon 25.5.0.

Uppity
Moonbather
Moonbather
Posts: 54
Joined: Wed Apr 23, 2014 8:50 pm
Location: ussa

Re: https://gab.ai doesn't render

Postby Uppity » Mon Jan 02, 2017 5:58 am

Hello, helloimustbegoing. Thanks for the input.

The signature was dated, but now fixed.
Everything is updated.

I also checked with Chromium and it renders fine, but, like Brave, no extensions are installed.

There must be at least one extension causing the problem.

uBlock Origin and NoScript show no indication of blocking anything.

Disconnect and Twitter Disconnect may be likely culprits, so I guess I have some testing to do.

I think I only have around 40 extensions...
Windows 8 is gone. Linux Mint 17.3, Cinnamon, Pale Moon 27.0.3 (x64)
Kernel: 3.19.0-32 (generic)
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Intel Centrino Wireless-N 2230.

Uppity
Moonbather
Moonbather
Posts: 54
Joined: Wed Apr 23, 2014 8:50 pm
Location: ussa

Re: https://gab.ai doesn't render

Postby Uppity » Mon Jan 02, 2017 6:40 am

Tested on Gab.ai

I tested these extensions, to no avail:

Disconnect
Element Hiding Helper for Adblock Plus
Google Privacy
Google Search Link Fix
Power Twitter
Twitter Disconnect

I changed compatibility mode from Firefox to Gecko.
This rendered the top line options and Search...
But, nothing else.

Changing compatibility mode to Native returned another white page.

It will have to wait, for more testing.
Windows 8 is gone. Linux Mint 17.3, Cinnamon, Pale Moon 27.0.3 (x64)
Kernel: 3.19.0-32 (generic)
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Intel Centrino Wireless-N 2230.

Uppity
Moonbather
Moonbather
Posts: 54
Joined: Wed Apr 23, 2014 8:50 pm
Location: ussa

Re: https://gab.ai doesn't render

Postby Uppity » Mon Jan 02, 2017 11:38 pm

All extensions disabled, then gab.ai reloaded.

No change.

Firfefox Compatibility mode and Native mode yield a white page.
Again, Gecko mode renders the top line options and Search...
But, nothing else.

Entering gab.ai in about:config yields 2 lines:
capability.policy.maonoscript.sites
extensions.nosquint.sites

I wouldn't know what to do in either of those entries.

I'm at a loss.
Here are all of my extension, if it might suggest something...

Code: Select all

37 Extensions

ChromeEdit Plus
Date Picker/Calendar (Pseudo-Static)
Disconnect
Download Manager Tweak
Download Status Bar (No longer works after 26.5)
Download Helper
Easy Youtube Video Downloader Express
Element Hiding Helper for Adblock Plus
Extended Status Bar
FEBE
FoxNotes
Google Privacy
Google Search Link Fix
Hide Add-on Bar Close Button
History Submenus II
Image Zoom
ImageHost Grabber
Map This
NoScript
NoSquint
PDF Viewer
Power Twitter
QuickNote
ReminderFox
Restartless Restart
Screenshoter Fixed
Shortly URL Shortner
Sun Cult
Tab Mix Plus
TinEye Reverse Image Search
TinyURL Generator
Twitter Disconnect
uBlock Origin
URL Shrink Easy
User Agent Overrider
User Agent Switcher
Video Downloader Professional
Windows 8 is gone. Linux Mint 17.3, Cinnamon, Pale Moon 27.0.3 (x64)
Kernel: 3.19.0-32 (generic)
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Intel Centrino Wireless-N 2230.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20061
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: https://gab.ai doesn't render

Postby Moonchild » Sat Jan 07, 2017 1:17 pm

I've just got an account approved with them, looked around the entire site and everything loads up perfectly. Not sure what to suggest, other than disabling extensions to see if any of them interfere with the site's rendering.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

krberos
New to the forum
New to the forum
Posts: 1
Joined: Sun Feb 26, 2017 4:56 am

Re: https://gab.ai doesn't render

Postby krberos » Sun Feb 26, 2017 5:01 am

Hello I had the same problem. Gab rendered fine till I installed Noscript... then I have weir rendering.

Allowing gab.ai didn't work, disabling Noscript didn't work. Uninstalling it, worked like a charm.

Uppity
Moonbather
Moonbather
Posts: 54
Joined: Wed Apr 23, 2014 8:50 pm
Location: ussa

Re: https://gab.ai doesn't render

Postby Uppity » Sun Feb 26, 2017 10:28 am

Moonchild wrote:I've just got an account approved with them, looked around the entire site and everything loads up perfectly. Not sure what to suggest, other than disabling extensions to see if any of them interfere with the site's rendering.
Hi, Moonchild.

Some issues got in the way and put this on a back burner.
Maybe I can get back to it, soon.
Or maybe Gab will improve their code.

Thanks.
Windows 8 is gone. Linux Mint 17.3, Cinnamon, Pale Moon 27.0.3 (x64)
Kernel: 3.19.0-32 (generic)
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Intel Centrino Wireless-N 2230.

Uppity
Moonbather
Moonbather
Posts: 54
Joined: Wed Apr 23, 2014 8:50 pm
Location: ussa

Re: https://gab.ai doesn't render

Postby Uppity » Sun Feb 26, 2017 10:29 am

krberos wrote:Hello I had the same problem. Gab rendered fine till I installed Noscript... then I have weir rendering.

Allowing gab.ai didn't work, disabling Noscript didn't work. Uninstalling it, worked like a charm.
Hi, krberos.

I can't tell you how encouraging that is...

Thanks.
Windows 8 is gone. Linux Mint 17.3, Cinnamon, Pale Moon 27.0.3 (x64)
Kernel: 3.19.0-32 (generic)
Dell Inspiron 15z Inspiron 5523, 6 GB Memory, Intel® Core™ i3-3217U, Intel Centrino Wireless-N 2230.


Return to “Pale Moon for Linux”

Who is online

Users browsing this forum: No registered users and 5 guests