Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
bernardm
New to the forum
New to the forum
Posts: 1
Joined: 2019-07-31, 12:53

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Unread post by bernardm » 2019-07-31, 12:59

I used this link
https://download.opensuse.org/repositor ... _amd64.deb
to dowload this morning to install on Ubuntu 18.04 LTS, but on opening the DEB file with GDEBI, installation failed because the DEB requires libc6>=2.29
This is not available on Ubuntu until 19.04

User avatar
martywd
Fanatic
Fanatic
Posts: 119
Joined: 2014-04-16, 14:36
Location: TX

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Unread post by martywd » 2019-07-31, 14:52

bernardm wrote:
2019-07-31, 12:59
I used this link
https://download.opensuse.org/repositor ... _amd64.deb
to dowload this morning to install on Ubuntu 18.04 LTS, but on opening the DEB file with GDEBI, installation failed because the DEB requires libc6>=2.29
This is not available on Ubuntu until 19.04
I just downloaded the package you linked and ran 'dpkg -I' (Capital 'I', _not_ lowercase 'l'!) command and got this output:

Code: Select all

$ dpkg -I palemoon_28.6.1+repack-1_amd64.deb 
 new Debian package, version 2.0.
 size 41580824 bytes: control archive=2872 bytes.
    1539 bytes,    23 lines      control              
    4075 bytes,    56 lines      md5sums              
     324 bytes,    11 lines   *  postinst             #!/bin/sh
     211 bytes,     8 lines   *  prerm                #!/bin/sh
 Package: palemoon
 Version: 28.6.1+repack-1
 Architecture: amd64
 Bugs: mailto: <maintainer@mepiscommunity.org>
 Maintainer: Steven Pusser <stevep@mxlinux.org>
 Installed-Size: 114636
 Depends: libasound2 (>= 1.0.16), libc6 (>= 2.27), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.12), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.30.0), libgtk2.0-0 (>= 2.24.0), libpango-1.0-0 (>= 1.14.0), libstdc++6 (>= 5.2), libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxext6, libxrender1, libxt6, libavcodec54 | libavcodec-extra54 | libavcodec55 | libavcodec-extra55 | libavcodec56 | libavcodec-extra56 | libavcodec57 | libavcodec-extra57 | libavcodec58 | libavcodec-extra58 | libavcodec-ffmpeg56 | libavcodec-ffmpeg-extra56
 Conflicts: palemoon-nonsse2
 Replaces: palemoon-nonsse2
 Provides: gnome-www-browser, www-browser, x-www-browser
 Section: web
 Priority: optional
 Homepage: http://www.palemoon.org/
 Description: Firefox-based, efficient and easy to use web browser
  Pale Moon offers selected features and optimizations to maximize
  the browser's speed, stability and user experience, while maintaining
  compatibility with the thousands of Firefox extensions you have come
  to love and rely on.
  .
  Pale Moon requires a processor that supports the SSE2 instruction set.
  Run "/proc/cpuinfo" in a terminal, and look for sse2 in the flags to ensure
  that your processor supports it.
 Original-Maintainer: Marian Kadanka <marian.kadanka@openmailbox.org>
libc6 (>= 2.27) <== From the out put of the text above the dependency of that package for libc6 is equal to or greater than 2.27, and not as you typed 'libc6>=2.29'.

Hmmmmmm? I think you should try again.


.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Unread post by stevepusser » 2019-08-02, 19:33

My best guess is that you accidentally downloaded the deb for a higher version of Ubuntu, which is easy to do with the tricky way the OBS makes the list. Try again and make sure you're getting the right version for 18.04.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Unread post by stevepusser » 2019-08-02, 19:38

First Debian Unstable, and now Debian Testing builds are failing as they updated to the latest dh-strip-nondeterminism:

Code: Select all

dh_strip_nondeterminism: debian/palemoon/usr/lib/palemoon/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi: Reading ZIP archive failed: format error: bad signature: 0x49605b30 at offset 3080 in file debian/palemoon/usr/lib/palemoon/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi 
I can add an override so that file is ignored, but I wonder if it does indeed have a bad signature, and fixing that would be the better way to handle it. The other possibility would be a bug in dh-strip-nondeterminism.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: Ubuntu 16.04, 16.10, 17.04, 18.04 Debian 8, 9 Pale Moon repositories

Unread post by stevepusser » 2019-08-03, 00:49

I pushed the update with the override through to fix the builds on Debian Sid and Testing. If you aren't running those, and have very limited bandwidth, you're safe in holding off the update for now.

Post Reply