Page 14 of 18

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-04-27, 19:33
by inops
Thanks for the great work, Steve! :D

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-05-04, 01:06
by stevepusser
I spoke too soon..I assumed that it would build, based on the success for Debian Buster, but it's failing with some new compiler error. :thumbdown: So 18.04 users will have to use the rebundled binary version in the repo instead.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-05-21, 20:29
by stevepusser
Updating to 27.9.2. Something has rolled into Debian Buster that is now breaking the builds there, the rest seem OK:

Code: Select all

[ 1162s] make[9]: Entering directory '/usr/src/packages/BUILD/obj-i686-pc-linux-gnu/intl/icu/target/layoutex'
[ 1162s] make[9]: *** No rule to make target 'ParagraphLayout.o', needed by '../lib/libiculx.so.58.2'.  Stop.
[ 1162s] make[9]: Leaving directory '/usr/src/packages/BUILD/obj-i686-pc-linux-gnu/intl/icu/target/layoutex'
[ 1162s] Makefile:147: recipe for target 'all-recursive' failed
[ 1162s] make[8]: *** [all-recursive] Error 2
[ 1162s] make[8]: Leaving directory '/usr/src/packages/BUILD/obj-i686-pc-linux-gnu/intl/icu/target'
[ 1162s] Makefile:59: recipe for target 'buildicu' failed
[ 1162s] make[7]: *** [buildicu] Error 2
Edit: the Arch AUR build runs this command before the build:

Code: Select all

 sed -i 's#xlocale#locale#' Pale-Moon/intl/icu/source/i18n/digitlst.cpp
Don't exactly what it inserts, but I can run it and then make a patch from the difference, then see what happens for the Buster build.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-06-18, 19:49
by stevepusser
The 27.9.3 builds are getting an update that pulls in fonts-symbola to solve issues with sites that use emoji fonts as icons, notably Github. The repo will also update fonts-symbola to 2.60 if you have an older version, in order to support the 9.0 emoji standards.

Re: Ubuntu 16.0.4, 15.10, 15.04, 14.04, Debian 8 Pale Moon repositories

Posted: 2018-07-10, 05:34
by C1xLb
stevepusser wrote:Just added firejail 0.9.4.10 and firetools 0.9.4.6 to the repository; firejail's default palemoon.profile is patched to hopefully work with this build of Pale Moon.

There is no firejail package for Debian 7 (Wheezy) amd64, since the build fails with the hardening flags enabled in the rules file. If anyone really needs that, I could build a version with the hardening flags turned off, with the understanding that could be less secure.
Hi Steve, I'm now running Debian 9 and using your excellent repo, thank you! One thing I've noticed though, I've installed firejail from the backports repo but apt still wants to upgrade to your version. When I run

Code: Select all

apt search firejail
this is what I get...

Code: Select all

Sorting... Done
Full Text Search... Done
firejail/unknown 1:0.9.44.10-1 amd64 [upgradable from: 0.9.54-1~bpo9+1]
I'm wondering if this isn't happening because you're version numbering starts with 1:0 and not 0.9 as per the backported version? What do you think?

Re: Ubuntu 16.0.4, 15.10, 15.04, 14.04, Debian 8 Pale Moon repositories

Posted: 2018-07-10, 23:02
by martywd
C1xLb wrote:...
I'm wondering if this isn't happening because you're version numbering starts with 1:0 and not 0.9 as per the backported version? What do you think?
@C1xLb

If/when/until Steve fixes this issue... Here's my workaround to Steve's firejail version issue that works for me. I added a file to directory: /etc/apt/preferences.d/ named 'palemoon.pref' (you can name it anything you like as long as it has the .pref extension!) with contents:

Code: Select all

Package: firejail gtk2-engines-oxygen:i386 firetools
Pin: origin "download.opensuse.org"
Pin-Priority: 50
'man apt_preferences ==> https://linux.die.net/man/5/apt_preferences

Since the 'Pin-Priority' in the code shown above is set to a very low: '50', any other firejail package you install should take precedent over the 'firejail' pkg available from Steve's repo

BTW, I'm running 'firejail 0.9.54-1' in Linux Mint 19 MATE 64-bit, but this most likely will work for you in Debian as well.

.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-07-11, 06:36
by C1xLb
Perfect, thank you, that worked first time!

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-07-11, 17:32
by stevepusser
Thanks for catching that..I'll update firejail.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-07-18, 18:15
by stevepusser
Various PM packages updated to 27.9.4 in the repo (standard, nonsse2, and binaryrepack).

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-15, 20:58
by stevepusser
Pulling the 27.9.4 binary repackage and non-sse2 versions in preparation for the upcoming 28.0.0 release. Also removed any gcc-4.9 packages, since 28 can build on gcc-4.9 through 7, so all the supported distros can handle that. 28 doesn't support non-sse2 builds any longer, though. Building 28 in the repo now, but will wait for the official release statement to publish the packages.

I also dropped Debian 7 and Ubuntu 14.04 repositories, since they are end-of-life and don't have the minimum required gcc versions anyway.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-16, 16:19
by sspencerwire
Steven Pusser, I have a need for Palemoon on a number of 18.04 machines. Is there some way that I can help with the problems you are running into compiling the repository package? Thanks for what you do.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-16, 17:31
by stevepusser
sspencerwire wrote:Steven Pusser, I have a need for Palemoon on a number of 18.04 machines. Is there some way that I can help with the problems you are running into compiling the repository package? Thanks for what you do.
The build problems were solved with the 28.0.0 release. :D https://build.opensuse.org/package/show ... r/palemoon

I just flipped on the publication switch for those builds, so they are now visible as upgrades in the repository. Enjoy the new release!

Packaging technical note: I have the build process set to build with gcc-7 instead the default gcc-8 on Debian testing and any Ubuntu 18.10 platform, since gcc-8 support is still in the experimental stage. I've been told that 28.1.0 should have solid gcc-8 support, so will remove that code for that next release.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-16, 21:33
by sspencerwire
Thanks very much for your hard work!!

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-17, 00:35
by martywd
.
@stevepusser

Problem installing your PM 28.0.0 deb on Linux Mint 19 MATE 64-bit ==> (Ubuntu 18.04 variant). When I run 'apt upgrade' I get the following error:

Code: Select all

root@phobos:~# apt list --upgradable -a
Listing... Done
palemoon/unknown 28.0.0~repack-1 amd64 [upgradable from: 27.9.4~binaryrepack-1]
palemoon/now 27.9.4~binaryrepack-1 amd64 [installed,upgradable to: 28.0.0~repack-1]

root@phobos:~# apt upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavcodec-extra57 : Conflicts: libavcodec57 but 7:3.4.2-2 is to be installed
E: Broken packages

root@phobos:~# 
The package, libavcodec-extra57, is installed by default in Linux Mint. If I try to install 'libavcodec57'

Code: Select all

root@phobos:~# apt install libavcodec57
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libhal1-flash libunshield0 unshield vlc vlc-l10n vlc-plugin-notify
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  libavcodec-extra libavcodec-extra57 mint-meta-codecs
The following NEW packages will be installed:
  libavcodec57
0 upgraded, 1 newly installed, 3 to remove and 1 not upgraded.
Need to get 4,589 kB of archives.
After this operation, 89.1 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

root@phobos:~#
The 'mint-meta-codecs' deb is kinda important. Don't want to be removing that deb!

Code: Select all

root@phobos:~# aptitude show mint-meta-codecs 
Package: mint-meta-codecs                
Version: 2018.06.08
State: installed
Automatically installed: no
Priority: optional
Section: admin
Maintainer: Clement Lefebvre <root@linuxmint.com>
Architecture: all
Uncompressed Size: 13.3 k
Depends: adobe-flashplugin, cabextract, chromium-codecs-ffmpeg-extra, gstreamer1.0-libav,
         gstreamer1.0-plugins-bad, gstreamer1.0-plugins-ugly, gstreamer1.0-vaapi,
         libavcodec-extra, libdvdcss2, libdvdnav4, libdvdread4, libhal1-flash, unrar, unshield,
         vlc, vlc-l10n, vlc-plugin-notify
Description: All the packages required for multimedia support in Linux Mint.
 All the packages required for multimedia support in Linux Mint.

root@phobos:~# 
.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-17, 01:12
by stevepusser
I guess Mint went their own way and made that extra version essential. I'll add the "extra" versions as alternative dependencies...should be ready in an hour or so. You can check on the progress of the "-2" revision builds here: https://build.opensuse.org/package/show ... r/palemoon

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-17, 02:53
by martywd
stevepusser wrote:... I'll add the "extra" versions as alternative dependencies...should be ready in an hour or so. You can check on the progress of the "-2" revision builds here: https://build.opensuse.org/package/show ... r/palemoon
Yup, '28.0.0~repack-2' (64-bit) installs without any issues. Much, much better now. Thank you, @stevepusser !

.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-17, 12:54
by lazyest
stevepusser wrote:Pulling the 27.9.4 binary repackage and non-sse2 versions in preparation for the upcoming 28.0.0 release. Also removed any gcc-4.9 packages, since 28 can build on gcc-4.9 through 7, so all the supported distros can handle that. 28 doesn't support non-sse2 builds any longer, though. Building 28 in the repo now, but will wait for the official release statement to publish the packages.

I also dropped Debian 7 and Ubuntu 14.04 repositories, since they are end-of-life and don't have the minimum required gcc versions anyway.
:( rip my desktop

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-18, 13:57
by gracious1
stevepusser wrote:I also dropped Debian 7 and Ubuntu 14.04 repositories, since they are end-of-life and don't have the minimum required gcc versions anyway.
Ubuntu 14.04.5 end of life is April 2019, which is over half a year away.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-18, 18:33
by stevepusser
gracious1 wrote:
stevepusser wrote:I also dropped Debian 7 and Ubuntu 14.04 repositories, since they are end-of-life and don't have the minimum required gcc versions anyway.
Ubuntu 14.04.5 end of life is April 2019, which is over half a year away.
Whoops, didn't know that...but the requirement for at least gcc-4.9 prevented any builds anyway. 14.04 has gcc-4.8.

I also just updated the packages to the "-3" release to make them compatible with Ubuntu 16.04 and derivatives, since that release used a different name for libavcodec.

Re: Ubuntu 14.04, 16.04, 16.10, 17.04, Debian 7, 8, 9 Pale Moon repositories

Posted: 2018-08-18, 18:34
by Aube Bleue
gracious1 wrote:Ubuntu 14.04.5 end of life is April 2019, which is over half a year away.
That's correct. Ubuntu 14.04 LTS is still alive! I have some people on it -- and won't get to them until next year to upgrade their system, so they will be running an unpatched Pale Moon. They solely rely on the update manager and the repository you kindly provide, Steven Pusser.
stevepusser wrote:and don't have the minimum required gcc versions anyway.
Is there a way you could work around that?